Upgrade to 1.0.6-4.

PR:		ports/24356
Submitted by:	KATO Tsuguru
This commit is contained in:
Vanilla I. Shu 2001-01-15 21:34:59 +00:00
parent 3fb1e7c462
commit d8acc37d1d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=37228
15 changed files with 225 additions and 107 deletions

View File

@ -6,27 +6,55 @@
#
PORTNAME= icewm
PORTVERSION= 1.0.4
PORTREVISION= 1
PORTVERSION= 1.0.6
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.physik.TU-Berlin.DE/~ibex/ports/distfiles/
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
EXTRACT_SUFX= .src.tar.gz
DISTNAME= ${PORTNAME}-${PORTVERSION}-4
MAINTAINER= nakai@FreeBSD.org
.if defined(GNOME)
LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
WANT_GNOME= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_AUTOCONF= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-i18n --enable-nls \
--with-cfgdir=${PREFIX}/share/icewm \
--with-libdir=${PREFIX}/share/icewm
.include <bsd.port.pre.mk>
.if defined(HAVE_GNOME)
USE_GNOME= yes
CONFIGURE_ARGS+= --with-imlib --without-xpm --with-gnome-menus
INSTALL_TARGET= install install-gnome
PLIST_SUB+= GNOME=""
.else
USE_XPM= yes
CONFIGURE_ARGS+= --without-imlib --with-xpm --without-gnome-menus
PLIST_SUB+= GNOME="@comment "
.endif
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_IMLIB= yes
CONFIGURE_ARGS= --enable-i18n --with-imlib
.if defined(NOPORTDOCS)
PLIST_SUB+= NODOCS="@comment "
.else
PLIST_SUB+= NODOCS=""
.endif
post-install:
${INSTALL_DATA} ${FILESDIR}/bsd-daemon.xpm ${PREFIX}/share/icewm/taskbar
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/icewm
.for file in CHANGES FAQ INSTALL README TODO
${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/icewm
.endfor
${INSTALL_DATA} ${WRKSRC}/doc/*.html ${PREFIX}/share/doc/icewm
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1 +1 @@
MD5 (icewm-1.0.4.src.tar.gz) = 31d6fd8b94fd1becab0de15d4a8e4eb4
MD5 (icewm-1.0.6-4.tar.bz2) = 9231eca07f8aa39b06f3a94e400676e4

View File

@ -1,12 +1,11 @@
--- Makefile.orig Sat May 1 23:20:32 1999
+++ Makefile Sun May 16 09:33:07 1999
@@ -12,8 +12,7 @@
GNOMEFILES = src/icewm-gnome
--- Makefile.in.orig Mon Jan 15 06:49:38 2001
+++ Makefile.in Mon Jan 15 23:07:09 2001
@@ -14,7 +14,7 @@
GUIEVENTSFILES = src/icesound
GNOMEFILES = lib/IceWM.desktop
all:
- cd src ; $(MAKE) LIBDIR=$(LIBDIR) ETCDIR=$(ETCDIR)
- cd doc ; $(MAKE)
+ cd src ; $(MAKE) LIBDIR=$(LIBDIR) ETCDIR=$(ETCDIR) PREFIX=$(PREFIX)
-WMPROPDIR = $(shell gnome-config --datadir)/gnome/wm-properties/
+WMPROPDIR = $(shell gnome-config --datadir)/wm-properties/
docs:
cd doc ; $(MAKE)
all: @TARGETS@
install: @TARGETS_INSTALL@

View File

@ -1,12 +1,7 @@
--- install.in.orig Mon Jun 7 20:07:12 1999
+++ install.in Mon Jun 7 20:08:10 1999
@@ -3,11 +3,11 @@
PREFIX = @prefix@
BINDIR = @bindir@
-LIBDIR = @libdir@/X11/icewm
+LIBDIR = @prefix@/share/icewm
ETCDIR = @sysconfdir@
--- install.in.orig Mon Jan 15 06:49:39 2001
+++ install.in Mon Jan 15 22:18:04 2001
@@ -13,7 +13,7 @@
DOCDIR = @docdir@
INSTALL = @INSTALL@
-INSTALLDIR = @INSTALL@ -m 755 -d

View File

@ -1,11 +0,0 @@
--- icewm.spec.in.orig Wed Mar 17 00:12:01 1999
+++ icewm.spec.in Wed Mar 17 00:12:22 1999
@@ -36,7 +36,7 @@
%files
%defattr(-,root,root)
%doc README COPYING CHANGES TODO BUGS icewm.lsm FAQ doc/*.html doc/icewm.sgml
-%{prefix}/lib/X11/icewm/
+%{prefix}/share/icewm/
%{prefix}/bin/icewm
%{prefix}/bin/icewmhint
%{prefix}/bin/icewmbg

View File

@ -1,6 +1,19 @@
--- src/wmtaskbar.cc.orig Wed Dec 1 16:46:05 1999
+++ src/wmtaskbar.cc Wed Dec 1 16:46:15 1999
@@ -72,9 +72,9 @@
--- src/wmtaskbar.cc.orig Mon Jan 15 06:49:41 2001
+++ src/wmtaskbar.cc Mon Jan 15 22:18:04 2001
@@ -47,6 +47,12 @@
YPixmap *windowsPixmap = 0;
YPixmap *taskbackPixmap = 0;
+#ifdef __FreeBSD__
+#define APMDEV "/dev/apm"
+#else
+#define APMDEV "/proc/apm"
+#endif
+
static void initPixmaps() {
static const char *home = getenv("HOME");
const char *base = 0;
@@ -74,9 +80,9 @@
/** Use Linux 2.0 Penguin as start button */
#ifndef START_PIXMAP
@ -12,15 +25,12 @@
//#define START_PIXMAP "start.xpm"
//#define START_PIXMAP "xfree86os2.xpm"
#endif
@@ -253,7 +253,11 @@
@@ -256,7 +262,7 @@
} else
fClock = 0;
#ifdef CONFIG_APM
+#ifdef __FreeBSD__
+ if (taskBarShowApm && access("/dev/apm", 0) == 0) {
+#else
if (taskBarShowApm && access("/proc/apm", 0) == 0) {
+#endif
fApm = new YApm(this);
if (fApm->height() + ADD1 > ht) ht = fApm->height() + ADD1;
#ifdef CONFIG_APPLET_APM
- if (taskBarShowApm && access("/proc/apm", 0) == 0) {
+ if (taskBarShowApm && access(APMDEV, 0) == 0) {
fApm = new YApm(this);
if (fApm->height() + ADD1 > ht) ht = fApm->height() + ADD1;
} else

View File

@ -1,5 +1,5 @@
--- src/ysocket.h.orig Tue Nov 23 01:37:11 1999
+++ src/ysocket.h Wed Nov 24 15:56:28 1999
--- src/ysocket.h.orig Mon Jan 15 06:49:41 2001
+++ src/ysocket.h Mon Jan 15 22:18:05 2001
@@ -2,6 +2,9 @@
#define YSOCKET_H_

View File

@ -1,6 +1,6 @@
--- src/aapm.cc.orig Mon Nov 8 20:45:52 1999
+++ src/aapm.cc Wed Dec 1 16:42:31 1999
@@ -20,15 +20,32 @@
--- src/aapm.cc.orig Mon Jan 15 06:49:39 2001
+++ src/aapm.cc Mon Jan 15 22:18:05 2001
@@ -21,15 +21,32 @@
#include <string.h>
#include <stdio.h>
@ -11,7 +11,7 @@
+#include <machine/apm_bios.h>
+#endif
+
#ifdef CONFIG_APM
#ifdef CONFIG_APPLET_APM
YColor *YApm::apmBg = 0;
YColor *YApm::apmFg = 0;
@ -34,26 +34,26 @@
char driver[16];
char apmver[16];
int apmflags;
@@ -40,9 +57,27 @@
@@ -41,9 +58,27 @@
char units[16];
if (fd == -1) {
+ static int error = 0;
+ if (!error)
+ perror("Can't open the apm device");
+ error = 1;
+ static int error = 0;
+ if (!error)
+ perror("Can't open the apm device");
+ error = 1;
return ;
}
-
+#ifdef __FreeBSD__
+ if (ioctl(fd,APMIO_GETINFO, &ai) == -1)
+ {
+ static int error = 0;
+ if (!error)
+ perror("Can't ioctl the apm device");
+ error = 1;
+ close(fd);
+ return;
+ static int error = 0;
+ if (!error)
+ perror("Can't ioctl the apm device");
+ error = 1;
+ close(fd);
+ return;
+ }
+ close(fd);
+ BATlife = ai.ai_batt_life;
@ -63,11 +63,10 @@
len = read(fd, buf, sizeof(buf) - 1);
close(fd);
@@ -60,6 +95,7 @@
@@ -61,6 +96,7 @@
}
return ;
}
+#endif
if (BATlife == -1)
BATlife = 0;

View File

@ -1,19 +1,12 @@
--- sysdep.in.orig Sat Jan 1 17:26:22 2000
+++ sysdep.in Sat Jan 1 17:26:32 2000
@@ -3,4 +3,4 @@
SYS_CFLAGS = @CXXFLAGS@ @DEFS@
--- sysdep.in.orig Mon Jan 15 06:49:39 2001
+++ sysdep.in Mon Jan 15 22:18:06 2001
@@ -1,7 +1,7 @@
CXX = @CXX@
LD = @CXX_LINK@
DEBUG = @debug_flags@
-SYS_CFLAGS = @CXXFLAGS@ @DEFS@
+SYS_CFLAGS = @CXXFLAGS@ @CPPFLAGS@ @DEFS@
SYS_INCDIRS =
SYS_LIBDIRS =
-SYS_LIBS = @LIBS@
+SYS_LIBS = @LIBS@ -lxpg4
--- src/Makefile.orig Sat Jan 1 17:29:50 2000
+++ src/Makefile Sat Jan 1 17:30:04 2000
@@ -10,7 +10,7 @@
CXXFLAGS = \
$(I18N) $(DEBUG) $(OS2)\
-DLIBDIR='"$(LIBDIR)"' \
- -DCONFIGDIR='"/etc/X11/icewm"' \
+ -DCONFIGDIR='"$(LIBDIR)"' \
-DVERSION='"$(VERSION)"' \
-DEXEEXT='"$(EXEEXT)"' \
$(SYS_CFLAGS) $(SYS_INCDIRS)

View File

@ -0,0 +1,28 @@
--- configure.in.orig Mon Jan 15 06:49:39 2001
+++ configure.in Mon Jan 15 22:18:06 2001
@@ -66,7 +66,7 @@
AC_FUNC_SELECT_ARGTYPES
dnl Configuring features
-TARGETS='base docs'
+TARGETS='base'
dnl Checking for X11
AC_PATH_XTRA
@@ -94,7 +94,7 @@
[ --enable-nls Enable internationalized message],
[ if test "$enable_nls" != "no"; then
AC_CHECK_LIB(intl, gettext)
- localedir='${datadir}/locale'
+ localedir='${prefix}/share/locale'
AC_DEFINE(ENABLE_NLS, 1,
[Define to enable internationalized message])
TARGETS=$TARGETS' nls'
@@ -190,7 +190,7 @@
AC_DEFINE(GNOME, 1, [Define to make IceWM more GNOME-friendly])
else
- AC_MSG_ERROR([gnome-config can not be found])
+ AC_MSG_WARN([gnome-config can not be found])
fi
fi ])

View File

@ -0,0 +1,11 @@
--- po/Makefile.orig Mon Jan 15 06:49:39 2001
+++ po/Makefile Mon Jan 15 22:18:06 2001
@@ -24,7 +24,7 @@
MSGDIR="$(LOCDIR)/$$LANG/LC_MESSAGES"; \
echo Installing language: $$LANG ; \
$(INSTALLDIR) $$MSGDIR; \
- $(INSTALLBIN) $$c $$MSGDIR/$(PACKAGE).mo; \
+ $(INSTALLLIB) $$c $$MSGDIR/$(PACKAGE).mo; \
done
clean:

View File

@ -0,0 +1,20 @@
--- src/Makefile.orig Mon Jan 15 06:49:39 2001
+++ src/Makefile Mon Jan 15 22:40:24 2001
@@ -14,7 +14,7 @@
-DPACKAGE='"icewm"' \
-DVERSION='"$(VERSION)"' \
-DEXEEXT='"$(EXEEXT)"' \
- -DICEWMEXE='"icewm"EXEEXT' \
+ -DICEWMEXE='"icewm$(EXEEXT)"' \
$(SYS_CFLAGS) $(SYS_INCDIRS)
LFLAGS =
LIBS = $(SYS_LIBDIRS) $(SYS_LIBS)
@@ -97,7 +97,7 @@
genpref$(EXEEXT): $(GENPREFOBJS)
-@rm -f $@
- $(LD) -o $@ $(LFLAGS) $(GENPREFOBJS)
+ $(LD) -o $@ $(LFLAGS) $(GENPREFOBJS) $(LIBS)
icewmhint$(EXEEXT): $(ICEWMHINTOBJS)
-@rm -f $@

View File

@ -0,0 +1,19 @@
--- src/wmprog.cc.orig Mon Jan 15 06:49:41 2001
+++ src/wmprog.cc Mon Jan 15 22:18:07 2001
@@ -474,7 +474,7 @@
#ifdef GNOME
if (autoReloadMenus) {
- char *gnomeAppsMenu = gnome_datadir_file("gnome/apps/");
+ char *gnomeAppsMenu = gnome_datadir_file("apps/");
char *gnomeUserMenu = gnome_util_home_file("apps/");
const char *kdeMenu = strJoin(kdeDataDir, "/applnk", 0);
@@ -535,7 +535,7 @@
YIcon *gnomeicon = 0;
YIcon *kdeicon = 0;
- char *gnomeAppsMenu = gnome_datadir_file("gnome/apps/");
+ char *gnomeAppsMenu = gnome_datadir_file("apps/");
char *gnomeUserMenu = gnome_util_home_file("apps/");
const char *kdeMenu = strJoin(kdeDataDir, "/applnk", 0);

View File

@ -1,11 +1,5 @@
Window Manager designed for speed, usability and consistency.
When you want gnome option,
% make -DGNOME install
When you want i18n option,
% make -DUSE_I18N install
'bsd-daemon.xpm' is from Steve Farrell.
WWW: http://www.kiss.uni-lj.si/~k4fr0235/icewm/
WWW: http://icewm.sourceforge.net

View File

@ -1,6 +1,27 @@
bin/icewm
bin/icewmbg
bin/icewmhint
%%NODOCS%%share/doc/icewm/CHANGES
%%NODOCS%%share/doc/icewm/FAQ
%%NODOCS%%share/doc/icewm/INSTALL
%%NODOCS%%share/doc/icewm/README
%%NODOCS%%share/doc/icewm/TODO
%%NODOCS%%share/doc/icewm/icewm-1.html
%%NODOCS%%share/doc/icewm/icewm-10.html
%%NODOCS%%share/doc/icewm/icewm-11.html
%%NODOCS%%share/doc/icewm/icewm-12.html
%%NODOCS%%share/doc/icewm/icewm-13.html
%%NODOCS%%share/doc/icewm/icewm-14.html
%%NODOCS%%share/doc/icewm/icewm-15.html
%%NODOCS%%share/doc/icewm/icewm-2.html
%%NODOCS%%share/doc/icewm/icewm-3.html
%%NODOCS%%share/doc/icewm/icewm-4.html
%%NODOCS%%share/doc/icewm/icewm-5.html
%%NODOCS%%share/doc/icewm/icewm-6.html
%%NODOCS%%share/doc/icewm/icewm-7.html
%%NODOCS%%share/doc/icewm/icewm-8.html
%%NODOCS%%share/doc/icewm/icewm-9.html
%%NODOCS%%share/doc/icewm/icewm.html
share/icewm/icons/app_16x16.xpm
share/icewm/icons/app_32x32.xpm
share/icewm/icons/bomb_16x16.xpm
@ -25,8 +46,10 @@ share/icewm/icons/gimp_16x16.xpm
share/icewm/icons/gimp_32x32.xpm
share/icewm/icons/gimp_hi_16x16.xpm
share/icewm/icons/gimp_hi_32x32.xpm
share/icewm/icons/gnome_16x16.xpm
share/icewm/icons/java_16x16.xpm
share/icewm/icons/java_32x32.xpm
share/icewm/icons/kde_16x16.xpm
share/icewm/icons/koules_16x16.xpm
share/icewm/icons/koules_32x32.xpm
share/icewm/icons/navigator_16x16.xpm
@ -192,16 +215,26 @@ share/icewm/themes/win95/minimize.xpm
share/icewm/themes/win95/restore.xpm
share/icewm/toolbar
share/icewm/winoptions
@dirrm share/icewm/icons
@dirrm share/icewm/ledclock
@dirrm share/icewm/mailbox
@dirrm share/icewm/taskbar
@dirrm share/icewm/themes/gtk2
@dirrm share/icewm/themes/metal2
@dirrm share/icewm/themes/motif
@dirrm share/icewm/themes/nice
@dirrm share/icewm/themes/warp3
@dirrm share/icewm/themes/warp4
share/locale/de/LC_MESSAGES/icewm.mo
share/locale/es/LC_MESSAGES/icewm.mo
share/locale/fi/LC_MESSAGES/icewm.mo
share/locale/fr/LC_MESSAGES/icewm.mo
share/locale/ja/LC_MESSAGES/icewm.mo
share/locale/pt_BR/LC_MESSAGES/icewm.mo
share/locale/ru/LC_MESSAGES/icewm.mo
share/locale/zh_TW.Big5/LC_MESSAGES/icewm.mo
%%GNOME%%share/gnome/wm-properties/IceWM.desktop
@dirrm share/icewm/themes/win95
@dirrm share/icewm/themes/warp4
@dirrm share/icewm/themes/warp3
@dirrm share/icewm/themes/nice
@dirrm share/icewm/themes/motif
@dirrm share/icewm/themes/metal2
@dirrm share/icewm/themes/gtk2
@dirrm share/icewm/themes
@dirrm share/icewm/taskbar
@dirrm share/icewm/mailbox
@dirrm share/icewm/ledclock
@dirrm share/icewm/icons
@dirrm share/icewm
%%NODOCS%%@dirrm share/doc/icewm