- Update to 0.08

- Add LICENSE
- Update patch file to respect LOCALBASE

Changes:	http://search.cpan.org/dist/XML-WBXML/Changes
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2015-05-22 17:34:52 +00:00
parent ebfd4da336
commit d8a8067d87
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=387037
3 changed files with 20 additions and 18 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= XML-WBXML
PORTVERSION= 0.03
PORTREVISION= 2
PORTVERSION= 0.08
CATEGORIES= converters perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@ -11,13 +10,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Convert between XML and WBXML using libwbxml2
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
LIB_DEPENDS= libwbxml2.so:${PORTSDIR}/textproc/wbxml2
USES= perl5
USE_PERL5= configure
post-patch:
@${REINPLACE_CMD} -e 's,-I.,-I. -I${LOCALBASE}/include,' ${WRKSRC}/Makefile.PL
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/Makefile.PL
post-install:
${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/XML/WBXML/WBXML.so

View File

@ -1,2 +1,2 @@
SHA256 (XML-WBXML-0.03.tar.gz) = 618033732691ed6991b2568213dcc2cb41aee0b65aff5a90ffe253fb650e27da
SIZE (XML-WBXML-0.03.tar.gz) = 52022
SHA256 (XML-WBXML-0.08.tar.gz) = bfabde1879865d227ec405a0e4d6bc0f6ad54dd31d679009585b579a5286ac19
SIZE (XML-WBXML-0.08.tar.gz) = 61277

View File

@ -1,14 +1,14 @@
--- Makefile.PL.orig Fri Jul 28 01:39:37 2006
+++ Makefile.PL Fri Jul 28 09:02:40 2006
@@ -8,9 +8,9 @@
PREREQ_PM => {}, # e.g., Module::Name => 1.1
ABSTRACT_FROM => 'lib/XML/WBXML.pm', # retrieve abstract from module
AUTHOR => 'David Glasser <glasser@bestpractical.com>',
- LIBS => ['-lwbxml2'], # e.g., '-lm'
+ LIBS => ['-L/usr/local/lib -lwbxml2'], # e.g., '-lm'
DEFINE => '', # e.g., '-DHAVE_SOMETHING'
- INC => '-I.', # e.g., '-I. -I/usr/include/other'
+ INC => '-I. -I/usr/local/include', # e.g., '-I. -I/usr/include/other'
# Un-comment this if you add C files to link with later:
--- Makefile.PL.orig 2015-05-21 10:43:29 UTC
+++ Makefile.PL
@@ -10,9 +10,9 @@ WriteMakefile(
ABSTRACT_FROM => 'lib/XML/WBXML.pm', # retrieve abstract from module
LICENSE => 'perl_5',
PREREQ_PM => {}, # e.g., Module::Name => 1.1
- LIBS => ['-lwbxml2'], # e.g., '-lm'
+ LIBS => ['-L%%LOCALBASE%%/lib -lwbxml2'], # e.g., '-lm'
DEFINE => '', # e.g., '-DHAVE_SOMETHING'
- INC => '-I.', # e.g., '-I. -I/usr/include/other'
+ INC => '-I. -I%%LOCALBASE%%/include', # e.g., '-I. -I/usr/include/other'
# Un-comment this if you add C files to link with later:
# OBJECT => '$(O_FILES)', # link all the C files too
);