Update to 1.1.1

PR:		ports/140919
Submitted by:	Gea-Suan Lin <gslin@gslin.org>
This commit is contained in:
Michael Johnson 2009-12-21 03:00:51 +00:00
parent 2fadfa2cfb
commit d89b6e8ed1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=246328
4 changed files with 23 additions and 83 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= libtheora
PORTVERSION= 1.0
PORTREVISION= 1
PORTVERSION= 1.1.1
CATEGORIES= multimedia
MASTER_SITES= http://downloads.xiph.org/releases/theora/ \
http://distfiles.master.finkmirrors.net/
@ -29,8 +28,13 @@ CONFIGURE_ARGS+=--disable-sdltest \
--enable-shared \
--disable-examples
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -e 's|doc||g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's, x86_64), x86_64|amd64),' ${WRKSRC}/configure
.if ${ARCH}=="amd64"
@${REINPLACE_CMD} -e 's|#define OC_X86_ASM|#undef OC_X86_ASM|' ${WRKSRC}/configure
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (libtheora-1.0.tar.bz2) = c963937053f45a7878954bed37ceb182
SHA256 (libtheora-1.0.tar.bz2) = 3ae9df56e8fc75ffe26e63a13cae2ce79d079416175fb0baffe0e2de8dc91a6d
SIZE (libtheora-1.0.tar.bz2) = 1652987
MD5 (libtheora-1.1.1.tar.bz2) = 292ab65cedd5021d6b7ddd117e07cd8e
SHA256 (libtheora-1.1.1.tar.bz2) = b6ae1ee2fa3d42ac489287d3ec34c5885730b1296f0801ae577a35193d3affbc
SIZE (libtheora-1.1.1.tar.bz2) = 1903175

View File

@ -1,20 +1,20 @@
--- Makefile.in.orig 2008-10-29 11:36:48.000000000 +0100
+++ Makefile.in 2009-02-25 03:35:59.886902862 +0100
@@ -80,7 +80,7 @@
DATA = $(pkgconfig_DATA)
ETAGS = etags
CTAGS = ctags
-DIST_SUBDIRS = lib include doc tests m4 examples
+DIST_SUBDIRS = lib include m4
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
distdir = $(PACKAGE)-$(VERSION)
top_distdir = $(distdir)
@@ -274,7 +274,7 @@
libtheora.spec libtheora.spec.in \
--- Makefile.in.orig 2009-10-01 18:04:07.000000000 +0000
+++ Makefile.in 2009-12-21 01:17:02.000000000 +0000
@@ -177,7 +177,7 @@
theora-uninstalled.pc.in
-pkgconfigdir = $(libdir)/pkgconfig
+pkgconfigdir = $(prefix)/libdata/pkgconfig
pkgconfig_DATA = theora.pc theoradec.pc theoraenc.pc
subdir = .
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
@@ -200,7 +200,7 @@
missing mkinstalldirs theora-uninstalled.pc.in theora.pc.in \
theoradec-uninstalled.pc.in theoradec.pc.in \
theoraenc-uninstalled.pc.in theoraenc.pc.in
-DIST_SUBDIRS = lib include doc tests m4 examples
+DIST_SUBDIRS = lib include m4
all: config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive

View File

@ -1,64 +0,0 @@
diff -ru lib/enc.orig/encode.c lib/enc/encode.c
--- lib/enc.orig/encode.c 2009-02-25 00:37:51.868139315 +0100
+++ lib/enc/encode.c 2009-02-25 00:23:45.582743808 +0100
@@ -934,7 +934,7 @@
ogg_uint32_t SBRows,
ogg_uint32_t SBCols){
- ogg_int32_t FragIndex; /* Fragment number */
+ ogg_int32_t FragIndex, FirstFragIndex; /* Fragment number */
ogg_uint32_t MB, B; /* Macro-Block, Block indices */
ogg_uint32_t SBrow; /* Super-Block row number */
ogg_uint32_t SBcol; /* Super-Block row number */
@@ -953,19 +953,20 @@
/* There may be MB's lying out of frame which must be
ignored. For these MB's Top left block will have a negative
Fragment Index. */
- if ( QuadMapToMBTopLeft(cpi->pb.BlockMap,SB,MB) >= 0 ) {
+ if ( (FirstFragIndex = QuadMapToMBTopLeft(cpi->pb.BlockMap,SB,MB)) >= 0 ) {
cpi->MBCodingMode = CODE_INTRA;
/* Now actually code the blocks. */
for ( B=0; B<4; B++ ) {
FragIndex = QuadMapToIndex1( cpi->pb.BlockMap, SB, MB, B );
- cpi->pb.FragCodingMethod[FragIndex] = cpi->MBCodingMode;
+ if (FragIndex >= 0)
+ cpi->pb.FragCodingMethod[FragIndex] = cpi->MBCodingMode;
}
/* Matching fragments in the U and V planes */
- UVRow = (FragIndex / (cpi->pb.HFragments * 2));
- UVColumn = (FragIndex % cpi->pb.HFragments) / 2;
+ UVRow = (FirstFragIndex / (cpi->pb.HFragments * 2));
+ UVColumn = (FirstFragIndex % cpi->pb.HFragments) / 2;
UVFragOffset = (UVRow * (cpi->pb.HFragments / 2)) + UVColumn;
cpi->pb.FragCodingMethod[cpi->pb.YPlaneFragments + UVFragOffset] =
Only in lib/enc: encode.c.orig
diff -ru lib/enc.orig/misc_common.c lib/enc/misc_common.c
--- lib/enc.orig/misc_common.c 2009-02-25 00:37:51.865139234 +0100
+++ lib/enc/misc_common.c 2009-02-25 00:51:20.362286530 +0100
@@ -87,14 +87,14 @@
if ( QuadMapToMBTopLeft(cpi->pb.BlockMap, SB, MB ) >= 0 ) {
/* Up regulate the component blocks Y then UV. */
for ( B=0; B<4; B++ ){
- FragIndex = QuadMapToIndex1( cpi->pb.BlockMap, SB, MB, B );
-
- if ( ( !cpi->pb.display_fragments[FragIndex] ) &&
- ( (NoCheck) || (cpi->FragmentLastQ[FragIndex] > RegulationQ) ) ){
- cpi->pb.display_fragments[FragIndex] = 1;
- cpi->extra_fragments[FragIndex] = 1;
- cpi->FragmentLastQ[FragIndex] = RegulationQ;
- cpi->MotionScore++;
+ if ((FragIndex = QuadMapToIndex1( cpi->pb.BlockMap, SB, MB, B )) >= 0) {
+ if ( ( !cpi->pb.display_fragments[FragIndex] ) &&
+ ( (NoCheck) || (cpi->FragmentLastQ[FragIndex] > RegulationQ) ) ){
+ cpi->pb.display_fragments[FragIndex] = 1;
+ cpi->extra_fragments[FragIndex] = 1;
+ cpi->FragmentLastQ[FragIndex] = RegulationQ;
+ cpi->MotionScore++;
+ }
}
}