Port of the FreeBSD calendar program from -CURRENT

This version of	the calendar program includes data file locations
populated by the calendar-data port in the search path.

It is meant to provide this feature to users of	FreeBSD	releases that
have not received the updated calendar program,	yet.

Development of the calendar program will	continue in the base system
and the	port will be updated to	reflect	changes	made to	the calendar
program	in FreeBSD-CURRENT.

Different from the version in -CURRENT this port does not warn about
missing calendar files provided by the calendar-data port since it has
this port declared as a run-time dependency and it can therefore be
assumed that the data port has been installed with this port.

This port uses a preliminary location for the repository to fetch from.

It is expected to be updated to an official repository with updated sources
that eliminate the need for the patches that are currently required.
This commit is contained in:
Stefan Eßer 2020-10-25 11:46:49 +00:00
parent 137ece1848
commit d88c4de7de
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=553259
7 changed files with 213 additions and 0 deletions

View File

@ -0,0 +1,31 @@
# $FreeBSD$
PORTNAME= calendar
DISTVERSION= 0.1
CATEGORIES= deskutils
MAINTAINER= se@FreeBSD.org
COMMENT= Port of the FreeBSD calendar program
LICENSE= BSD3CLAUSE
RUN_DEPENDS= ${LOCALBASE}/share/calendar/calendar.all:deskutils/calendar-data
USE_GITHUB= yes
GH_ACCOUNT= bsdimp
GH_TAGNAME= fcc5d31
CFLAGS+= -DLOCALBASE=${LOCALBASE}
LDFLAGS+= -lm -lutil
PLIST_FILES= bin/calendar \
share/man/man1/calendar.1.gz
OPTIONS_DEFINE= NLS
NLS_CFLAGS= -DWITH_ICONV
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/calendar ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/calendar.1 ${STAGEDIR}${PREFIX}/share/man/man1
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1603625001
SHA256 (bsdimp-calendar-0.1-fcc5d31_GH0.tar.gz) = ad7d0b51c4b834241aebbf6c50d187e5720f6c46c02615b27841a923e082aebc
SIZE (bsdimp-calendar-0.1-fcc5d31_GH0.tar.gz) = 132824

View File

@ -0,0 +1,126 @@
--- Makefile.orig 2020-10-18 03:01:26 UTC
+++ Makefile
@@ -1,117 +1,14 @@
# @(#)Makefile 8.1 (Berkeley) 6/6/93
# $FreeBSD$
-.include <src.opts.mk>
-
PROG= calendar
-SRCS= calendar.c locale.c events.c dates.c parsedata.c io.c day.c \
- ostern.c paskha.c pom.c sunpos.c
-LIBADD= m util
-INTER= de_AT.ISO_8859-15 de_DE.ISO8859-1 fr_FR.ISO8859-1 \
- hr_HR.ISO8859-2 hu_HU.ISO8859-2 pt_BR.ISO8859-1 \
- pt_BR.UTF-8 ru_RU.KOI8-R ru_RU.UTF-8 uk_UA.KOI8-U
-DE_LINKS= de_DE.ISO8859-15
-FR_LINKS= fr_FR.ISO8859-15
-.if ${MK_ICONV} == "yes"
-CFLAGS+= -DWITH_ICONV
-.endif
+OBJS= calendar.o locale.o events.o dates.o parsedata.o io.o day.o \
+ ostern.o paskha.o pom.o sunpos.o
-FILESGROUPS+= CALS
-CALS= calendars/calendar.all \
- calendars/calendar.australia \
- calendars/calendar.birthday \
- calendars/calendar.brazilian \
- calendars/calendar.christian \
- calendars/calendar.computer \
- calendars/calendar.croatian \
- calendars/calendar.dutch \
- calendars/calendar.freebsd \
- calendars/calendar.french \
- calendars/calendar.german \
- calendars/calendar.history \
- calendars/calendar.holiday \
- calendars/calendar.hungarian \
- calendars/calendar.judaic \
- calendars/calendar.lotr \
- calendars/calendar.music \
- calendars/calendar.newzealand \
- calendars/calendar.russian \
- calendars/calendar.southafrica \
- calendars/calendar.ukrainian \
- calendars/calendar.usholiday \
- calendars/calendar.world
-CALSDIR= ${SHAREDIR}/calendar
+LDFLAGS= -lm -lutil
-CAL_de_AT.ISO_8859-15= calendar.feiertag
+all: ${PROG}
-CAL_de_DE.ISO8859-1= calendar.all \
- calendar.feiertag \
- calendar.geschichte \
- calendar.kirche \
- calendar.literatur \
- calendar.musik \
- calendar.wissenschaft
-
-CAL_fr_FR.ISO8859-1= calendar.all \
- calendar.fetes \
- calendar.french \
- calendar.jferies \
- calendar.proverbes
-
-CAL_hr_HR.ISO8859-2= calendar.all \
- calendar.praznici
-
-CAL_hu_HU.ISO8859-2= calendar.all \
- calendar.nevnapok \
- calendar.unnepek
-
-CAL_pt_BR.ISO8859-1= calendar.all \
- calendar.commemorative \
- calendar.holidays \
- calendar.mcommemorative
-
-CAL_pt_BR.UTF-8= calendar.all \
- calendar.commemorative \
- calendar.holidays \
- calendar.mcommemorative
-
-CAL_ru_RU.KOI8-R= calendar.all \
- calendar.common \
- calendar.holiday \
- calendar.military \
- calendar.orthodox \
- calendar.pagan
-
-CAL_ru_RU.UTF-8= calendar.all \
- calendar.common \
- calendar.holiday \
- calendar.military \
- calendar.orthodox \
- calendar.pagan
-
-CAL_uk_UA.KOI8-U= calendar.all \
- calendar.holiday \
- calendar.misc \
- calendar.orthodox
-
-.for lang in ${INTER}
-FILESGROUPS+= CALS_${lang}
-CALS_${lang}DIR= ${SHAREDIR}/calendar/${lang}
-.for file in ${CAL_${lang}}
-CALS_${lang}+= ${file:S@^@calendars/${lang}/@}
-.endfor
-.endfor
-
-
-.for link in ${DE_LINKS}
-SYMLINKS+= de_DE.ISO8859-1 ${SHAREDIR}/calendar/${link}
-.endfor
-.for link in ${FR_LINKS}
-SYMLINKS+= fr_FR.ISO8859-1 ${SHAREDIR}/calendar/${link}
-.endfor
-
-HAS_TESTS=
-SUBDIR.${MK_TESTS}+= tests
-
-.include <bsd.prog.mk>
+${PROG}: ${OBJS}
+ ${CC} ${OBJS} ${LDFLAGS} -o ${PROG}

View File

@ -0,0 +1,11 @@
--- calendar.h.orig 2020-10-18 03:01:26 UTC
+++ calendar.h
@@ -28,7 +28,7 @@
* OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
* SUCH DAMAGE.
*
- * $FreeBSD$
+ * $FreeBSD: head/usr.bin/calendar/calendar.h 358562 2020-03-03 00:20:08Z cem $
*/
#include <sys/types.h>

View File

@ -0,0 +1,20 @@
--- io.c.orig 2020-10-18 03:01:26 UTC
+++ io.c
@@ -42,7 +42,7 @@ static char sccsid[] = "@(#)calendar.c 8.3 (Berkeley)
#endif
#include <sys/cdefs.h>
-__FBSDID("$FreeBSD$");
+__FBSDID("$FreeBSD: head/usr.bin/calendar/io.c 366962 2020-10-23 09:22:23Z se $");
#include <sys/param.h>
#include <sys/stat.h>
@@ -71,7 +71,7 @@ enum {
};
const char *calendarFile = "calendar"; /* default calendar file */
-static const char *calendarHomes[] = {".calendar", _PATH_INCLUDE}; /* HOME */
+static const char *calendarHomes[] = {".calendar", _PATH_INCLUDE_LOCAL, _PATH_INCLUDE}; /* HOME */
static const char *calendarNoMail = "nomail";/* don't sent mail if file exist */
static char path[MAXPATHLEN];

View File

@ -0,0 +1,16 @@
--- pathnames.h.orig 2020-10-18 03:01:26 UTC
+++ pathnames.h
@@ -29,9 +29,12 @@
* SUCH DAMAGE.
*
* @(#)pathnames.h 8.1 (Berkeley) 6/6/93
- * $FreeBSD$
+ * $FreeBSD: head/usr.bin/calendar/pathnames.h 366962 2020-10-23 09:22:23Z se $
*/
#include <paths.h>
+#define s1(s) #s
+#define s2(s) s1(s)
#define _PATH_INCLUDE "/usr/share/calendar"
+#define _PATH_INCLUDE_LOCAL s2(LOCALBASE) "/share/calendar"

View File

@ -0,0 +1,6 @@
This is the calendar program from FreeBSD converted into a port.
The purpose of this port is to make upgrades to the calendar program
available independently of the FreeBSD release cycle.
WWW: http://freebsd.org