module name conflict with print/gp, so remove it and I'll reimport it again

This commit is contained in:
Ying-Chieh Liao 2001-02-28 02:43:22 +00:00
parent ee5e877dec
commit d87d30e484
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=38874
8 changed files with 0 additions and 163 deletions

View File

@ -11,7 +11,6 @@
SUBDIR += fasta3
SUBDIR += fastdnaml
SUBDIR += gaussian98
SUBDIR += gp
SUBDIR += gperiodic
SUBDIR += hmmer
SUBDIR += kinemage

View File

@ -1,36 +0,0 @@
# ex:ts=8
# New ports collection makefile for: gp
# Date created: Feb 28, 2001
# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= gp
PORTVERSION= 0.25
CATEGORIES= biology
MASTER_SITES= http://www.bioinformatics.org/genpak/download/
EXTRACT_SUFX= .tgz
MAINTAINER= ijliao@FreeBSD.org
LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd \
png.4:${PORTSDIR}/graphics/png
USE_GMAKE= yes
MAN1= Genpak.1 gp_acc.1 gp_cusage.1 gp_digest.1 gp_dimer.1 gp_findorf.1 \
gp_gc.1 gp_getseq.1 gp_matrix.1 gp_mkmtx.1 gp_pattern.1 gp_qs.1 \
gp_randseq.1 gp_seq2prot.1 gp_slen.1 gp_tm.1 gp_trimer.1 gp_primer.1
.if !defined(NOPORTDOCS)
INSTALL_TARGET= install docs
.endif
post-patch:
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g ; \
s|%%MANPREFIX%%|${MANPREFIX}|g ; \
s|%%DOCDIR%%|${PREFIX}/share/doc|g ; \
s|%%CFLAGS%%|${CFLAGS}|g" ${WRKSRC}/Makefile
.include <bsd.port.mk>

View File

@ -1 +0,0 @@
MD5 (gp-0.25.tgz) = 35bc282e2da3d5af24cf44ed01a04551

View File

@ -1,51 +0,0 @@
--- Makefile.orig Tue Feb 13 22:41:12 2001
+++ Makefile Wed Feb 28 01:01:15 2001
@@ -5,15 +5,13 @@
######################################################################
# Change the following to suit your needs
-SHELL=/bin/bash
-
# The directory root of your installation
# If you make a personal installation, change it to your home directory
# Default: /usr
# uncomment the following line to install to the default directories...
# TREE=/usr
# ...or the following line to install into your home directory:
-TREE=$(HOME)
+TREE=%%PREFIX%%
# if you don't have the gd graphic library installed, you have to comment out or
# delete the following line. However, gp_map is such a nice program, so you
@@ -25,7 +23,7 @@
BINDIR=$(TREE)/bin
# directory to install the manual pages
-MANDIR=$(TREE)/man
+MANDIR=%%MANPREFIX%%/man
#directory to install the data directory
DATADIR=$(TREE)/lib
@@ -36,11 +34,11 @@
# A catalog will be created: $(DOCDIR)/gp
# It will *not* be uninstalled automagically after a "make uninstall"
-DOCDIR=$(TREE)/doc
+DOCDIR=%%DOCDIR%%
# Your favourite ANSI compiler and it's flags
CC=gcc
-CFLAGS=-ansi -pedantic -O3
+CFLAGS=%%CFLAGS%%
######################################################################
# Do not change anything below this line
@@ -58,7 +56,7 @@
mporfs.seq
all:
- cd src ; make PROGRAMS="$(PROGRAMS)" GDPROGRAMS="$(GDPROGRAMS)" CC=$(CC) \
+ cd src ; gmake PROGRAMS="$(PROGRAMS)" GDPROGRAMS="$(GDPROGRAMS)" CC=$(CC) \
LIBS="$(LIBS)" CFLAGS="$(CFLAGS)" ;
@echo -e "\nAll programs compiled. \nType 'make install' to install all programs."

View File

@ -1,10 +0,0 @@
--- src/Makefile.orig Wed Feb 28 01:01:24 2001
+++ src/Makefile Wed Feb 28 01:01:31 2001
@@ -5,7 +5,6 @@
######################################################################
# Change the following to suit your needs
-SHELL=/bin/bash
CC=gcc
LIBS= -lz -lm
#CFLAGS= -DNLS -DGZ

View File

@ -1 +0,0 @@
GP is a set of small utilities to manipulate DNA sequences

View File

@ -1,9 +0,0 @@
GP is a set of small utilities written in ANSI C to manipulate DNA
sequences in a Unix fashion, fit for combining within shell and cgi
scripts.
The sequences are usually in fasta format, that means the first line
is the sequence name starting with ">", and the sequence comes in the
next lines. The programs accept also gzipped sequence files.
WWW: http://www.bioinformatics.org/genpak/#gp

View File

@ -1,54 +0,0 @@
bin/gp_acc
bin/gp_cusage
bin/gp_digest
bin/gp_dimer
bin/gp_findorf
bin/gp_gc
bin/gp_getseq
bin/gp_matrix
bin/gp_mkmtx
bin/gp_pars
bin/gp_pattern
bin/gp_primer
bin/gp_qs
bin/gp_randseq
bin/gp_scan
bin/gp_seq2prot
bin/gp_shift
bin/gp_slen
bin/gp_tm
bin/gp_trimer
lib/genpak/ecoli.mtx
lib/genpak/enzyme.enz
lib/genpak/mporfs.seq
lib/genpak/myco.cdn
lib/genpak/sample.seq
lib/genpak/standard.cdn
@dirrm lib/genpak
%%PORTDOCS%%share/doc/gp/CHANGES.TXT
%%PORTDOCS%%share/doc/gp/INSTALL.TXT
%%PORTDOCS%%share/doc/gp/LICENSE.TXT
%%PORTDOCS%%share/doc/gp/Makefile
%%PORTDOCS%%share/doc/gp/README.TXT
%%PORTDOCS%%share/doc/gp/html/README.html
%%PORTDOCS%%share/doc/gp/html/gp_acc.html
%%PORTDOCS%%share/doc/gp/html/gp_cusage.html
%%PORTDOCS%%share/doc/gp/html/gp_digest.html
%%PORTDOCS%%share/doc/gp/html/gp_dimer.html
%%PORTDOCS%%share/doc/gp/html/gp_findorf.html
%%PORTDOCS%%share/doc/gp/html/gp_gc.html
%%PORTDOCS%%share/doc/gp/html/gp_getseq.html
%%PORTDOCS%%share/doc/gp/html/gp_map.html
%%PORTDOCS%%share/doc/gp/html/gp_matrix.html
%%PORTDOCS%%share/doc/gp/html/gp_mkmtx.html
%%PORTDOCS%%share/doc/gp/html/gp_pattern.html
%%PORTDOCS%%share/doc/gp/html/gp_primer.html
%%PORTDOCS%%share/doc/gp/html/gp_qs.html
%%PORTDOCS%%share/doc/gp/html/gp_randseq.html
%%PORTDOCS%%share/doc/gp/html/gp_seq2prot.html
%%PORTDOCS%%share/doc/gp/html/gp_slen.html
%%PORTDOCS%%share/doc/gp/html/gp_tm.html
%%PORTDOCS%%share/doc/gp/html/gp_trimer.html
%%PORTDOCS%%share/doc/gp/html/index.html
%%PORTDOCS%%@dirrm share/doc/gp/html
%%PORTDOCS%%@dirrm share/doc/gp