Add cdf 0.1,

cdf means "colorized df". The main features of cdf are:

 * customazable color schemes
 * eye-friendly capacity bars
 * most of such utils needs some 3rd party libraries,
 * python interpreter and so on, while cdf written in pure C

PR:		ports/73007
Submitted by:	Roman Bogorodskiy <bogorodskiy@inbox.ru>
This commit is contained in:
Kirill Ponomarev 2004-10-26 18:41:39 +00:00
parent 10e491cce3
commit d7aecd0c11
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=120269
6 changed files with 58 additions and 0 deletions

View File

@ -48,6 +48,7 @@
SUBDIR += cdargs
SUBDIR += cdbakeoven
SUBDIR += cdbkup
SUBDIR += cdf
SUBDIR += cdrdao
SUBDIR += cdroot
SUBDIR += cdrtools

21
sysutils/cdf/Makefile Normal file
View File

@ -0,0 +1,21 @@
# New ports collection makefile for: cdf
# Date created: 2004-10-22
# Whom: Charlie & <root@lame.novel.ru>
#
# $FreeBSD$
#
PORTNAME= cdf
PORTVERSION= 0.1
CATEGORIES= sysutils
MASTER_SITES= http://bmp-plugins.berlios.de/misc/cdf/
MAINTAINER= bogorodskiy@inbox.ru
COMMENT= A colorized df
PLIST_FILES= bin/cdf
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.mk>

2
sysutils/cdf/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (cdf-0.1.tar.gz) = 8591e101a9da0844c010804445091545
SIZE (cdf-0.1.tar.gz) = 147061

View File

@ -0,0 +1,15 @@
--- src/colors.c.orig Fri Oct 22 19:03:40 2004
+++ src/colors.c Fri Oct 22 19:04:16 2004
@@ -53,12 +53,6 @@
int read_colors()
{
-
-#ifdef DEBUG
- if (read_config_file(expand_filename("~/.cdfrc")) != 0)
- (void)fprintf(stderr, "Using default color theme\n");
-#endif /* DEBUG */
-
bracket_color = (char *)malloc(64);
gauge_color = (char *)malloc(64);
header_color = (char *)malloc(64);

View File

@ -0,0 +1,11 @@
--- src/main.c.orig Fri Oct 22 19:18:32 2004
+++ src/main.c Fri Oct 22 19:18:43 2004
@@ -38,6 +38,8 @@
blocksize = 1048576;
+
+ read_config_file(expand_filename("~/.cdfrc"));
while ((ch = getopt(argc, argv, "gkmt:v")) != -1)
switch (ch) {

8
sysutils/cdf/pkg-descr Normal file
View File

@ -0,0 +1,8 @@
cdf means "colorized df". The main features of cdf are:
* customazable color schemes
* eye-friendly capacity bars
* most of such utils needs some 3rd party libraries, python interpreter
and so on, while cdf written in pure C
WWW: http://bmp-plugins.berlios.de/misc/cdf/cdf.html