- Remove easy_install dependency

- Fix file removal, so that recording the plist works properly with distutils
- Bump PORTREVISION to enforce a cleanup for the easy_install references

With hat:	python@
Approved by:	portmgr (implicit)
This commit is contained in:
Marcus von Appen 2014-06-21 20:33:23 +00:00
parent 9c58fe8c93
commit d7aa7dad53
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=358741
2 changed files with 30 additions and 5 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= Skype4Py
PORTVERSION= 1.0.35
#PORTREVISION= 0
PORTREVISION= 1
CATEGORIES= net-im devel
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -11,12 +11,11 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
COMMENT= Skype (TM) API wrapper for Python
LICENSE= BSD
LICENSE= BSD3CLAUSE
USE_PYTHON= 2
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
USE_PYDISTUTILS= easy_install
USE_PYTHON= 2
USES= zip
.include <bsd.port.mk>

View File

@ -0,0 +1,26 @@
--- setup.py.orig 2013-05-25 11:00:56.000000000 +0200
+++ setup.py 2014-06-21 22:27:11.000000000 +0200
@@ -129,11 +129,21 @@
print >>sys.stderr, 'epydoc not installed, skipping build_doc.'
-commands = {'build_doc': build_doc,
- 'install_lib': install_lib}
+commands = {'build_doc': build_doc}
desc = open("README.rst").read() + "\n" + open("CHANGES.rst").read()
+if sys.platform[:3] == 'win':
+ platform = 'windows'
+elif sys.platform == 'darwin':
+ platform = 'darwin'
+else:
+ platform = 'posix'
+path = os.path.join('Skype4Py', 'api')
+for name in os.listdir(path):
+ if not (name.startswith('__') or name.startswith(platform)):
+ os.remove(os.path.join(path, name))
+
# start the distutils setup
setup(name='Skype4Py',
version=VERSION,