- update to 1.7

PR:		141183
Submitted by:	Makoto Kishimoto
This commit is contained in:
Dirk Meyer 2010-04-23 11:10:44 +00:00
parent 8982f50106
commit d7729ca196
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=253083
3 changed files with 8 additions and 34 deletions

View File

@ -6,10 +6,9 @@
#
PORTNAME= chasen
PORTVERSION= 1.6
PORTREVISION= 2
PORTVERSION= 1.7
CATEGORIES= japanese textproc ruby
MASTER_SITES= http://www.itlb.te.noda.tus.ac.jp/~ikarashi/ruby/
MASTER_SITES= http://sites.google.com/a/ixenon.net/ruby-chasen/home/
DISTNAME= ${PORTNAME}${PORTVERSION}
DIST_SUBDIR= ruby
@ -21,8 +20,9 @@ LIB_DEPENDS= chasen.2:${PORTSDIR}/japanese/chasen-base
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
CONFIGURE_ARGS= --with-chasen-include="${PREFIX}/include/chasen" \
--with-chasen-lib="${PREFIX}/lib"
FETCH_ARGS= -pRr
CONFIGURE_ARGS= --with-chasen-dir="${PREFIX}"
INSTALL_TARGET= site-install
.include <bsd.port.pre.mk>

View File

@ -1,3 +1,3 @@
MD5 (ruby/chasen1.6.tar.gz) = 534c5865e62b228f544f22f7aeee1335
SHA256 (ruby/chasen1.6.tar.gz) = 9f76ec4987804f55d82497a757745615843eb5f1def5685a0f4d25b0ab802f6a
SIZE (ruby/chasen1.6.tar.gz) = 3255
MD5 (ruby/chasen1.7.tar.gz) = 862833b93f70975df0d31af252dfcfac
SHA256 (ruby/chasen1.7.tar.gz) = bbf913ef1e9946b000bc1e2e4fd5c271fd8c10e0854c4f227fb748f589a8ae03
SIZE (ruby/chasen1.7.tar.gz) = 2753

View File

@ -1,26 +0,0 @@
--- extconf.rb.orig Thu Sep 9 05:57:36 1999
+++ extconf.rb Sun Aug 29 21:26:29 2004
@@ -1,20 +1,7 @@
require "mkmf"
-require "parsearg"
-def usage()
- printf "Usage:\n"
- printf "%s [-L library_path]\n", $0
-end
-
-$USAGE = 'usage'
-parseArgs(0, "L", nil, "L:.")
-
-unless have_library("chasen", "chasen_getopt_argv")
- $objs = Dir["*.{c,cc}"]
- for f in $objs
- f.sub!(/\.(c|cc)$/, ".o")
- end
- $objs.push File.join(["#{$OPT_L}", "libchasen.a"])
-end
+dir_config("chasen")
+have_library("stdc++")
+have_library("chasen", "chasen_getopt_argv") &&
create_makefile("chasen")