Update to 2.0
- Account for different username between postgresql 9.5 (postgres) or earlier versions (pgsql) - Regenerate patches by 'make makepatch'
This commit is contained in:
parent
59fc2b7609
commit
d71323ff32
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=422997
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= barman
|
||||
DISTVERSION= 1.6.1
|
||||
DISTVERSION= 2.0
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= SF/${PKGNAMEPREFIX}${PORTNAME}/${DISTVERSION}
|
||||
PKGNAMEPREFIX= pg
|
||||
@ -31,11 +31,21 @@ USE_PYTHON= autoplist distutils
|
||||
|
||||
PORTDOCS= tutorial.pdf
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PGSQL_VER:M9\.[12345]}
|
||||
PGUSER= pgsql
|
||||
.else
|
||||
PGUSER= postgres
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
${CP} ${DISTDIR}/${PORTDOCS} ${WRKDIR}/
|
||||
|
||||
post-patch:
|
||||
${SED} -i -e "s@%%PREFIX%%@${PREFIX}@" ${WRKSRC}/barman/config.py
|
||||
${SED} -i -e "s@%%PREFIX%%@${PREFIX}@" ${WRKSRC}/doc/barman.conf
|
||||
${SED} -i -e "s@%%PGUSER%%@${PGUSER}@" ${WRKSRC}/doc/barman.5
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
@ -43,4 +53,4 @@ post-install:
|
||||
${MKDIR} ${STAGEDIR}${ETCDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/barman.conf ${STAGEDIR}${ETCDIR}/barman.conf.sample
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,5 +1,5 @@
|
||||
TIMESTAMP = 1464011005
|
||||
SHA256 (barman-1.6.1.tar.gz) = 2fb8bbf0a386114dda4f1ade3e02a79aede5e3dd77c6b8d4f872b75fd1427e65
|
||||
SIZE (barman-1.6.1.tar.gz) = 189826
|
||||
TIMESTAMP = 1475218946
|
||||
SHA256 (barman-2.0.tar.gz) = 063c7bec1cda13175b615fe910418622e564405a68694ea179273f0b3713e8e4
|
||||
SIZE (barman-2.0.tar.gz) = 231486
|
||||
SHA256 (tutorial.pdf) = 21acf6152b959c55b996fb6479c722d3f416eac3384479498a25911a3912a158
|
||||
SIZE (tutorial.pdf) = 349394
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- barman/config.py.orig 2015-09-25 15:06:25 UTC
|
||||
--- barman/config.py.orig 2016-09-23 12:56:55 UTC
|
||||
+++ barman/config.py
|
||||
@@ -429,8 +429,8 @@ class Config(object):
|
||||
@@ -520,8 +520,8 @@ class Config(object):
|
||||
"""
|
||||
CONFIG_FILES = [
|
||||
'~/.barman.conf',
|
||||
|
@ -1,36 +1,36 @@
|
||||
--- doc/barman.5.orig 2015-09-25 15:06:25 UTC
|
||||
--- doc/barman.5.orig 2016-09-26 15:32:17 UTC
|
||||
+++ doc/barman.5
|
||||
@@ -8,7 +8,7 @@ The system\-level Barman configuration f
|
||||
@@ -17,7 +17,7 @@ The system\-level Barman configuration f
|
||||
.IP
|
||||
.nf
|
||||
\f[C]
|
||||
-/etc/barman.conf
|
||||
+/usr/local/etc/barman.conf
|
||||
+%%PREFIX%%/etc/barman.conf
|
||||
\f[]
|
||||
.fi
|
||||
.PP
|
||||
@@ -16,7 +16,7 @@ or
|
||||
@@ -25,7 +25,7 @@ or
|
||||
.IP
|
||||
.nf
|
||||
\f[C]
|
||||
-/etc/barman/barman.conf
|
||||
+/usr/local/etc/barman/barman.conf
|
||||
+%%PREFIX%%/etc/barman/barman.conf
|
||||
\f[]
|
||||
.fi
|
||||
.PP
|
||||
@@ -42,9 +42,9 @@ configurations.
|
||||
@@ -51,9 +51,9 @@ configurations.
|
||||
If the value of \f[C]configuration_files_directory\f[] is a directory,
|
||||
Barman reads all files with \f[C]\&.conf\f[] extension that exist in
|
||||
that folder.
|
||||
-For example, if you set it to \f[C]/etc/barman.d\f[], you can specify
|
||||
+For example, if you set it to \f[C]/usr/local/etc/barman.d\f[], you can specify
|
||||
+For example, if you set it to \f[C]%%PREFIX%%/etc/barman.d\f[], you can specify
|
||||
your PostgreSQL servers placing each section in a separate
|
||||
-\f[C]\&.conf\f[] file inside the \f[C]/etc/barman.d\f[] folder.
|
||||
+\f[C]\&.conf\f[] file inside the \f[C]/usr/local/etc/barman.d\f[] folder.
|
||||
+\f[C]\&.conf\f[] file inside the \f[C]%%PREFIX%%/etc/barman.d\f[] folder.
|
||||
.SH OPTIONS
|
||||
.TP
|
||||
.B active
|
||||
@@ -445,7 +445,7 @@ Here is an example of configuration file
|
||||
@@ -608,7 +608,7 @@ Here is an example of configuration file
|
||||
\f[C]
|
||||
[barman]
|
||||
;\ Main\ directory
|
||||
@ -39,16 +39,20 @@
|
||||
|
||||
;\ System\ user
|
||||
barman_user\ =\ barman
|
||||
@@ -465,10 +465,10 @@ reuse_backup\ =\ link
|
||||
@@ -628,13 +628,13 @@ reuse_backup\ =\ link
|
||||
description\ =\ \ "Main\ PostgreSQL\ Database"
|
||||
|
||||
;\ SSH\ options
|
||||
-ssh_command\ =\ ssh\ postgres\@pg
|
||||
+ssh_command\ =\ ssh\ pgsql\@pg
|
||||
+ssh_command\ =\ ssh\ %%PGUSER%%\@pg
|
||||
|
||||
;\ PostgreSQL\ connection\ string
|
||||
-conninfo\ =\ host=pg\ user=postgres
|
||||
+conninfo\ =\ host=pg\ user=pgsql\ db=postgres
|
||||
+conninfo\ =\ host=pg\ user=%%PGUSER%%\ db=postgres
|
||||
|
||||
;\ PostgreSQL\ streaming\ connection\ string
|
||||
-streaming_conninfo\ =\ host=pg\ user=postgres
|
||||
+streaming_conninfo\ =\ host=pg\ user=%%PGUSER%%
|
||||
|
||||
;\ Minimum\ number\ of\ required\ backups\ (redundancy)
|
||||
minimum_redundancy\ =\ 1
|
||||
|
@ -1,35 +1,17 @@
|
||||
--- doc/barman.conf.orig 2014-08-18 10:29:45 UTC
|
||||
--- doc/barman.conf.orig 2016-09-23 12:56:55 UTC
|
||||
+++ doc/barman.conf
|
||||
@@ -5,7 +5,7 @@
|
||||
@@ -8,11 +8,11 @@
|
||||
barman_user = barman
|
||||
|
||||
; Directory of configuration files. Place your sections in separate files with .conf extension
|
||||
-; For example place the 'main' server section in /etc/barman.d/main.conf
|
||||
-configuration_files_directory = /etc/barman.d
|
||||
+; For example place the 'main' server section in %%PREFIX%%/etc/barman.d/main.conf
|
||||
+configuration_files_directory = %%PREFIX%%/etc/barman.d
|
||||
|
||||
[barman]
|
||||
; Main directory
|
||||
-barman_home = /var/lib/barman
|
||||
+barman_home = /var/barman
|
||||
|
||||
; System user
|
||||
barman_user = barman
|
||||
@@ -25,8 +25,8 @@ log_file = /var/log/barman/barman.log
|
||||
;post_archive_script = env | grep ^BARMAN
|
||||
|
||||
; Directory of configuration files. Place your sections in separate files with .conf extension
|
||||
-; For example place the 'main' server section in /etc/barman.d/main.conf
|
||||
-;configuration_files_directory = /etc/barman.d
|
||||
+; For example place the 'main' server section in /usr/local/etc/barman.d/main.conf
|
||||
+;configuration_files_directory = /usr/local/etc/barman.d
|
||||
|
||||
; Minimum number of required backups (redundancy) - default 0
|
||||
;minimum_redundancy = 0
|
||||
@@ -68,10 +68,10 @@ log_file = /var/log/barman/barman.log
|
||||
;; description = "Main PostgreSQL Database"
|
||||
;;
|
||||
;; ; SSH options
|
||||
-;; ssh_command = ssh postgres@pg
|
||||
+;; ssh_command = ssh pgsql@pg
|
||||
;;
|
||||
;; ; PostgreSQL connection string
|
||||
-;; conninfo = host=pg user=postgres
|
||||
+;; conninfo = host=pg user=pgsql dbname=postgres
|
||||
;;
|
||||
;; ; Minimum number of required backups (redundancy)
|
||||
;; ; minimum_redundancy = 1
|
||||
; Locks directory - default: %(barman_home)s
|
||||
;barman_lock_directory = /var/run/barman
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- setup.py.orig 2014-12-03 15:50:50 UTC
|
||||
--- setup.py.orig 2016-09-23 15:43:57 UTC
|
||||
+++ setup.py
|
||||
@@ -74,8 +74,8 @@ setup(
|
||||
@@ -69,8 +69,8 @@ setup(
|
||||
packages=['barman', ],
|
||||
scripts=['bin/barman', ],
|
||||
data_files=[
|
||||
|
Loading…
Reference in New Issue
Block a user