* Update to 5.0.0.
* Remove extra patches for 4.X.
This commit is contained in:
parent
532151dd1a
commit
d70e76282e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=189312
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= multitail
|
||||
PORTVERSION= 4.3.0
|
||||
PORTVERSION= 5.0.0
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://www.vanheusden.com/multitail/
|
||||
EXTRACT_SUFX= .tgz
|
||||
@ -20,13 +20,6 @@ MAN1= multitail.1
|
||||
PLIST_FILES= bin/multitail etc/multitail.conf.sample
|
||||
PORTDOCS= readme.txt license.txt
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
EXTRA_PATCHES= ${FILESDIR}/extra-patch-config.c ${FILESDIR}/extra-patch-cv.c \
|
||||
${FILESDIR}/extra-patch-stripstring.c
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's,/etc/multitail.conf,${PREFIX}/etc/multitail.conf,' \
|
||||
${WRKSRC}/mt.c ${WRKSRC}/Makefile
|
||||
@ -41,4 +34,4 @@ do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/license.txt ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (multitail-4.3.0.tgz) = 1e547e97affabbcf90fde950e2bfbf27
|
||||
SHA256 (multitail-4.3.0.tgz) = 7d40b412c4235f18e2f13948d607544fa9e7a16c4cb165b0a18443dd1ea1f43a
|
||||
SIZE (multitail-4.3.0.tgz) = 132563
|
||||
MD5 (multitail-5.0.0.tgz) = cf42c825f327a841202fad5151337cdb
|
||||
SHA256 (multitail-5.0.0.tgz) = 69e432ac3413c760eef43fc5280376bb164cb2e2d6f9b31225ec40b7a6706281
|
||||
SIZE (multitail-5.0.0.tgz) = 147307
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- config.c.orig Tue Apr 18 15:54:34 2006
|
||||
+++ config.c Sun Apr 30 18:19:00 2006
|
||||
@@ -40,6 +40,7 @@
|
||||
long long int kb_str_to_value(char *field, char *str)
|
||||
{
|
||||
char *mult;
|
||||
+ #define atoll(a) strtoll((a), (char **)NULL, 10)
|
||||
long long int bytes = atoll(str);
|
||||
if (bytes < -1)
|
||||
error_exit("%s: value cannot be < -1\n", field);
|
@ -1,18 +0,0 @@
|
||||
--- cv.c.orig Fri Sep 8 08:38:28 2006
|
||||
+++ cv.c Thu Sep 21 21:09:36 2006
|
||||
@@ -105,6 +105,7 @@
|
||||
|
||||
case CONVTYPE_EPOCHTODATE:
|
||||
{
|
||||
+ #define atoll(a) strtoll((a), (char **)NULL, 10)
|
||||
char *new_str = epoch_to_str((time_t)atoll(what));
|
||||
|
||||
if (new_str)
|
||||
@@ -131,6 +132,7 @@
|
||||
|
||||
case CONVTYPE_DECTOHEX:
|
||||
{
|
||||
+ #define atoll(a) strtoll((a), (char **)NULL, 10)
|
||||
long long int result = atoll(what);
|
||||
char result_str[128];
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- stripstring.c.orig Fri Sep 8 08:38:28 2006
|
||||
+++ stripstring.c Thu Sep 21 21:08:24 2006
|
||||
@@ -417,7 +417,7 @@
|
||||
|
||||
char do_strip_column(char *delimiter, int col_nr, char *in, char *strip_what)
|
||||
{
|
||||
- char changed = 0;;
|
||||
+ char changed = 0;
|
||||
char *p = in;
|
||||
int del_len = strlen(delimiter);
|
||||
int col_i;
|
Loading…
Reference in New Issue
Block a user