math/xtensor: Update 0.16.3 -> 0.16.4

Reported by:	portscout
This commit is contained in:
Yuri Victorovich 2018-06-23 16:40:32 +00:00
parent 95103f9423
commit d70ad3a313
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=473140
5 changed files with 11 additions and 10 deletions

View File

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= xtensor
DISTVERSION= 0.16.3
DISTVERSION= 0.16.4
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org

View File

@ -1,5 +1,5 @@
TIMESTAMP = 1528516496
SHA256 (QuantStack-xtensor-0.16.3_GH0.tar.gz) = 42167bae716ee1a897e616b5b143dab9a58167abc6f19b12008add6632437ff7
SIZE (QuantStack-xtensor-0.16.3_GH0.tar.gz) = 762095
TIMESTAMP = 1529768354
SHA256 (QuantStack-xtensor-0.16.4_GH0.tar.gz) = 9a0d9ec254383c1721473fb391e10f082eeceec4d0a7bf29fce9356c68949e74
SIZE (QuantStack-xtensor-0.16.4_GH0.tar.gz) = 777228
SHA256 (QuantStack-xtl-0.4.9_GH0.tar.gz) = 587251bb7787b7dd05a2d432712bb2a7f05411155c61a9bc4a0f69c7b4e85dc3
SIZE (QuantStack-xtl-0.4.9_GH0.tar.gz) = 81044

View File

@ -1,11 +1,11 @@
--- CMakeLists.txt.orig 2018-05-16 08:49:00 UTC
--- CMakeLists.txt.orig 2018-06-23 15:40:12 UTC
+++ CMakeLists.txt
@@ -28,9 +28,9 @@ message(STATUS "Building xtensor v${${PR
# Dependencies
# ============
-find_package(xtl 0.4.9 REQUIRED)
+#find_package(xtl 0.4.1 REQUIRED)
+#find_package(xtl 0.4.9 REQUIRED)
-message(STATUS "Found xtl: ${xtl_INCLUDE_DIRS}/xtl")
+message(STATUS "Found xtl: xtl/include")

View File

@ -1,4 +1,4 @@
--- test/CMakeLists.txt.orig 2018-03-13 17:07:19 UTC
--- test/CMakeLists.txt.orig 2018-06-22 15:12:37 UTC
+++ test/CMakeLists.txt
@@ -8,12 +8,13 @@
@ -19,7 +19,7 @@
message(STATUS "Forcing tests build type to Release")
set(CMAKE_BUILD_TYPE Release CACHE STRING "Choose the type of build." FORCE)
@@ -158,7 +158,7 @@ endforeach()
@@ -174,7 +175,7 @@ add_custom_target(
foreach(filename IN LISTS XTENSOR_TESTS)
string(REPLACE ".cpp" "" targetname ${filename})
add_executable(${targetname} ${COMMON_BASE} ${filename} ${XTENSOR_HEADERS})
@ -28,7 +28,7 @@
if(DOWNLOAD_GTEST OR GTEST_SRC_DIR)
add_dependencies(${targetname} gtest_main)
endif()
@@ -169,7 +169,7 @@ add_executable(${XTENSOR_TARGET} ${COMMO
@@ -188,6 +189,6 @@ add_executable(${XTENSOR_TARGET} ${COMMO
if(DOWNLOAD_GTEST OR GTEST_SRC_DIR)
add_dependencies(${XTENSOR_TARGET} gtest_main)
endif()
@ -36,4 +36,3 @@
+target_link_libraries(${XTENSOR_TARGET} ${GTEST_BOTH_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
add_custom_target(xtest COMMAND ${XTENSOR_TARGET} DEPENDS ${XTENSOR_TARGET})

View File

@ -33,6 +33,7 @@ include/xtensor/xoperation.hpp
include/xtensor/xoptional.hpp
include/xtensor/xoptional_assembly.hpp
include/xtensor/xoptional_assembly_base.hpp
include/xtensor/xoptional_assembly_storage.hpp
include/xtensor/xrandom.hpp
include/xtensor/xreducer.hpp
include/xtensor/xscalar.hpp
@ -42,6 +43,7 @@ include/xtensor/xslice.hpp
include/xtensor/xsort.hpp
include/xtensor/xstorage.hpp
include/xtensor/xstrided_view.hpp
include/xtensor/xstrided_view_base.hpp
include/xtensor/xstrides.hpp
include/xtensor/xtensor.hpp
include/xtensor/xtensor_config.hpp