New port: Coin-or Branch and Cut: mixed integer programming solver
This commit is contained in:
parent
bd336e50c1
commit
d709177109
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=467464
@ -139,6 +139,7 @@
|
|||||||
SUBDIR += calctool
|
SUBDIR += calctool
|
||||||
SUBDIR += cantor
|
SUBDIR += cantor
|
||||||
SUBDIR += cantor-kde4
|
SUBDIR += cantor-kde4
|
||||||
|
SUBDIR += cbc
|
||||||
SUBDIR += cblas
|
SUBDIR += cblas
|
||||||
SUBDIR += ccmath
|
SUBDIR += ccmath
|
||||||
SUBDIR += ceres-solver
|
SUBDIR += ceres-solver
|
||||||
|
29
math/cbc/Makefile
Normal file
29
math/cbc/Makefile
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
# $FreeBSD$
|
||||||
|
|
||||||
|
PORTNAME= cbc
|
||||||
|
DISTVERSIONPREFIX= releases/
|
||||||
|
DISTVERSION= 2.9.9
|
||||||
|
CATEGORIES= math
|
||||||
|
|
||||||
|
MAINTAINER= yuri@FreeBSD.org
|
||||||
|
COMMENT= Coin-or Branch and Cut: mixed integer programming solver
|
||||||
|
|
||||||
|
LICENSE= EPL
|
||||||
|
LICENSE_FILE= ${WRKSRC}/Cbc/LICENSE
|
||||||
|
|
||||||
|
LIB_DEPENDS= libblas.so:math/blas \
|
||||||
|
libCgl.so:math/cgl \
|
||||||
|
libClp.so:math/clp \
|
||||||
|
liblapack.so:math/lapack
|
||||||
|
|
||||||
|
USES= fortran gmake libtool pkgconfig
|
||||||
|
USE_GITHUB= yes
|
||||||
|
GH_ACCOUNT= coin-or
|
||||||
|
GH_PROJECT= Cbc
|
||||||
|
GNU_CONFIGURE= yes
|
||||||
|
USE_LDCONFIG= yes
|
||||||
|
|
||||||
|
post-install:
|
||||||
|
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
3
math/cbc/distinfo
Normal file
3
math/cbc/distinfo
Normal file
@ -0,0 +1,3 @@
|
|||||||
|
TIMESTAMP = 1522614939
|
||||||
|
SHA256 (coin-or-Cbc-releases-2.9.9_GH0.tar.gz) = 3760fa9fe24fe3390c8b3d5f03583a62652d9b159aef9b0b609e4948ef1b8f29
|
||||||
|
SIZE (coin-or-Cbc-releases-2.9.9_GH0.tar.gz) = 1658623
|
11
math/cbc/files/patch-Cbc_src_CbcModel.cpp
Normal file
11
math/cbc/files/patch-Cbc_src_CbcModel.cpp
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- Cbc/src/CbcModel.cpp.orig 2018-04-16 07:45:54 UTC
|
||||||
|
+++ Cbc/src/CbcModel.cpp
|
||||||
|
@@ -5338,7 +5338,7 @@ void CbcModel::branchAndBound(int doStat
|
||||||
|
OsiClpSolverInterface * clpSolver
|
||||||
|
= dynamic_cast<OsiClpSolverInterface *> (solver_);
|
||||||
|
if (clpSolver)
|
||||||
|
- clpSolver->setFakeObjective(reinterpret_cast<double *> (NULL));
|
||||||
|
+ clpSolver->setFakeObjective((double*)nullptr);
|
||||||
|
}
|
||||||
|
#endif
|
||||||
|
moreSpecialOptions_ = saveMoreSpecialOptions;
|
8
math/cbc/pkg-descr
Normal file
8
math/cbc/pkg-descr
Normal file
@ -0,0 +1,8 @@
|
|||||||
|
Cbc (Coin-or branch and cut) is an open-source mixed integer programming solver
|
||||||
|
written in C++. It can be used as a callable library or using a stand-alone
|
||||||
|
executable. It can be called through AMPL (natively), GAMS (using the links
|
||||||
|
provided by the Optimization Services and GAMSlinks projects), MPL (through the
|
||||||
|
CoinMP project), AIMMS (through the AIMMSlinks project), PuLP, CMPL, OpenSolver
|
||||||
|
for Excel, JuMP, or MiniZinc.
|
||||||
|
|
||||||
|
WWW: https://projects.coin-or.org/Cbc
|
92
math/cbc/pkg-plist
Normal file
92
math/cbc/pkg-plist
Normal file
@ -0,0 +1,92 @@
|
|||||||
|
bin/cbc
|
||||||
|
include/coin/CbcBranchActual.hpp
|
||||||
|
include/coin/CbcBranchAllDifferent.hpp
|
||||||
|
include/coin/CbcBranchBase.hpp
|
||||||
|
include/coin/CbcBranchCut.hpp
|
||||||
|
include/coin/CbcBranchDecision.hpp
|
||||||
|
include/coin/CbcBranchDefaultDecision.hpp
|
||||||
|
include/coin/CbcBranchDynamic.hpp
|
||||||
|
include/coin/CbcBranchLotsize.hpp
|
||||||
|
include/coin/CbcBranchToFixLots.hpp
|
||||||
|
include/coin/CbcBranchingObject.hpp
|
||||||
|
include/coin/CbcClique.hpp
|
||||||
|
include/coin/CbcCompare.hpp
|
||||||
|
include/coin/CbcCompareActual.hpp
|
||||||
|
include/coin/CbcCompareBase.hpp
|
||||||
|
include/coin/CbcCompareDefault.hpp
|
||||||
|
include/coin/CbcCompareDepth.hpp
|
||||||
|
include/coin/CbcCompareEstimate.hpp
|
||||||
|
include/coin/CbcCompareObjective.hpp
|
||||||
|
include/coin/CbcConfig.h
|
||||||
|
include/coin/CbcConsequence.hpp
|
||||||
|
include/coin/CbcCountRowCut.hpp
|
||||||
|
include/coin/CbcCutGenerator.hpp
|
||||||
|
include/coin/CbcCutModifier.hpp
|
||||||
|
include/coin/CbcCutSubsetModifier.hpp
|
||||||
|
include/coin/CbcDummyBranchingObject.hpp
|
||||||
|
include/coin/CbcEventHandler.hpp
|
||||||
|
include/coin/CbcFathom.hpp
|
||||||
|
include/coin/CbcFathomDynamicProgramming.hpp
|
||||||
|
include/coin/CbcFeasibilityBase.hpp
|
||||||
|
include/coin/CbcFixVariable.hpp
|
||||||
|
include/coin/CbcFollowOn.hpp
|
||||||
|
include/coin/CbcFullNodeInfo.hpp
|
||||||
|
include/coin/CbcGeneral.hpp
|
||||||
|
include/coin/CbcGeneralDepth.hpp
|
||||||
|
include/coin/CbcHeuristic.hpp
|
||||||
|
include/coin/CbcHeuristicDINS.hpp
|
||||||
|
include/coin/CbcHeuristicDW.hpp
|
||||||
|
include/coin/CbcHeuristicDive.hpp
|
||||||
|
include/coin/CbcHeuristicDiveCoefficient.hpp
|
||||||
|
include/coin/CbcHeuristicDiveFractional.hpp
|
||||||
|
include/coin/CbcHeuristicDiveGuided.hpp
|
||||||
|
include/coin/CbcHeuristicDiveLineSearch.hpp
|
||||||
|
include/coin/CbcHeuristicDivePseudoCost.hpp
|
||||||
|
include/coin/CbcHeuristicDiveVectorLength.hpp
|
||||||
|
include/coin/CbcHeuristicFPump.hpp
|
||||||
|
include/coin/CbcHeuristicGreedy.hpp
|
||||||
|
include/coin/CbcHeuristicLocal.hpp
|
||||||
|
include/coin/CbcHeuristicPivotAndFix.hpp
|
||||||
|
include/coin/CbcHeuristicRENS.hpp
|
||||||
|
include/coin/CbcHeuristicRINS.hpp
|
||||||
|
include/coin/CbcHeuristicRandRound.hpp
|
||||||
|
include/coin/CbcHeuristicVND.hpp
|
||||||
|
include/coin/CbcLinked.hpp
|
||||||
|
include/coin/CbcMessage.hpp
|
||||||
|
include/coin/CbcMipStartIO.hpp
|
||||||
|
include/coin/CbcModel.hpp
|
||||||
|
include/coin/CbcNWay.hpp
|
||||||
|
include/coin/CbcNode.hpp
|
||||||
|
include/coin/CbcNodeInfo.hpp
|
||||||
|
include/coin/CbcObject.hpp
|
||||||
|
include/coin/CbcObjectUpdateData.hpp
|
||||||
|
include/coin/CbcParam.hpp
|
||||||
|
include/coin/CbcPartialNodeInfo.hpp
|
||||||
|
include/coin/CbcSOS.hpp
|
||||||
|
include/coin/CbcSimpleInteger.hpp
|
||||||
|
include/coin/CbcSimpleIntegerDynamicPseudoCost.hpp
|
||||||
|
include/coin/CbcSimpleIntegerPseudoCost.hpp
|
||||||
|
include/coin/CbcSolver.hpp
|
||||||
|
include/coin/CbcStrategy.hpp
|
||||||
|
include/coin/CbcSubProblem.hpp
|
||||||
|
include/coin/CbcTree.hpp
|
||||||
|
include/coin/CbcTreeLocal.hpp
|
||||||
|
include/coin/Cbc_C_Interface.h
|
||||||
|
include/coin/ClpAmplObjective.hpp
|
||||||
|
include/coin/ClpConstraintAmpl.hpp
|
||||||
|
include/coin/OsiCbcSolverInterface.hpp
|
||||||
|
lib/libCbc.so
|
||||||
|
lib/libCbc.so.3
|
||||||
|
lib/libCbc.so.3.9.9
|
||||||
|
lib/libCbcSolver.so
|
||||||
|
lib/libCbcSolver.so.3
|
||||||
|
lib/libCbcSolver.so.3.9.9
|
||||||
|
lib/libOsiCbc.so
|
||||||
|
lib/libOsiCbc.so.3
|
||||||
|
lib/libOsiCbc.so.3.9.9
|
||||||
|
libdata/pkgconfig/cbc.pc
|
||||||
|
libdata/pkgconfig/osi-cbc.pc
|
||||||
|
share/coin/doc/Cbc/AUTHORS
|
||||||
|
share/coin/doc/Cbc/LICENSE
|
||||||
|
share/coin/doc/Cbc/README
|
||||||
|
share/coin/doc/Cbc/cbc_addlibs.txt
|
Loading…
Reference in New Issue
Block a user