GUI program to semi-automatically download album cover images for a music

collection. It will work through a specified music directory, and for each
subdirectory will download a set of corresponding (best guess) album covers.
The naming format of the subdirectories can be configured, as can the
location to save the results, such as .desktop-entry files, folder.jpg
files, mp3 tags, etc.

WWW: http://www.unrealvoodoo.org/hiteck/projects/albumart/

PR:		ports/126883
Submitted by:	Timothy Bourke <timbob at bigpond.com>
This commit is contained in:
Martin Wilke 2008-09-05 14:16:32 +00:00
parent cdf00acdd4
commit d6dc2addd2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=219921
6 changed files with 107 additions and 0 deletions

View File

@ -24,6 +24,7 @@
SUBDIR += akode-plugins-resampler
SUBDIR += akode-plugins-xiph
SUBDIR += alac
SUBDIR += albumart
SUBDIR += alienwah
SUBDIR += amarok
SUBDIR += amarok-fs

31
audio/albumart/Makefile Normal file
View File

@ -0,0 +1,31 @@
# New ports collection makefile for: albumart
# Date created: 27 Aug 2008
# Whom: Timothy Bourke <timbob@bigpond.com>
#
# $FreeBSD$
#
PORTNAME= albumart
PORTVERSION= 1.6.6
CATEGORIES= audio python
MASTER_SITES= http://muksuluuri.ath.cx/~skyostil/projects/albumart/dist/
MAINTAINER= timbob@bigpond.com
COMMENT= GUI application for downloading album cover art
USE_GMAKE= yes
USE_PYTHON= 2.3+
USE_PYDISTUTILS=yes
RUN_DEPENDS+= py*-qt>=3.1:${PORTSDIR}/x11-toolkits/py-qt
RUN_DEPENDS+= py*-imaging>=1.1:${PORTSDIR}/graphics/py-imaging
post-patch:
${CP} ${WRKSRC}/bin/albumart-qt ${WRKSRC}/bin/albumart-qt.orig
echo "#!${PYTHON_CMD}" > ${WRKSRC}/bin/albumart-qt
${TAIL} -n +2 ${WRKSRC}/bin/albumart-qt.orig >> ${WRKSRC}/bin/albumart-qt
${CP} ${WRKSRC}/setup.py ${WRKSRC}/setup.py.orig
${SED} -e "s/os.system(\"make\")/os.system(\"${GMAKE}\")/" \
${WRKSRC}/setup.py.orig > ${WRKSRC}/setup.py
.include <bsd.port.mk>

3
audio/albumart/distinfo Normal file
View File

@ -0,0 +1,3 @@
MD5 (albumart-1.6.6.tar.gz) = 445a487eea4b8e41e85b47134edb330a
SHA256 (albumart-1.6.6.tar.gz) = de2e7e344e0fa1ebdf593099af9a365230d2a467b02364b1f9be6b2f023cae8e
SIZE (albumart-1.6.6.tar.gz) = 443415

View File

@ -0,0 +1,10 @@
--- setup.py.orig 2008-08-27 21:01:10.000000000 +1000
+++ setup.py 2008-08-27 21:01:24.000000000 +1000
@@ -51,7 +51,6 @@
'lib/albumart/yahoo/search/webservices.py',
'lib/albumart/yahoo/search/version.py',
]),
- ('share/doc/albumart', ['README', 'TODO', 'CHANGELOG']),
]
)

8
audio/albumart/pkg-descr Normal file
View File

@ -0,0 +1,8 @@
GUI program to semi-automatically download album cover images for a music
collection. It will work through a specified music directory, and for each
subdirectory will download a set of corresponding (best guess) album covers.
The naming format of the subdirectories can be configured, as can the
location to save the results, such as .desktop-entry files, folder.jpg
files, mp3 tags, etc.
WWW: http://www.unrealvoodoo.org/hiteck/projects/albumart/

54
audio/albumart/pkg-plist Normal file
View File

@ -0,0 +1,54 @@
bin/albumart-qt
lib/albumart/albumart_source_buy.py
lib/albumart/event.py
lib/albumart/config.py
lib/albumart/albumart_source_amazon.py
lib/albumart/albumart_images.py
lib/albumart/albumart_source_yahoo.py
lib/albumart/albumart_configuration_dialog.py
lib/albumart/albumart_dialog_base.py
lib/albumart/albumart_target_freedesktop.py
lib/albumart/albumart_target_id3v2.py
lib/albumart/albumart_target_windows.py
lib/albumart/albumart_progress_widget.py
lib/albumart/albumart_string_list_widget.py
lib/albumart/albumart_about_dialog_base.py
lib/albumart/id3/__init__.py
lib/albumart/id3/binfuncs.py
lib/albumart/id3/ID3v2Frames.py
lib/albumart/items.py
lib/albumart/albumart_about_dialog.py
lib/albumart/albumart_exception_dialog.py
lib/albumart/albumart_configuration_dialog_base.py
lib/albumart/albumart.py
lib/albumart/albumart_recognizer_path.py
lib/albumart/albumart_exception_dialog_base.py
lib/albumart/amazon.py
lib/albumart/albumart_source_walmart.py
lib/albumart/pixmap.py
lib/albumart/albumart_target_generic.py
lib/albumart/albumart_recognizer_id3v2.py
lib/albumart/albumart_dialog.py
lib/albumart/albumart_unattended_ui.py
lib/albumart/albumart_string_list_widget_base.py
lib/albumart/version.py
lib/albumart/process.py
lib/albumart/yahoo/__init__.py
lib/albumart/yahoo/search/domparsers.py
lib/albumart/yahoo/search/debug.py
lib/albumart/yahoo/search/__init__.py
lib/albumart/yahoo/search/webservices.py
lib/albumart/yahoo/search/version.py
share/pixmaps/albumart.png
share/applnk/Multimedia/albumart.desktop
share/apps/konqueror/servicemenus/albumart_set_cover_image.desktop
@dirrmtry share/doc/albumart
@dirrmtry share/apps/konqueror/servicemenus
@dirrmtry share/apps/konqueror
@dirrmtry share/apps
@dirrmtry share/applnk/Multimedia
@dirrmtry share/applnk
@dirrmtry lib/albumart/yahoo/search
@dirrmtry lib/albumart/yahoo
@dirrmtry lib/albumart/id3
@dirrmtry lib/albumart