multimedia/x264: update to 0.155.2917
- HI10P is always built after https://git.videolan.org/?p=x264.git;a=commitdiff;h=71ed44c73124 Changes: https://git.videolan.org/?p=x264.git;a=shortlog;h=0a84d986e7020f8344f00752e3600b9769cc1e85 ABI: https://abi-laboratory.pro/tracker/timeline/x264/
This commit is contained in:
parent
8d1b00716f
commit
d6bccda8d9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=476802
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= avidemux
|
||||
PORTVERSION= ${AVIDEMUX_VERSION}
|
||||
PORTREVISION= 8
|
||||
PORTREVISION= 9
|
||||
CATEGORIES= multimedia
|
||||
PKGNAMESUFFIX= -plugins
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
PORTNAME= ccextractor
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.85
|
||||
PORTREVISION= 7
|
||||
PORTREVISION= 8
|
||||
CATEGORIES= multimedia
|
||||
|
||||
MAINTAINER= oz@nixil.net
|
||||
|
@ -3,6 +3,7 @@
|
||||
PORTNAME= cinelerra-gg
|
||||
DISTVERSION= 5.1-20180714
|
||||
DISTVERSIONSUFFIX= -${REV:C/(.......).*/\1/}
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= https://git.cinelerra-cv.org/gitweb?p=goodguy/cinelerra.git;a=snapshot;h=${REV};sf=tgz;dummy=/ # tarballs are @ https://cinelerra-cv.org/five/pkgs/src/
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= ffmpeg
|
||||
PORTVERSION= 4.0.2
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= multimedia audio ipv6 net
|
||||
MASTER_SITES= https://ffmpeg.org/releases/
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= ffmpeg
|
||||
PORTVERSION= 0.7.17
|
||||
PORTREVISION= 14
|
||||
PORTREVISION= 15
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= multimedia audio ipv6 net
|
||||
MASTER_SITES= http://ffmpeg.org/releases/
|
||||
|
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
# $MCom: ports/multimedia/gstreamer-plugins-x264/Makefile,v 1.3 2008/03/19 14:05:37 ahze Exp $
|
||||
|
||||
PORTREVISION= 7
|
||||
PORTREVISION= 8
|
||||
CATEGORIES= multimedia
|
||||
|
||||
COMMENT= Gstreamer x264 plugin
|
||||
|
@ -0,0 +1,95 @@
|
||||
From 83c38dc44622611c1f67dd26e4cb383c5aef90f6 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Tim-Philipp=20M=C3=BCller?= <tim@centricular.com>
|
||||
Date: Wed, 28 Feb 2018 10:07:13 +0000
|
||||
Subject: x264enc: fix build with newer x264 with support for multiple bit
|
||||
depths
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
libx264 used to be built for one specific bit depth, and if we
|
||||
wanted to support multiple bit depths we would have to dynamically
|
||||
load the right .so from different paths. That has changed now, and
|
||||
libx264 can include support for multiple depths in the same lib,
|
||||
so we don't need to do the dlopen() dance any more. We'll keep
|
||||
the vtable stuff around until we can drop support for older x264.
|
||||
|
||||
gstx264enc.c:2927:36: error: ‘x264_bit_depth’ undeclared
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=792111
|
||||
|
||||
--- ext/x264/gstx264enc.c.orig 2017-07-25 08:26:28 UTC
|
||||
+++ ext/x264/gstx264enc.c
|
||||
@@ -117,7 +117,9 @@ struct _GstX264EncVTable
|
||||
{
|
||||
GModule *module;
|
||||
|
||||
+#if X264_BUILD < 153
|
||||
const int *x264_bit_depth;
|
||||
+#endif
|
||||
const int *x264_chroma_format;
|
||||
void (*x264_encoder_close) (x264_t *);
|
||||
int (*x264_encoder_delayed_frames) (x264_t *);
|
||||
@@ -170,8 +172,9 @@ load_x264 (const gchar * filename)
|
||||
"' from '%s'. Incompatible version?", filename);
|
||||
goto error;
|
||||
}
|
||||
-
|
||||
+#if X264_BUILD < 153
|
||||
LOAD_SYMBOL (x264_bit_depth);
|
||||
+#endif
|
||||
LOAD_SYMBOL (x264_chroma_format);
|
||||
LOAD_SYMBOL (x264_encoder_close);
|
||||
LOAD_SYMBOL (x264_encoder_delayed_frames);
|
||||
@@ -288,6 +291,7 @@ gst_x264_enc_add_x264_chroma_format (GstStructure * s,
|
||||
return ret;
|
||||
}
|
||||
|
||||
+#if X264_BUILD < 153
|
||||
static gboolean
|
||||
load_x264_libraries (void)
|
||||
{
|
||||
@@ -326,6 +330,33 @@ load_x264_libraries (void)
|
||||
return TRUE;
|
||||
}
|
||||
|
||||
+#else /* X264_BUILD >= 153 */
|
||||
+
|
||||
+static gboolean
|
||||
+load_x264_libraries (void)
|
||||
+{
|
||||
+#if X264_BIT_DEPTH == 0 /* all */
|
||||
+ vtable_8bit = &default_vtable;
|
||||
+ vtable_10bit = &default_vtable;
|
||||
+#elif X264_BIT_DEPTH == 8
|
||||
+ vtable_8bit = &default_vtable;
|
||||
+#elif X264_BIT_DEPTH == 10
|
||||
+ vtable_10bit = &default_vtable;
|
||||
+#else
|
||||
+#error "unexpected X264_BIT_DEPTH value"
|
||||
+#endif
|
||||
+
|
||||
+#ifdef HAVE_X264_ADDITIONAL_LIBRARIES
|
||||
+ GST_WARNING ("Ignoring configured additional libraries %s, using libx264 "
|
||||
+ "version enabled for multiple bit depths",
|
||||
+ HAVE_X264_ADDITIONAL_LIBRARIES);
|
||||
+#endif
|
||||
+
|
||||
+ return TRUE;
|
||||
+}
|
||||
+
|
||||
+#endif
|
||||
+
|
||||
enum
|
||||
{
|
||||
ARG_0,
|
||||
@@ -2897,7 +2928,9 @@ plugin_init (GstPlugin * plugin)
|
||||
* if needed. We can't initialize statically because these values are not
|
||||
* constant on Windows. */
|
||||
default_vtable.module = NULL;
|
||||
+#if X264_BUILD < 153
|
||||
default_vtable.x264_bit_depth = &x264_bit_depth;
|
||||
+#endif
|
||||
default_vtable.x264_chroma_format = &x264_chroma_format;
|
||||
default_vtable.x264_encoder_close = x264_encoder_close;
|
||||
default_vtable.x264_encoder_delayed_frames = x264_encoder_delayed_frames;
|
@ -1,6 +1,6 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= multimedia
|
||||
|
||||
COMMENT= GStreamer libx264 based H264 plugin
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= handbrake
|
||||
DISTVERSION= 1.1.1
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= multimedia
|
||||
DIST_SUBDIR= ${PORTNAME}
|
||||
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= libav
|
||||
PORTVERSION= 12.1
|
||||
PORTREVISION= 6
|
||||
PORTREVISION= 7
|
||||
CATEGORIES= multimedia audio ipv6 net
|
||||
MASTER_SITES= http://libav.org/releases/
|
||||
|
||||
|
72
multimedia/libav/files/patch-libavcodec_libx264.c
Normal file
72
multimedia/libav/files/patch-libavcodec_libx264.c
Normal file
@ -0,0 +1,72 @@
|
||||
https://git.libav.org/?p=libav.git;a=commitdiff;h=c6558e8840fb
|
||||
|
||||
--- libavcodec/libx264.c.orig 2017-05-14 19:25:01 UTC
|
||||
+++ libavcodec/libx264.c
|
||||
@@ -243,7 +243,11 @@ static int X264_frame(AVCodecContext *ctx, AVPacket *p
|
||||
|
||||
x264_picture_init( &x4->pic );
|
||||
x4->pic.img.i_csp = x4->params.i_csp;
|
||||
+#if X264_BUILD >= 153
|
||||
+ if (x4->params.i_bitdepth > 8)
|
||||
+#else
|
||||
if (x264_bit_depth > 8)
|
||||
+#endif
|
||||
x4->pic.img.i_csp |= X264_CSP_HIGH_DEPTH;
|
||||
x4->pic.img.i_plane = 3;
|
||||
|
||||
@@ -395,6 +399,9 @@ static av_cold int X264_init(AVCodecContext *avctx)
|
||||
x4->params.p_log_private = avctx;
|
||||
x4->params.i_log_level = X264_LOG_DEBUG;
|
||||
x4->params.i_csp = convert_pix_fmt(avctx->pix_fmt);
|
||||
+#if X264_BUILD >= 153
|
||||
+ x4->params.i_bitdepth = av_pix_fmt_desc_get(avctx->pix_fmt)->comp[0].depth;
|
||||
+#endif
|
||||
|
||||
if (avctx->bit_rate) {
|
||||
x4->params.rc.i_bitrate = avctx->bit_rate / 1000;
|
||||
@@ -675,6 +682,7 @@ FF_ENABLE_DEPRECATION_WARNINGS
|
||||
return 0;
|
||||
}
|
||||
|
||||
+#if X264_BUILD < 153
|
||||
static const enum AVPixelFormat pix_fmts_8bit[] = {
|
||||
AV_PIX_FMT_YUV420P,
|
||||
AV_PIX_FMT_YUVJ420P,
|
||||
@@ -701,15 +709,37 @@ static const enum AVPixelFormat pix_fmts_10bit[] = {
|
||||
AV_PIX_FMT_NV20,
|
||||
AV_PIX_FMT_NONE
|
||||
};
|
||||
+#else
|
||||
+static const enum AVPixelFormat pix_fmts_all[] = {
|
||||
+ AV_PIX_FMT_YUV420P,
|
||||
+ AV_PIX_FMT_YUVJ420P,
|
||||
+ AV_PIX_FMT_YUV422P,
|
||||
+ AV_PIX_FMT_YUVJ422P,
|
||||
+ AV_PIX_FMT_YUV444P,
|
||||
+ AV_PIX_FMT_YUVJ444P,
|
||||
+ AV_PIX_FMT_NV12,
|
||||
+ AV_PIX_FMT_NV16,
|
||||
+ AV_PIX_FMT_NV21,
|
||||
+ AV_PIX_FMT_YUV420P10,
|
||||
+ AV_PIX_FMT_YUV422P10,
|
||||
+ AV_PIX_FMT_YUV444P10,
|
||||
+ AV_PIX_FMT_NV20,
|
||||
+ AV_PIX_FMT_NONE
|
||||
+};
|
||||
+#endif
|
||||
|
||||
static av_cold void X264_init_static(AVCodec *codec)
|
||||
{
|
||||
+#if X264_BUILD < 153
|
||||
if (x264_bit_depth == 8)
|
||||
codec->pix_fmts = pix_fmts_8bit;
|
||||
else if (x264_bit_depth == 9)
|
||||
codec->pix_fmts = pix_fmts_9bit;
|
||||
else if (x264_bit_depth == 10)
|
||||
codec->pix_fmts = pix_fmts_10bit;
|
||||
+#else
|
||||
+ codec->pix_fmts = pix_fmts_all;
|
||||
+#endif
|
||||
}
|
||||
|
||||
#define OFFSET(x) offsetof(X264Context, x)
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= libquicktime
|
||||
PORTVERSION= 1.2.4
|
||||
PORTREVISION?= 20
|
||||
PORTREVISION?= 21
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= SF
|
||||
|
||||
|
@ -14,7 +14,7 @@ LIB_DEPENDS= #
|
||||
|
||||
USES= pathfix
|
||||
|
||||
OPTIONS_DEFINE= ASM HI10P OPENCL
|
||||
OPTIONS_DEFINE= ASM OPENCL
|
||||
OPTIONS_DEFAULT= ASM OPENCL
|
||||
OPTIONS_EXCLUDE= FFMS GPAC LAVF LSMASH SWSCALE
|
||||
|
||||
@ -23,9 +23,6 @@ ASM_BUILD_DEPENDS_amd64=${ASM_BUILD_DEPENDS_i386}
|
||||
ASM_BUILD_DEPENDS_i386= nasm>=2.13:devel/nasm
|
||||
ASM_CONFIGURE_ENABLE= asm
|
||||
|
||||
HI10P_DESC= Enable High 10 Profile 10-bit encoding
|
||||
HI10P_CONFIGURE_ON= --bit-depth=10
|
||||
|
||||
OPENCL_BUILD_DEPENDS= ${LOCALBASE}/include/CL/opencl.h:devel/opencl
|
||||
OPENCL_CONFIGURE_ENABLE=opencl
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= mencoder
|
||||
PORTVERSION= ${MPLAYER_PORT_VERSION}.${MPLAYER_SNAPSHOT_DATE:S/-//g}
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= multimedia audio
|
||||
|
||||
MAINTAINER= riggs@FreeBSD.org
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= mpeg4ip
|
||||
PORTVERSION= 1.6.1
|
||||
PORTREVISION= 41
|
||||
PORTREVISION= 42
|
||||
CATEGORIES= multimedia audio ipv6 net
|
||||
MASTER_SITES= LOCAL/ahze
|
||||
# http://sourceforge.net/forum/forum.php?thread_id=1839453&forum_id=59136
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= msx264
|
||||
PORTVERSION= 1.5.2
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= multimedia net
|
||||
MASTER_SITES= SAVANNAH/linphone/plugins/sources/
|
||||
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= obs-studio
|
||||
DISTVERSION= 21.1.2
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= multimedia
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= transcode
|
||||
PORTVERSION= 1.1.7
|
||||
PORTREVISION= 34
|
||||
PORTREVISION= 35
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= https://bitbucket.org/france/transcode-tcforge/downloads/
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= vlc
|
||||
DISTVERSION= 2.2.8
|
||||
PORTREVISION= 8
|
||||
PORTREVISION= 9
|
||||
PORTEPOCH= 4
|
||||
CATEGORIES= multimedia audio ipv6 net www
|
||||
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/a$//}/ \
|
||||
|
204
multimedia/vlc/files/patch-git_a8953ba
Normal file
204
multimedia/vlc/files/patch-git_a8953ba
Normal file
@ -0,0 +1,204 @@
|
||||
commit a8953ba707cca1f2de372ca24513296bcfcdaaa8
|
||||
Author: Ilkka Ollakka <ileoo@videolan.org>
|
||||
Date: Sat Mar 24 13:23:33 2018 +0200
|
||||
|
||||
x264: drop <148 build support and fix 10bit support
|
||||
|
||||
Drop old #if as 148 is not that recent anymore.
|
||||
|
||||
fixes #19581
|
||||
---
|
||||
modules/codec/x264.c | 65 ++++++++--------------------------------------------
|
||||
1 file changed, 10 insertions(+), 55 deletions(-)
|
||||
|
||||
diff --git modules/codec/x264.c modules/codec/x264.c
|
||||
index be5d0006de..96a4b08524 100644
|
||||
--- modules/codec/x264.c
|
||||
+++ modules/codec/x264.c
|
||||
@@ -83,13 +83,7 @@ static void x264_log( void *, int i_level, const char *psz, va_list );
|
||||
"I-frames, but do not start a new GOP." )
|
||||
|
||||
#define OPENGOP_TEXT N_("Use recovery points to close GOPs")
|
||||
-#if X264_BUILD < 115
|
||||
-#define OPENGOP_LONGTEXT N_("none: use closed GOPs only\n"\
|
||||
- "normal: use standard open GOPs\n" \
|
||||
- "bluray: use Blu-ray compatible open GOPs" )
|
||||
-#else
|
||||
#define OPENGOP_LONGTEXT N_("use open GOP, for bluray compatibility use also bluray-compat option")
|
||||
-#endif
|
||||
|
||||
#define BLURAY_TEXT N_("Enable compatibility hacks for Blu-ray support")
|
||||
#define BLURAY_LONGTEXT N_("Enable hacks for Blu-ray support, this doesn't enforce every aspect of Blu-ray compatibility\n" \
|
||||
@@ -471,16 +465,10 @@ vlc_module_begin ()
|
||||
add_integer( SOUT_CFG_PREFIX "min-keyint", 25, MIN_KEYINT_TEXT,
|
||||
MIN_KEYINT_LONGTEXT, true )
|
||||
|
||||
-#if X264_BUILD >= 102 && X264_BUILD <= 114
|
||||
- add_string( SOUT_CFG_PREFIX "opengop", "none", OPENGOP_TEXT,
|
||||
- OPENGOP_LONGTEXT, true )
|
||||
- change_string_list( x264_open_gop_names, x264_open_gop_names )
|
||||
-#elif X264_BUILD > 114
|
||||
add_bool( SOUT_CFG_PREFIX "opengop", false, OPENGOP_TEXT,
|
||||
OPENGOP_LONGTEXT, true )
|
||||
add_bool( SOUT_CFG_PREFIX "bluray-compat", false, BLURAY_TEXT,
|
||||
BLURAY_LONGTEXT, true )
|
||||
-#endif
|
||||
|
||||
add_integer( SOUT_CFG_PREFIX "scenecut", 40, SCENE_TEXT,
|
||||
SCENE_LONGTEXT, true )
|
||||
@@ -500,13 +488,8 @@ vlc_module_begin ()
|
||||
B_BIAS_LONGTEXT, true )
|
||||
change_integer_range( -100, 100 )
|
||||
|
||||
-#if X264_BUILD >= 87
|
||||
add_string( SOUT_CFG_PREFIX "bpyramid", "normal", BPYRAMID_TEXT,
|
||||
BPYRAMID_LONGTEXT, true )
|
||||
-#else
|
||||
- add_string( SOUT_CFG_PREFIX "bpyramid", "none", BPYRAMID_TEXT,
|
||||
- BPYRAMID_LONGTEXT, true )
|
||||
-#endif
|
||||
change_string_list( bpyramid_list, bpyramid_list )
|
||||
|
||||
add_bool( SOUT_CFG_PREFIX "cabac", true, CABAC_TEXT, CABAC_LONGTEXT,
|
||||
@@ -543,22 +526,18 @@ vlc_module_begin ()
|
||||
add_bool( SOUT_CFG_PREFIX "interlaced", false, INTERLACED_TEXT, INTERLACED_LONGTEXT,
|
||||
true )
|
||||
|
||||
-#if X264_BUILD >= 111
|
||||
add_integer( SOUT_CFG_PREFIX "frame-packing", -1, FRAMEPACKING_TEXT, FRAMEPACKING_LONGTEXT, true )
|
||||
change_integer_list( framepacking_list, framepacking_list_text )
|
||||
change_integer_range( -1, 5)
|
||||
-#endif
|
||||
|
||||
add_integer( SOUT_CFG_PREFIX "slices", 0, SLICE_COUNT, SLICE_COUNT_LONGTEXT, true )
|
||||
add_integer( SOUT_CFG_PREFIX "slice-max-size", 0, SLICE_MAX_SIZE, SLICE_MAX_SIZE_LONGTEXT, true )
|
||||
add_integer( SOUT_CFG_PREFIX "slice-max-mbs", 0, SLICE_MAX_MBS, SLICE_MAX_MBS_LONGTEXT, true )
|
||||
|
||||
-#if X264_BUILD >= 89
|
||||
add_string( SOUT_CFG_PREFIX "hrd", "none", HRD_TEXT, HRD_TEXT, true )
|
||||
vlc_config_set (VLC_CONFIG_LIST,
|
||||
(sizeof(x264_nal_hrd_names) / sizeof (char*)) - 1,
|
||||
x264_nal_hrd_names, x264_nal_hrd_names);
|
||||
-#endif
|
||||
|
||||
|
||||
/* Ratecontrol */
|
||||
@@ -843,20 +822,14 @@ static int Open ( vlc_object_t *p_this )
|
||||
fullrange = var_GetBool( p_enc, SOUT_CFG_PREFIX "fullrange" );
|
||||
p_enc->fmt_in.i_codec = fullrange ? VLC_CODEC_J420 : VLC_CODEC_I420;
|
||||
p_sys->i_colorspace = X264_CSP_I420;
|
||||
-#if X264_BUILD >= 118
|
||||
char *psz_profile = var_GetString( p_enc, SOUT_CFG_PREFIX "profile" );
|
||||
- if( psz_profile )
|
||||
- {
|
||||
- const int mask = x264_bit_depth > 8 ? X264_CSP_HIGH_DEPTH : 0;
|
||||
-
|
||||
-
|
||||
# ifdef MODULE_NAME_IS_x26410b
|
||||
- if( mask == 0)
|
||||
- {
|
||||
- msg_Err( p_enc, "Only high bith depth encoding supported, bit depth:%d", x264_bit_depth);
|
||||
- return VLC_EGENERIC;
|
||||
- }
|
||||
+ const int mask = X264_CSP_HIGH_DEPTH;
|
||||
+# else
|
||||
+ const int mask = 0;
|
||||
# endif
|
||||
+ if( psz_profile )
|
||||
+ {
|
||||
|
||||
if( !strcmp( psz_profile, "high10" ) )
|
||||
{
|
||||
@@ -879,7 +852,6 @@ static int Open ( vlc_object_t *p_this )
|
||||
msg_Err( p_enc, "Only high-profiles and 10-bit are supported");
|
||||
return VLC_EGENERIC;
|
||||
}
|
||||
-
|
||||
# endif
|
||||
}
|
||||
# ifdef MODULE_NAME_IS_x26410b
|
||||
@@ -890,7 +862,6 @@ static int Open ( vlc_object_t *p_this )
|
||||
}
|
||||
# endif
|
||||
free( psz_profile );
|
||||
-#endif //X264_BUILD
|
||||
|
||||
p_enc->pf_encode_video = Encode;
|
||||
p_enc->pf_encode_audio = NULL;
|
||||
@@ -913,6 +884,10 @@ static int Open ( vlc_object_t *p_this )
|
||||
#else
|
||||
x264_param_default( &p_sys->param );
|
||||
x264_param_default_preset( &p_sys->param, psz_preset, psz_tune );
|
||||
+# if X264_BUILD > 152
|
||||
+ if( mask )
|
||||
+ p_sys->param.i_bitdepth = 10;
|
||||
+# endif
|
||||
#endif
|
||||
free( psz_preset );
|
||||
free( psz_tune );
|
||||
@@ -1045,10 +1020,8 @@ static int Open ( vlc_object_t *p_this )
|
||||
if( fabs( var_GetFloat( p_enc, SOUT_CFG_PREFIX "aq-strength" ) - 1.0) > 0.005 )
|
||||
p_sys->param.rc.f_aq_strength = var_GetFloat( p_enc, SOUT_CFG_PREFIX "aq-strength" );
|
||||
|
||||
-#if X264_BUILD >= 111
|
||||
if( var_GetInteger( p_enc, SOUT_CFG_PREFIX "frame-packing" ) > -1 )
|
||||
p_sys->param.i_frame_packing = var_GetInteger( p_enc, SOUT_CFG_PREFIX "frame-packing" );
|
||||
-#endif
|
||||
|
||||
if( var_GetBool( p_enc, SOUT_CFG_PREFIX "verbose" ) )
|
||||
p_sys->param.i_log_level = X264_LOG_DEBUG;
|
||||
@@ -1064,26 +1037,14 @@ static int Open ( vlc_object_t *p_this )
|
||||
|
||||
i_val = var_GetInteger( p_enc, SOUT_CFG_PREFIX "keyint" );
|
||||
if( i_val > 0 && i_val != 250 ) p_sys->param.i_keyint_max = i_val;
|
||||
-#if X264_BUILD >= 102
|
||||
if( i_val == -1 ) p_sys->param.i_keyint_max = X264_KEYINT_MAX_INFINITE;
|
||||
-#endif
|
||||
|
||||
i_val = var_GetInteger( p_enc, SOUT_CFG_PREFIX "min-keyint" );
|
||||
if( i_val > 0 && i_val != 25 ) p_sys->param.i_keyint_min = i_val;
|
||||
|
||||
-#if X264_BUILD >= 102 && X264_BUILD <= 114
|
||||
- psz_val = var_GetString( p_enc, SOUT_CFG_PREFIX "opengop" );
|
||||
- if( !strcmp( psz_val, "none" ) )
|
||||
- p_sys->param.i_open_gop = X264_OPEN_GOP_NONE;
|
||||
- else if( !strcmp( psz_val, "normal" ) )
|
||||
- p_sys->param.i_open_gop = X264_OPEN_GOP_NORMAL;
|
||||
- else if( !strcmp( psz_val, "bluray" ) )
|
||||
- p_sys->param.i_open_gop = X264_OPEN_GOP_BLURAY;
|
||||
- free( psz_val );
|
||||
-#elif X264_BUILD >= 115
|
||||
p_sys->param.b_open_gop = var_GetBool( p_enc, SOUT_CFG_PREFIX "opengop" );
|
||||
p_sys->param.b_bluray_compat = var_GetBool( p_enc, SOUT_CFG_PREFIX "bluray-compat" );
|
||||
-#endif
|
||||
+
|
||||
i_val = var_GetInteger( p_enc, SOUT_CFG_PREFIX "bframes" );
|
||||
if( i_val >= 0 && i_val <= 16 && i_val != 3 )
|
||||
p_sys->param.i_bframe = i_val;
|
||||
@@ -1121,14 +1082,12 @@ static int Open ( vlc_object_t *p_this )
|
||||
if( i_val >= 1 && i_val != 7 )
|
||||
p_sys->param.analyse.i_subpel_refine = i_val;
|
||||
|
||||
-#if X264_BUILD >= 89
|
||||
psz_val = var_GetString( p_enc, SOUT_CFG_PREFIX "hrd");
|
||||
if( !strcmp( psz_val, "vbr" ) )
|
||||
p_sys->param.i_nal_hrd = X264_NAL_HRD_VBR;
|
||||
else if( !strcmp( psz_val, "cbr" ) )
|
||||
p_sys->param.i_nal_hrd = X264_NAL_HRD_CBR;
|
||||
free( psz_val );
|
||||
-#endif
|
||||
|
||||
//TODO: psz_val == NULL ?
|
||||
psz_val = var_GetString( p_enc, SOUT_CFG_PREFIX "me" );
|
||||
@@ -1486,11 +1445,7 @@ static block_t *Encode( encoder_t *p_enc, picture_t *p_pict )
|
||||
int i_nal=0, i_out=0, i=0;
|
||||
|
||||
/* init pic */
|
||||
-#if X264_BUILD >= 98
|
||||
x264_picture_init( &pic );
|
||||
-#else
|
||||
- memset( &pic, 0, sizeof( x264_picture_t ) );
|
||||
-#endif
|
||||
if( likely(p_pict) ) {
|
||||
pic.i_pts = p_pict->date;
|
||||
pic.img.i_csp = p_sys->i_colorspace;
|
@ -37,11 +37,11 @@ LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
BUILD_DEPENDS= bash:shells/bash
|
||||
LIB_DEPENDS?= libx264.so:multimedia/libx264
|
||||
|
||||
X264_BUILD= 152
|
||||
X264_REV= 2854
|
||||
X264_COMMIT= e9a5903edf8ca59ef20e6f4894c196f135af735e
|
||||
X264_BUILD= 155
|
||||
X264_REV= 2917
|
||||
X264_COMMIT= 0a84d986e7020f8344f00752e3600b9769cc1e85
|
||||
X264_GITVER= ${X264_COMMIT:C/^(.......).*$/\1/g}
|
||||
X264_SNAPSHOT= 20171225
|
||||
X264_SNAPSHOT= 20180807
|
||||
|
||||
USES?= pkgconfig
|
||||
USES+= gmake localbase shebangfix tar:bzip2
|
||||
|
@ -1,5 +1,5 @@
|
||||
TIMESTAMP = 1514238305
|
||||
SHA256 (x264/x264-snapshot-20171225-2245-stable.tar.bz2) = 91143276d18414f1c94ecdc472b063c874308833d57d7353f15286372ba4ba68
|
||||
SIZE (x264/x264-snapshot-20171225-2245-stable.tar.bz2) = 750690
|
||||
TIMESTAMP = 1533674705
|
||||
SHA256 (x264/x264-snapshot-20180807-2245-stable.tar.bz2) = 1439f1a054c87965089b646e77d16e1a8bf2f9687e4dd696ac518e44c7644c2a
|
||||
SIZE (x264/x264-snapshot-20180807-2245-stable.tar.bz2) = 766771
|
||||
SHA256 (x264/example.y4m.bz2) = a5bec9d37362bd9d7773fbd0644643f9ec096d654d20823004e88d5df32bbff7
|
||||
SIZE (x264/example.y4m.bz2) = 4910029
|
||||
|
@ -91,7 +91,7 @@
|
||||
libdl="-ldl"
|
||||
+ else
|
||||
+ opencl="yes"
|
||||
+ define HAVE_OPENCL
|
||||
+ define HAVE_OPENCL "(BIT_DEPTH==8)"
|
||||
fi
|
||||
LDFLAGS="$LDFLAGS $libdl"
|
||||
fi
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= zoneminder-h264
|
||||
PORTVERSION= 1.30.20170222
|
||||
PORTREVISION= 5
|
||||
PORTREVISION= 6
|
||||
CATEGORIES= multimedia
|
||||
|
||||
MAINTAINER= bsd@abinet.ru
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= opal
|
||||
PORTVERSION= 3.10.10
|
||||
PORTREVISION= 18
|
||||
PORTREVISION= 19
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= GNOME
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= xpra
|
||||
PORTVERSION= 2.0.3
|
||||
PORTREVISION= 11
|
||||
PORTREVISION= 12
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://xpra.org/src/
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user