V1.2.2 July 2017
---------------- 1/ Improvements to Hamlib support, error message reporting, serial rate box. 2/ Disabled unused UDP comms/egexp processing to clean up Options dialog.
This commit is contained in:
parent
7168e07c45
commit
d6b4be41ff
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=452754
@ -1,10 +1,9 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= freedv
|
||||
PORTVERSION= 1.2
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.2.2
|
||||
CATEGORIES= comms hamradio
|
||||
MASTER_SITES= http://files.freedv.org/freedv/ \
|
||||
MASTER_SITES= https://freedv.com/wp-content/uploads/sites/8/2017/10/ \
|
||||
LOCAL/db
|
||||
|
||||
MAINTAINER= hamradio@FreeBSD.org
|
||||
@ -21,8 +20,8 @@ LIB_DEPENDS= libcodec2.so:audio/codec2 \
|
||||
libspeex.so:audio/speex \
|
||||
libspeexdsp.so:audio/speexdsp
|
||||
|
||||
USE_WX= 3.0+
|
||||
USES= cmake:outsource compiler:c++11-lib tar:xz
|
||||
USE_WX= 3.0+
|
||||
CMAKE_ARGS+= -DCODEC2_INCLUDE_DIRS=${LOCALBASE}/include/codec2 \
|
||||
-DCODEC2_LIBRARY=${LOCALBASE}/lib/libcodec2.so \
|
||||
-DUSE_STATIC_CODEC2=FALSE \
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1495204498
|
||||
SHA256 (freedv-1.2.tar.xz) = 304f4d4febb3b6c74e6781c40535782c102df57b28383b35c2040bec11a97111
|
||||
SIZE (freedv-1.2.tar.xz) = 527124
|
||||
TIMESTAMP = 1508683454
|
||||
SHA256 (freedv-1.2.2.tar.xz) = 4884d2aaa283b3f091fc5d5594df3b5bb60078210c1bc50ea546901e2965ae1e
|
||||
SIZE (freedv-1.2.2.tar.xz) = 529904
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- CMakeLists.txt.orig 2017-02-15 02:12:19 UTC
|
||||
--- CMakeLists.txt.orig 2017-07-19 13:22:47 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -386,6 +387,7 @@ endif()
|
||||
@@ -391,6 +391,7 @@ endif()
|
||||
#
|
||||
# Find libdl for dlopen/dlclose
|
||||
#
|
||||
@ -8,11 +8,11 @@
|
||||
if(UNIX)
|
||||
message(STATUS "Looking for dl library.")
|
||||
find_library(DL_LIBRARY dl)
|
||||
@@ -400,6 +402,7 @@ On Linux systems try installing:
|
||||
@@ -405,6 +406,7 @@ On Linux systems try installing:
|
||||
)
|
||||
endif()
|
||||
endif(UNIX)
|
||||
+endif(DUMMUFLAG)
|
||||
+endif(DUMMYFLAG)
|
||||
|
||||
|
||||
#Freedv
|
||||
|
Loading…
Reference in New Issue
Block a user