Upgrade to 3.17.

This commit is contained in:
Thomas Gellekum 2000-03-09 10:02:47 +00:00
parent e46959cf44
commit d696382eab
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=26688
5 changed files with 60 additions and 10 deletions

View File

@ -1,27 +1,42 @@
# New ports collection makefile for: pstodit
# Version required: 3.11
# Version required: 3.17
# Date created: 03 July 1998
# Whom: Thomas Gellekum <tg@FreeBSD.org>
#
# $FreeBSD$
#
DISTNAME= pstoedit_3_11
PKGNAME= pstoedit-3.11
DISTNAME= pstoedit_3_17
PKGNAME= pstoedit-3.17
CATEGORIES= graphics print
MASTER_SITES= http://www.geocities.com/SiliconValley/Network/1958/pstoedit/
MAINTAINER= jseger@FreeBSD.org
RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript5
LIB_DEPENDS= plot.3:${PORTSDIR}/graphics/plotutils \
plotter.3:${PORTSDIR}/graphics/plotutils
RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript55
FETCH_BEFORE_ARGS= -t
USE_ZIP= yes
WRKSRC= ${WRKDIR}/pstoedit_3.11/src
MAKEFILE= makefile
ALL_TARGET=
WRKSRC= ${WRKDIR}/pstoedit_3.17/src
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${PREFIX}/include -I${X11BASE}/include" \
CXXFLAGS="${CFLAGS} -I${PREFIX}/include -I${X11BASE}/include" \
LDLIBS="-L${PREFIX}/lib -L${X11BASE}/lib" \
LIBS="-L${PREFIX}/lib -L${X11BASE}/lib"
ALL_TARGET= default
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pstoedit ${PREFIX}/bin
MAN1= pstoedit.1
post-extract:
${CP} ${WRKSRC}/../config/* ${WRKSRC}
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${PREFIX}/share/doc/pstoedit
${INSTALL_DATA} ${WRKSRC}/../*.htm ${PREFIX}/share/doc/pstoedit
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (pstoedit_3_11.zip) = 7e5acd38aeb5310db19f7712ba540c24
MD5 (pstoedit_3_17.zip) = e11b080ec22b60a85f58c3a050f651d1

View File

@ -0,0 +1,17 @@
--- configure.orig Sun Feb 27 14:04:26 2000
+++ configure Sun Feb 27 14:02:06 2000
@@ -1061,12 +1061,12 @@
#include "confdefs.h"
#include <plotter.h>
int main() {
- typdef int Point;
+ typedef int Point;
; return 0; }
EOF
if { (eval echo configure:1068: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
- echo "$ac_t""you seem to have a newer version " 1>&6]
+ echo "$ac_t""you seem to have a newer version " 1>&6
else
echo "configure: failed program was:" >&5
cat conftest.$ac_ext >&5

View File

@ -0,0 +1,13 @@
--- configure.in.orig Sun Feb 27 14:03:37 2000
+++ configure.in Sun Feb 27 14:02:43 2000
@@ -30,8 +30,8 @@
dnl See if we have a 2.3 or newer lib Plot version
AC_MSG_CHECKING(for version of "lib plot" )
-AC_TRY_COMPILE( [#include <plotter.h>],[ typdef int Point; ],
- AC_MSG_RESULT(you seem to have a newer version )],
+AC_TRY_COMPILE( [#include <plotter.h>],[ typedef int Point; ],
+ AC_MSG_RESULT(you seem to have a newer version ),
[PLOTCOMPILEFLAGS="$PLOTCOMPILEFLAGS -DOLD_LIBPLOTTER"; AC_MSG_RESULT(you seem to have a older version )])
AC_SUBST(PLOTCOMPILEFLAGS)

View File

@ -1 +1,6 @@
bin/pstoedit
lib/mpost.fmp
share/doc/pstoedit/changelog.htm
share/doc/pstoedit/index.htm
share/doc/pstoedit/pstoedit.htm
@dirrm share/doc/pstoedit