add stage support

This commit is contained in:
Olli Hauer 2014-03-09 17:42:56 +00:00
parent ccc8f79b07
commit d67a482188
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=347673
2 changed files with 24 additions and 9 deletions

View File

@ -11,7 +11,6 @@ PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache2.2 module to wrap served pages with a header and/or footer
CONFLICTS= mod_layout-3.* mod_layout-4.*
PORTSCOUT= limit:^5
@ -21,11 +20,15 @@ LATEST_LINK= mod_layout22
MAKE_ARGS+= builddir=${WRKSRC}
NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's|@APXS_STAGE@|-S LIBEXECDIR=${STAGEDIR}${PREFIX}/${APACHEMODDIR}|' \
${WRKSRC}/Makefile
pre-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
.endif
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/README
.include <bsd.port.mk>

View File

@ -1,6 +1,6 @@
--- Makefile.orig 2007-02-21 22:29:07.000000000 +0100
+++ Makefile 2008-08-31 21:53:05.000000000 +0200
@@ -1,10 +1,10 @@
--- ./Makefile.orig 2008-01-07 07:44:50.000000000 +0100
+++ ./Makefile 2014-03-09 18:38:09.000000000 +0100
@@ -1,10 +1,11 @@
##
## Makefile -- Build procedure for mod_layout Apache module
##
@ -10,6 +10,18 @@
# the used tools
-APXS=apxs
+APXS=${LOCALBASE}/sbin/apxs
+APXS_STAGE= @APXS_STAGE@
APACHECTL=apachectl
CC=`$(APXS) -q CC`
INC=-I`$(APXS) -q INCLUDEDIR` `$(APXS) -q CFLAGS` #-DLAYOUT_FILEOWNER_NAME
@@ -57,8 +58,8 @@
header.o : header.c
$(APXS) -c header.c
# install the shared object file into Apache
-install:
- $(APXS) -iac $(INCLUDES) $(LIBS) $(SRC)
+install: mod_layout.so
+ $(APXS) $(APXS_STAGE) -i -n layout mod_layout.la
@echo "+--------------------------------------------------------+"; \
echo "| All done. |"; \
echo "| |"; \