add swish++ 5.6
Simple Web Indexing System for Humans: C++ version
This commit is contained in:
parent
89c786c03b
commit
d5cd0b4a76
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=53002
@ -322,6 +322,7 @@
|
||||
SUBDIR += squishdot
|
||||
SUBDIR += ssserver
|
||||
SUBDIR += surfraw
|
||||
SUBDIR += swish++
|
||||
SUBDIR += swish-e
|
||||
SUBDIR += tclhttpd
|
||||
SUBDIR += thttpd
|
||||
|
40
www/swish++/Makefile
Normal file
40
www/swish++/Makefile
Normal file
@ -0,0 +1,40 @@
|
||||
# ex:ts=8
|
||||
# Ports collection makefile for: swish++
|
||||
# Date created: Jan 13, 2002
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= swish++
|
||||
PORTVERSION= 5.6
|
||||
CATEGORIES= www textproc
|
||||
MASTER_SITES= http://homepage.mac.com/pauljlucas/software/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
|
||||
|
||||
USE_PERL5= yes
|
||||
USE_GMAKE= yes
|
||||
MAKEFILE= GNUmakefile
|
||||
MAKE_ENV= PTHREAD_LIB=${PTHREAD_LIBS} \
|
||||
PERL=${PERL} PERL_VER=${PERL_VER}
|
||||
|
||||
MAN1= extract.1 httpindex.1 index.1 search.1 splitmail.1
|
||||
MAN3= WWW.3
|
||||
MAN4= swish++.conf.4 swish++.index.4
|
||||
MAN8= searchd.8 searchmonitor.8
|
||||
|
||||
post-patch:
|
||||
@(cd ${WRKSRC} ; \
|
||||
${SED} '/^#error/d' config.h > config.h.tmp ; \
|
||||
${MV} -f config.h.tmp config.h)
|
||||
.for file in searchd searchmonitor
|
||||
@${PERL} -pi -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/${file}
|
||||
.endfor
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/swish++.sh ${PREFIX}/etc/rc.d
|
||||
|
||||
.include <bsd.port.mk>
|
1
www/swish++/distinfo
Normal file
1
www/swish++/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (swish++-5.6.tar.gz) = 788811eea199c239931583bca1dc88d6
|
18
www/swish++/files/patch-GNUmakefile
Normal file
18
www/swish++/files/patch-GNUmakefile
Normal file
@ -0,0 +1,18 @@
|
||||
--- GNUmakefile.orig Wed Dec 19 12:24:07 2001
|
||||
+++ GNUmakefile Sun Jan 13 12:04:59 2002
|
||||
@@ -192,13 +192,13 @@
|
||||
cd $(I_BIN) && $(STRIP) $(CPP_TARGET)
|
||||
|
||||
install_lib: $(I_LIB)
|
||||
- $(INSTALL) $(I_OWNER) $(I_GROUP) $(I_MODE) $(LIB_TARGET) $(I_LIB)
|
||||
+ $(INSTALL) $(I_OWNER) $(I_GROUP) $(I_MODE) $(LIB_TARGET) $(I_LIB)/perl5/site_perl/${PERL_VER}
|
||||
|
||||
install_man:
|
||||
@$(MAKE) -C man install
|
||||
|
||||
install_conf:
|
||||
- $(INSTALL) $(I_OWNER) $(I_GROUP) $(I_MODE) swish++.conf /etc
|
||||
+ $(INSTALL) $(I_OWNER) $(I_GROUP) $(I_MODE) swish++.conf ${PREFIX}/etc
|
||||
|
||||
$(I_BIN) $(I_LIB):
|
||||
$(MKDIR) $@
|
56
www/swish++/files/patch-config::config.mk
Normal file
56
www/swish++/files/patch-config::config.mk
Normal file
@ -0,0 +1,56 @@
|
||||
--- config/config.mk.orig Sun Jan 13 11:38:36 2002
|
||||
+++ config/config.mk Sun Jan 13 11:41:51 2002
|
||||
@@ -35,8 +35,8 @@
|
||||
#
|
||||
###############################################################################
|
||||
|
||||
-#FREE_BSD:= -DFreeBSD
|
||||
-LINUX:= -DLinux
|
||||
+FREE_BSD:= -DFreeBSD
|
||||
+#LINUX:= -DLinux
|
||||
#SOLARIS:= -DSolaris
|
||||
#WIN32:= -DWIN32
|
||||
|
||||
@@ -87,7 +87,6 @@
|
||||
ifdef SEARCH_DAEMON
|
||||
|
||||
ifdef FREE_BSD
|
||||
-PTHREAD_LIB:= -pthread
|
||||
else
|
||||
PTHREAD_LIB:= -lpthread
|
||||
endif
|
||||
@@ -118,7 +117,6 @@
|
||||
# The command to remove files recursively and ignore errors;
|
||||
# usually "rm -fr" for Unix or "erase" for Windows.
|
||||
|
||||
-PERL:= /usr/local/bin/perl
|
||||
# The full path to the Perl 5 executable; usually "/bin/perl" or
|
||||
# "/usr/local/bin/perl" for Unix or "\Perl\bin\perl" for
|
||||
# Windows. You need this only if you intend on using
|
||||
@@ -145,15 +143,14 @@
|
||||
#
|
||||
###############################################################################
|
||||
|
||||
-#CC:= g++
|
||||
-CC:= /usr/local/bin/g++
|
||||
+CC:= g++
|
||||
# The C++ compiler you are using; usually "CC" or "g++".
|
||||
|
||||
#DEBUG:= true
|
||||
ifdef DEBUG
|
||||
OPTIM:= -g
|
||||
else
|
||||
-OPTIM:= -O2
|
||||
+OPTIM:= ${CXXFLAGS}
|
||||
# The optimization level. Many compilers allow a digit after the
|
||||
# O to specify the level of optimization; if so, set yours to the
|
||||
# highest number your compiler allows without eliciting problems
|
||||
@@ -196,7 +193,7 @@
|
||||
INSTALL:= $(ROOT)/install-sh
|
||||
# Install command; usually "$(ROOT)/install-sh".
|
||||
|
||||
-I_ROOT:= /usr/local
|
||||
+I_ROOT:= ${PREFIX}
|
||||
# The top-level directory of where SWISH++ will be installed.
|
||||
|
||||
I_BIN:= $(I_ROOT)/bin
|
11
www/swish++/files/patch-searchd.in
Normal file
11
www/swish++/files/patch-searchd.in
Normal file
@ -0,0 +1,11 @@
|
||||
--- searchd.in.orig Sun Jan 13 12:00:35 2002
|
||||
+++ searchd.in Sun Jan 13 12:00:53 2002
|
||||
@@ -27,7 +27,7 @@
|
||||
SEARCH="search"
|
||||
SEARCH_PATH="%%I_BIN%%/$SEARCH"
|
||||
SEARCHMONITOR="%%I_BIN%%/searchmonitor"
|
||||
-CONF_FILE="/etc/swish++.conf"
|
||||
+CONF_FILE="%%PREFIX%%/etc/swish++.conf"
|
||||
PID_FILE_DEFAULT="/var/run/search.pid"
|
||||
|
||||
##
|
11
www/swish++/files/patch-searchmonitor.in
Normal file
11
www/swish++/files/patch-searchmonitor.in
Normal file
@ -0,0 +1,11 @@
|
||||
--- searchmonitor.in.orig Sun Jan 13 12:01:32 2002
|
||||
+++ searchmonitor.in Sun Jan 13 12:01:47 2002
|
||||
@@ -63,7 +63,7 @@
|
||||
CONF_FILE="swish++.conf"
|
||||
if [ ! -f "$CONF_FILE" ]
|
||||
then
|
||||
- CONF_FILE="/etc/$CONF_FILE"
|
||||
+ CONF_FILE="%%PREFIX%%/etc/$CONF_FILE"
|
||||
[ -f "$CONF_FILE" ] ||
|
||||
{ echo "$ME: no configuration file found" >&2; exit 3; }
|
||||
fi
|
19
www/swish++/files/swish++.sh
Normal file
19
www/swish++/files/swish++.sh
Normal file
@ -0,0 +1,19 @@
|
||||
#!/bin/sh
|
||||
|
||||
if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
|
||||
echo "$0: Cannot determine the PREFIX" >&2
|
||||
exit 1
|
||||
fi
|
||||
|
||||
case "$1" in
|
||||
start)
|
||||
[ -x ${PREFIX}/bin/searchmonitor -a -f ${PREFIX}/etc/swish++.conf ] && ${PREFIX}/bin/searchmonitor -c ${PREFIX}/etc/swish++.conf -s ${PREFIX}/search &
|
||||
;;
|
||||
stop)
|
||||
;;
|
||||
*)
|
||||
echo "Usage: `basename $0` {start|stop}" >&2
|
||||
;;
|
||||
esac
|
||||
|
||||
exit 0
|
1
www/swish++/pkg-comment
Normal file
1
www/swish++/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Simple Web Indexing System for Humans: C++ version
|
4
www/swish++/pkg-descr
Normal file
4
www/swish++/pkg-descr
Normal file
@ -0,0 +1,4 @@
|
||||
SWISH++ is a Unix-based file indexing and searching engine (typically used to
|
||||
index and search files on web sites). It was based on SWISH-E
|
||||
|
||||
WWW: http://homepage.mac.com/pauljlucas/software/swish/
|
10
www/swish++/pkg-plist
Normal file
10
www/swish++/pkg-plist
Normal file
@ -0,0 +1,10 @@
|
||||
bin/extract
|
||||
bin/httpindex
|
||||
bin/index
|
||||
bin/search
|
||||
bin/searchc
|
||||
bin/searchmonitor
|
||||
bin/splitmail
|
||||
etc/swish++.conf
|
||||
etc/rc.d/swish++.sh
|
||||
lib/perl5/site_perl/%%PERL_VER%%/WWW.pm
|
Loading…
Reference in New Issue
Block a user