PyODE is a set of open-source Python bindings for The Open Dynamics
Engine, an open-source physics engine. PyODE also includes an XODE parser. Like ODE, PyODE may be distributed under the terms of either the GNU Lesser General Public License or a BSD-style license. WWW: http://pyode.sourceforge.net PR: ports/108411 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
This commit is contained in:
parent
0420e16f0a
commit
d575d5a419
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=183483
@ -1770,6 +1770,7 @@
|
||||
SUBDIR += py-notifier
|
||||
SUBDIR += py-notify
|
||||
SUBDIR += py-ocempgui
|
||||
SUBDIR += py-ode
|
||||
SUBDIR += py-omniorb
|
||||
SUBDIR += py-optik
|
||||
SUBDIR += py-orbit
|
||||
|
30
devel/py-ode/Makefile
Normal file
30
devel/py-ode/Makefile
Normal file
@ -0,0 +1,30 @@
|
||||
# New ports collection makefile for: py-ode
|
||||
# Date created: 26 Jan 2007
|
||||
# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= ode
|
||||
PORTVERSION= 1.1.0
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= pyode
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
DISTNAME= PyODE-${PORTVERSION}
|
||||
DIST_SUBDIR= python
|
||||
|
||||
MAINTAINER= amdmi3@amdmi3.ru
|
||||
COMMENT= Python bindings for The Open Dynamics Engine
|
||||
|
||||
BUILD_DEPENDS= ${X11BASE}/lib/libode.a:${PORTSDIR}/devel/ode
|
||||
|
||||
USE_BZIP2= yes
|
||||
|
||||
USE_PYTHON= yes
|
||||
USE_PYDISTUTILS=yes
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/^#ODE_BASE/ s|.*|ODE_BASE="${X11BASE}"|' ${WRKSRC}/setup.py
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/py-ode/distinfo
Normal file
3
devel/py-ode/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
MD5 (python/PyODE-1.1.0.tar.bz2) = ad7873c0977e275a9061898ac2e611cd
|
||||
SHA256 (python/PyODE-1.1.0.tar.bz2) = 5811121e25f81e55d65d4235baec623726096ce5cfdb980ed223ffde91ec066a
|
||||
SIZE (python/PyODE-1.1.0.tar.bz2) = 140371
|
27
devel/py-ode/files/patch-setup.py
Normal file
27
devel/py-ode/files/patch-setup.py
Normal file
@ -0,0 +1,27 @@
|
||||
--- setup.py.orig Thu Jul 7 15:36:03 2005
|
||||
+++ setup.py Fri Jan 26 22:54:51 2007
|
||||
@@ -150,22 +150,11 @@
|
||||
script so that it points to the actual location of the ODE directory."""%ODE_BASE
|
||||
sys.exit()
|
||||
|
||||
-config = readODEConfig()
|
||||
-
|
||||
generate('ode_trimesh.c', True)
|
||||
generate('ode_notrimesh.c', False)
|
||||
|
||||
-try:
|
||||
- wrap_trimesh = TRIMESH_SUPPORT_OVERRIDE
|
||||
-except NameError, e:
|
||||
- wrap_trimesh = config.get('OPCODE_DIRECTORY', '')
|
||||
-
|
||||
-if (wrap_trimesh):
|
||||
- print "Installing with trimesh support."
|
||||
- install = 'ode_trimesh.c'
|
||||
-else:
|
||||
- print "Installing without trimesh support."
|
||||
- install = 'ode_notrimesh.c'
|
||||
+print "Installing without trimesh support."
|
||||
+install = 'ode_notrimesh.c'
|
||||
|
||||
# Compile the module
|
||||
setup(name = "PyODE",
|
6
devel/py-ode/pkg-descr
Normal file
6
devel/py-ode/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
PyODE is a set of open-source Python bindings for The Open Dynamics
|
||||
Engine, an open-source physics engine. PyODE also includes an XODE
|
||||
parser. Like ODE, PyODE may be distributed under the terms of either
|
||||
the GNU Lesser General Public License or a BSD-style license.
|
||||
|
||||
WWW: http://pyode.sourceforge.net
|
26
devel/py-ode/pkg-plist
Normal file
26
devel/py-ode/pkg-plist
Normal file
@ -0,0 +1,26 @@
|
||||
%%PYTHON_SITELIBDIR%%/ode.so
|
||||
%%PYTHON_SITELIBDIR%%/xode/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/xode/__init__.pyc
|
||||
%%PYTHON_SITELIBDIR%%/xode/__init__.pyo
|
||||
%%PYTHON_SITELIBDIR%%/xode/body.py
|
||||
%%PYTHON_SITELIBDIR%%/xode/body.pyc
|
||||
%%PYTHON_SITELIBDIR%%/xode/body.pyo
|
||||
%%PYTHON_SITELIBDIR%%/xode/errors.py
|
||||
%%PYTHON_SITELIBDIR%%/xode/errors.pyc
|
||||
%%PYTHON_SITELIBDIR%%/xode/errors.pyo
|
||||
%%PYTHON_SITELIBDIR%%/xode/geom.py
|
||||
%%PYTHON_SITELIBDIR%%/xode/geom.pyc
|
||||
%%PYTHON_SITELIBDIR%%/xode/geom.pyo
|
||||
%%PYTHON_SITELIBDIR%%/xode/joint.py
|
||||
%%PYTHON_SITELIBDIR%%/xode/joint.pyc
|
||||
%%PYTHON_SITELIBDIR%%/xode/joint.pyo
|
||||
%%PYTHON_SITELIBDIR%%/xode/node.py
|
||||
%%PYTHON_SITELIBDIR%%/xode/node.pyc
|
||||
%%PYTHON_SITELIBDIR%%/xode/node.pyo
|
||||
%%PYTHON_SITELIBDIR%%/xode/parser.py
|
||||
%%PYTHON_SITELIBDIR%%/xode/parser.pyc
|
||||
%%PYTHON_SITELIBDIR%%/xode/parser.pyo
|
||||
%%PYTHON_SITELIBDIR%%/xode/transform.py
|
||||
%%PYTHON_SITELIBDIR%%/xode/transform.pyc
|
||||
%%PYTHON_SITELIBDIR%%/xode/transform.pyo
|
||||
@dirrm %%PYTHON_SITELIBDIR%%/xode
|
Loading…
Reference in New Issue
Block a user