devel/easyloggingpp: Update 9.96.7 -> 9.97.0
Reported by: portscout
This commit is contained in:
parent
a4fc91b3af
commit
d53b0a831d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=559344
@ -2,8 +2,7 @@
|
||||
|
||||
PORTNAME= easyloggingpp
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 9.96.7
|
||||
PORTREVISION= 2
|
||||
DISTVERSION= 9.97.0
|
||||
CATEGORIES= devel
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
@ -13,14 +12,21 @@ LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
USES= cmake compiler:c++11-lang
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= muflihun
|
||||
USE_LDCONFIG= yes
|
||||
CMAKE_ON= build_shared_lib # patched in, requested such option in https://github.com/muflihun/easyloggingpp/issues/603
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= amrayn
|
||||
|
||||
PLIST_FILES= include/easylogging++.h \
|
||||
include/easylogging++.cc \
|
||||
lib/libeasyloggingpp.so \
|
||||
libdata/pkgconfig/easyloggingpp.pc
|
||||
|
||||
do-test:
|
||||
@cd ${BUILD_WRKSRC} && \
|
||||
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -Dtest:BOOL=ON ${CMAKE_SOURCE_PATH} && \
|
||||
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
|
||||
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1543053240
|
||||
SHA256 (muflihun-easyloggingpp-v9.96.7_GH0.tar.gz) = 237c80072b9b480a9f2942b903b4b0179f65e146e5dcc64864dc91792dedd722
|
||||
SIZE (muflihun-easyloggingpp-v9.96.7_GH0.tar.gz) = 750349
|
||||
TIMESTAMP = 1609052128
|
||||
SHA256 (amrayn-easyloggingpp-v9.97.0_GH0.tar.gz) = 9110638e21ef02428254af8688bf9e766483db8cc2624144aa3c59006907ce22
|
||||
SIZE (amrayn-easyloggingpp-v9.97.0_GH0.tar.gz) = 750851
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- CMakeLists.txt.orig 2018-11-23 20:35:32 UTC
|
||||
--- CMakeLists.txt.orig 2020-12-25 09:02:08 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -22,7 +22,7 @@ macro(require_cpp11)
|
||||
endmacro()
|
||||
@ -18,9 +18,9 @@
|
||||
|
||||
include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include)
|
||||
|
||||
@@ -46,18 +46,18 @@ configure_file( ${CMAKE_CURRENT_SOURCE_D
|
||||
|
||||
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/easyloggingpp.pc DESTINATION "${ELPP_PKGCONFIG_INSTALL_DIR}")
|
||||
@@ -52,18 +52,18 @@ if (HAVE_EXECINFO)
|
||||
add_definitions(-DHAVE_EXECINFO)
|
||||
endif()
|
||||
|
||||
-if (build_static_lib)
|
||||
+if (build_shared_lib)
|
||||
@ -40,3 +40,14 @@
|
||||
endif()
|
||||
|
||||
export(PACKAGE ${PROJECT_NAME})
|
||||
@@ -98,7 +98,9 @@ if (test)
|
||||
)
|
||||
|
||||
# Standard linking to gtest stuff.
|
||||
- target_link_libraries(easyloggingpp-unit-tests gtest gtest_main)
|
||||
+ target_include_directories(easyloggingpp-unit-tests PRIVATE ${CMAKE_INSTALL_PREFIX}/include)
|
||||
+ target_link_directories(easyloggingpp-unit-tests PRIVATE ${CMAKE_INSTALL_PREFIX}/lib)
|
||||
+ target_link_libraries(easyloggingpp-unit-tests gtest gtest_main execinfo)
|
||||
|
||||
add_test(NAME easyloggingppUnitTests COMMAND easyloggingpp-unit-tests -v)
|
||||
endif()
|
||||
|
@ -4,4 +4,4 @@ built-in features. It provides ability to write logs in your own customized
|
||||
format. It also provide support for logging your classes, third-party
|
||||
libraries, STL and third-party containers etc.
|
||||
|
||||
WWW: https://muflihun.github.io/easyloggingpp/
|
||||
WWW: https://github.com/amrayn/easyloggingpp
|
||||
|
Loading…
Reference in New Issue
Block a user