Add polypuzzle, a small polygon puzzle written in Tk.
PR: ports/68510 Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu>
This commit is contained in:
parent
31a5ee8f5f
commit
d5270b31c4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=112793
@ -344,6 +344,7 @@
|
||||
SUBDIR += pinball
|
||||
SUBDIR += pipenightdreams
|
||||
SUBDIR += pmars
|
||||
SUBDIR += polypuzzle
|
||||
SUBDIR += powermanga
|
||||
SUBDIR += powerpak
|
||||
SUBDIR += pp
|
||||
|
43
games/polypuzzle/Makefile
Normal file
43
games/polypuzzle/Makefile
Normal file
@ -0,0 +1,43 @@
|
||||
# New ports collection makefile for: polypuzzle
|
||||
# Date created: 30 June 2004
|
||||
# Whom: janos.mohacsi@bsd.hu
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= polypuzzle
|
||||
PORTVERSION= 1.5.1
|
||||
CATEGORIES= games tcl84 tk84
|
||||
MASTER_SITES= ftp://ibiblio.org/pub/Linux/games/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= janos.mohacsi@bsd.hu
|
||||
COMMENT= Tessellation puzzle game
|
||||
|
||||
RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
USE_REINPLACE= yes
|
||||
NO_BUILD= yes
|
||||
|
||||
DOC_FILES= About Bugs Changelog Copyright Install Math Readme Thanks Todo
|
||||
DATA_FILES= menus pieces.3x20 pieces.783 pieces.bonus pieces.colours \
|
||||
pieces.flower pieces.large pieces.medium pieces.monster \
|
||||
pieces.small pieces.square pieces.star pieces.triangle
|
||||
|
||||
pre-install:
|
||||
@${REINPLACE_CMD} -e "s:%%DATADIR%%:${DATADIR}:g" ${WRKSRC}/polypuzzle
|
||||
do-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/polypuzzle ${PREFIX}/bin
|
||||
${MKDIR} ${DATADIR}
|
||||
.for f in ${DATA_FILES}
|
||||
@${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
|
||||
.endfor
|
||||
.ifndef(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
.for f in ${DOC_FILES}
|
||||
@${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
2
games/polypuzzle/distinfo
Normal file
2
games/polypuzzle/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (polypuzzle-1.5.1.tgz) = 02c8d6ed7ff40930cf9362b88fbf9f8d
|
||||
SIZE (polypuzzle-1.5.1.tgz) = 14385
|
13
games/polypuzzle/files/patch-polypuzzle
Normal file
13
games/polypuzzle/files/patch-polypuzzle
Normal file
@ -0,0 +1,13 @@
|
||||
--- polypuzzle.orig Fri Jun 18 11:51:04 2004
|
||||
+++ polypuzzle Wed Jun 30 13:46:07 2004
|
||||
@@ -1,8 +1,8 @@
|
||||
#/bin/sh
|
||||
# the next line restarts using tclsh \
|
||||
-exec wish "$0" "$@"
|
||||
+exec wish8.4 "$0" "$@"
|
||||
|
||||
-if {[file isdirectory /usr/local/lib/polypuzzle]} {cd /usr/local/lib/polypuzzle}
|
||||
+if {[file isdirectory %%DATADIR%%]} {cd %%DATADIR%%}
|
||||
|
||||
source pieces.colours
|
||||
set colour(bg) azure3 ;# background colour
|
5
games/polypuzzle/pkg-descr
Normal file
5
games/polypuzzle/pkg-descr
Normal file
@ -0,0 +1,5 @@
|
||||
Tessellation puzzle inspired by Beat The Computer.
|
||||
Puzzles implemented include several based on
|
||||
squares, hexagons and equilateral triangles.
|
||||
|
||||
WWW: ftp://ibiblio.org/pub/Linux/games/
|
25
games/polypuzzle/pkg-plist
Normal file
25
games/polypuzzle/pkg-plist
Normal file
@ -0,0 +1,25 @@
|
||||
bin/polypuzzle
|
||||
%%DATADIR%%/menus
|
||||
%%DATADIR%%/pieces.3x20
|
||||
%%DATADIR%%/pieces.783
|
||||
%%DATADIR%%/pieces.bonus
|
||||
%%DATADIR%%/pieces.colours
|
||||
%%DATADIR%%/pieces.flower
|
||||
%%DATADIR%%/pieces.large
|
||||
%%DATADIR%%/pieces.medium
|
||||
%%DATADIR%%/pieces.monster
|
||||
%%DATADIR%%/pieces.small
|
||||
%%DATADIR%%/pieces.square
|
||||
%%DATADIR%%/pieces.star
|
||||
%%DATADIR%%/pieces.triangle
|
||||
%%PORTDOCS%%%%DOCSDIR%%/About
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Bugs
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Changelog
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Copyright
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Install
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Math
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Readme
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Thanks
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Todo
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm %%DATADIR%%
|
Loading…
Reference in New Issue
Block a user