- Fix path prefix in installed test.xml

- Install one omitted image file
- Set locale as needed
- Bump PORTREVISION
This commit is contained in:
Alexey Dokuchaev 2005-02-12 16:58:39 +00:00
parent 5e8502dd08
commit d52623dfb5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=128612
4 changed files with 17 additions and 12 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= geist
PORTVERSION= 0.0.3
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://www.linuxbrit.co.uk/downloads/
@ -20,9 +20,14 @@ LIB_DEPENDS= Imlib2.2:${PORTSDIR}/graphics/imlib2 \
XML_CONFIG?= ${LOCALBASE}/bin/xml2-config
GNU_CONFIGURE= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GNOME= gtk12
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
LIBS="-L${X11BASE}/lib" \
XML_CONFIG="${XML_CONFIG}"
post-patch:
@${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},' \
${WRKSRC}/src/test.xml
.include <bsd.port.mk>

View File

@ -1,11 +0,0 @@
--- src/testimages/Makefile.in.orig Thu Oct 26 21:29:04 2000
+++ src/testimages/Makefile.in Thu Oct 26 22:38:54 2000
@@ -76,7 +76,7 @@
# A list of all the files in the current directory which can be regenerated
MAINTAINERCLEANFILES = Makefile.in
-testimages_DATA = bg.png bulb.png elogo.png globe.png mail.png mush.png paper.png laet.jpg
+testimages_DATA = bg.png bulb.png elogo.png globe.png mail.png mush.png paper.png
testimagesdir = $(prefix)/share/geist/images

View File

@ -0,0 +1,10 @@
--- src/main.c.orig Sat Feb 12 22:43:06 2005
+++ src/main.c Sat Feb 12 22:43:47 2005
@@ -49,6 +49,7 @@
opt.debug_level = 3;
D_ENTER(3);
+ gtk_set_locale();
gtk_init(&argc, &argv);
obj_win = geist_create_object_list();

View File

@ -16,6 +16,7 @@ share/geist/images/bg.png
share/geist/images/bulb.png
share/geist/images/elogo.png
share/geist/images/globe.png
share/geist/images/laet.jpg
share/geist/images/mail.png
share/geist/images/mush.png
share/geist/images/paper.png