MFH: r564962

devel/rlwrap: Update to 0.44

And while here, also:
- Switch to versioned release download
- Reformat Makefile according to portclippy/portfmt
- Fix pkg-plist

Reviewed by:	osa (mentor), swills (mentor)
Approved by:	osa (mentor)
Differential Revision:	https://reviews.freebsd.org/D28429
This commit is contained in:
Juraj Lutter 2021-02-11 17:41:41 +00:00
parent 9c6c8c8802
commit d514664edd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2021Q1/; revision=564972
7 changed files with 28 additions and 72 deletions

View File

@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= rlwrap
PORTVERSION= 0.42
DISTVERSIONPREFIX= v
PORTREVISION= 2
DISTVERSION= 0.44
CATEGORIES= devel
MASTER_SITES= https://github.com/hanslub42/rlwrap/releases/download/${DISTVERSION}/
MAINTAINER= gamato@users.sf.net
COMMENT= Readline wrapper
@ -13,18 +12,19 @@ COMMENT= Readline wrapper
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USE_GITHUB= yes
GH_ACCOUNT= hanslub42
USES= autoreconf python readline shebangfix
PYTHON_NO_DEPENDS= yes
SHEBANG_GLOB= *.py
python_OLD_CMD= "/usr/bin/env python3"
USES= readline autoreconf
GNU_CONFIGURE= yes
PORTDOCS= AUTHORS BUGS NEWS PLEA README TODO
PORTDOCS= AUTHORS BUGS NEWS README
OPTIONS_DEFINE= DOCS
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor

View File

@ -1,2 +1,3 @@
SHA256 (hanslub42-rlwrap-v0.42_GH0.tar.gz) = fff56c24341f0c717cf3a8f0ebbf2cba415b1952e1591168ca69ed13638b20f3
SIZE (hanslub42-rlwrap-v0.42_GH0.tar.gz) = 139838
TIMESTAMP = 1611167981
SHA256 (rlwrap-0.44.tar.gz) = cd7ff50cde66e443cbea0049b4abf1cca64a74948371fa4f1b5d9a5bbce1e13c
SIZE (rlwrap-0.44.tar.gz) = 321590

View File

@ -1,20 +0,0 @@
--- configure.ac.orig 2014-11-14 14:48:11 UTC
+++ configure.ac
@@ -212,7 +212,7 @@ AC_CACHE_CHECK(for pty/tty type, ptyttyl
AC_CHECK_HEADERS([pty.h])
else if test x$ac_cv_func__getpty = xyes; then
ptyttylib_cv_ptys=SGI4
- else if test -c /dev/ttyp20 -a ! -c /dev/ptmx; then
+ else if test -c /dev/ttyp20 -a ! -c /nonexistent; then
ptyttylib_cv_ptys=SCO
else if test -c /dev/ptym/clone; then
ptyttylib_cv_ptys=HPUX
@@ -222,7 +222,7 @@ AC_CACHE_CHECK(for pty/tty type, ptyttyl
ptyttylib_cv_ptys=PTC
else if test -c /dev/ptc -a -d /dev/pts; then
ptyttylib_cv_ptys=PTC
- else if test -c /dev/ptmx -a -c /dev/pts/0; then
+ else if test -c /nonexistent -a -c /dev/pts/0; then
ptyttylib_cv_ptys=STREAMS
else case "$host_os" in
*cygwin*) ptyttylib_cv_ptys=STREAMS ;;

View File

@ -1,27 +0,0 @@
--- src/ptytty.c.orig 2010-01-24 01:05:53.000000000 -0800
+++ src/ptytty.c 2010-01-24 01:09:19.000000000 -0800
@@ -159,11 +159,19 @@
char pty_name[] = "/dev/pty??";
char tty_name[] = "/dev/tty??";
-# ifndef PTYCHAR1
-# define PTYCHAR1 "pqrstuvwxyz"
-# endif
-# ifndef PTYCHAR2
-# define PTYCHAR2 "0123456789abcdef"
+# ifdef __FreeBSD__
+/* Auto-detected pty names do not work well with devfs! */
+# undef PTYCHAR1
+# define PTYCHAR1 "pqrsPQRS"
+# undef PTYCHAR2
+# define PTYCHAR2 "0123456789abcdefghijklmnopqrstuv"
+# else
+# ifndef PTYCHAR1
+# define PTYCHAR1 "pqrstuvwxyz"
+# endif
+# ifndef PTYCHAR2
+# define PTYCHAR2 "0123456789abcdef"
+# endif
# endif
for (c1 = PTYCHAR1; *c1; c1++) {
pty_name[(sizeof(pty_name) - 3)] =

View File

@ -1,11 +0,0 @@
--- src/main.c.orig 2014-11-14 14:48:11 UTC
+++ src/main.c
@@ -52,7 +52,7 @@ char *filter_command = NULL; /* -z opt
/* variables for global bookkeeping */
int master_pty_fd; /* master pty (rlwrap uses this to communicate with client) */
-int slave_pty_sensing_fd; /* slave pty (client uses this to communicate with rlwrap,
+extern int slave_pty_sensing_fd; /* slave pty (client uses this to communicate with rlwrap,
* we keep it open after forking in order to keep track of
* client's terminal settings */
FILE *debug_fp = NULL; /* filehandle of debugging log */

View File

@ -3,4 +3,4 @@ editing of keyboard input for any other command. Input history is remembered
across invocations, separately for each command; history completion and search
work as in bash and completion word lists can be specified on the command line.
WWW: http://utopia.knoware.nl/~hlub/uck/rlwrap/
WWW: https://github.com/hanslub42/rlwrap

View File

@ -1,22 +1,35 @@
bin/rlwrap
man/man1/rlwrap.1.gz
man/man3/RlwrapFilter.3pm.gz
%%DATADIR%%/completions/coqtop
%%DATADIR%%/completions/testclient
%%DATADIR%%/filters/README
%%DATADIR%%/filters/RlwrapFilter.3pm
%%DATADIR%%/filters/RlwrapFilter.pm
%%DATADIR%%/filters/censor_passwords
%%DATADIR%%/filters/censor_passwords.py
%%DATADIR%%/filters/count_in_prompt
%%DATADIR%%/filters/count_in_prompt.py
%%DATADIR%%/filters/debug_null
%%DATADIR%%/filters/ftp_filter
%%DATADIR%%/filters/ftp_filter.py
%%DATADIR%%/filters/handle_hotkeys
%%DATADIR%%/filters/handle_hotkeys.py
%%DATADIR%%/filters/handle_sigwinch.py
%%DATADIR%%/filters/history_format
%%DATADIR%%/filters/listing
%%DATADIR%%/filters/logger
%%DATADIR%%/filters/logger.py
%%DATADIR%%/filters/null
%%DATADIR%%/filters/null.py
%%DATADIR%%/filters/outfilter
%%DATADIR%%/filters/paint_prompt
%%DATADIR%%/filters/paint_prompt.py
%%DATADIR%%/filters/pipeline
%%DATADIR%%/filters/pipeto
%%DATADIR%%/filters/pipeto.py
%%DATADIR%%/filters/rlwrapfilter.py
%%DATADIR%%/filters/scrub_prompt
%%DATADIR%%/filters/simple_macro
%%DATADIR%%/filters/template
%%DATADIR%%/filters/unbackspace
man/man1/rlwrap.1.gz
man/man3/RlwrapFilter.3pm.gz