Remove kplot3d since it's homepage and distfiles disappeared

long ago (was kde1-based anyway).
This commit is contained in:
Chris D. Faulhaber 2001-11-27 15:21:34 +00:00
parent 11ab8da3b5
commit d5078f1e93
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=50649
8 changed files with 0 additions and 197 deletions

View File

@ -128,7 +128,6 @@
SUBDIR += kdc2tiff
SUBDIR += kdegraphics2
SUBDIR += kisomandel
SUBDIR += kplot3d
SUBDIR += kuickshow
SUBDIR += landscape
SUBDIR += lcms

View File

@ -1,19 +0,0 @@
# New ports collection makefile for: kplot3d
# Date created: 30 October 1999
# Whom: Chris D. Faulhaber <jedgar@fxp.org>
#
# $FreeBSD$
#
PORTNAME= kplot3d
PORTVERSION= 0.70
CATEGORIES= graphics kde
MASTER_SITES= http://members.nbci.com/kplot3d/
MAINTAINER= jedgar@FreeBSD.org
USE_KDELIBS_VER=1
GNU_CONFIGURE= yes
USE_GMAKE= yes
.include <bsd.port.mk>

View File

@ -1 +0,0 @@
MD5 (kplot3d-0.70.tar.gz) = d519ba0f0c7c84961bc1355c48d0e75d

View File

@ -1,138 +0,0 @@
--- kplot3d/SetColor.cpp.orig Sat Nov 27 08:05:33 1999
+++ kplot3d/SetColor.cpp Sat Nov 27 08:28:36 1999
@@ -148,9 +148,30 @@
Button_gray->setGeometry( 240, 90, 30, 30 );
Button_gray->setText( "" );
{
- QColorGroup normal( QColor( QRgb(0) ), QColor( QRgb(10789024) ), QColor( QRgb(16777215) ), QColor( QRgb(8421504) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
- QColorGroup disabled( QColor( QRgb(8421504) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(8421504) ), QColor( QRgb(10789024) ), QColor( QRgb(8421504) ), QColor( QRgb(12632256) ) );
- QColorGroup active( QColor( QRgb(0) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(8421504) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
+ QColorGroup normal(
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)16777215 ) );
+ QColorGroup disabled(
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)12632256 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)12632256 ) );
+ QColorGroup active(
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)12632256 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)16777215 ) );
QPalette palette( normal, disabled, active );
Button_gray->setPalette( palette );
}
@@ -161,9 +182,30 @@
Button_blue->setGeometry( 200, 90, 30, 30 );
Button_blue->setText( "" );
{
- QColorGroup normal( QColor( QRgb(0) ), QColor( QRgb(8388608) ), QColor( QRgb(16777215) ), QColor( QRgb(8421504) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
- QColorGroup disabled( QColor( QRgb(8421504) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(8421504) ), QColor( QRgb(10789024) ), QColor( QRgb(8421504) ), QColor( QRgb(12632256) ) );
- QColorGroup active( QColor( QRgb(0) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(8421504) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
+ QColorGroup normal(
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)8388608 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)16777215 ) );
+ QColorGroup disabled(
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)12632256 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)12632256 ) );
+ QColorGroup active(
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)12632256 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)16777215 ) );
QPalette palette( normal, disabled, active );
Button_blue->setPalette( palette );
}
@@ -174,9 +216,30 @@
Button_mag->setGeometry( 280, 90, 30, 30 );
Button_mag->setText( "" );
{
- QColorGroup normal( QColor( QRgb(0) ), QColor( QRgb(8388736) ), QColor( QRgb(16777215) ), QColor( QRgb(8421504) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
- QColorGroup disabled( QColor( QRgb(8421504) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(8421504) ), QColor( QRgb(10789024) ), QColor( QRgb(8421504) ), QColor( QRgb(12632256) ) );
- QColorGroup active( QColor( QRgb(0) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(8421504) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
+ QColorGroup normal(
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)8388736 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)16777215 ) );
+ QColorGroup disabled(
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)12632256 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)12632256 ) );
+ QColorGroup active(
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)12632256 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)16777215 ) );
QPalette palette( normal, disabled, active );
Button_mag->setPalette( palette );
}
@@ -186,9 +249,30 @@
Button_green->setGeometry( 320, 90, 30, 30 );
Button_green->setText( "" );
{
- QColorGroup normal( QColor( QRgb(0) ), QColor( QRgb(32768) ), QColor( QRgb(16777215) ), QColor( QRgb(8421504) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
- QColorGroup disabled( QColor( QRgb(8421504) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(8421504) ), QColor( QRgb(10789024) ), QColor( QRgb(8421504) ), QColor( QRgb(12632256) ) );
- QColorGroup active( QColor( QRgb(0) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(8421504) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
+ QColorGroup normal(
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)32768 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)16777215 ) );
+ QColorGroup disabled(
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)12632256 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)12632256 ) );
+ QColorGroup active(
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)12632256 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)16777215 ) );
QPalette palette( normal, disabled, active );
Button_green->setPalette( palette );
}

View File

@ -1,13 +0,0 @@
--- kplot3d/kplot3d.cpp.orig Sat Nov 27 08:30:23 1999
+++ kplot3d/kplot3d.cpp Sat Nov 27 08:31:45 1999
@@ -178,8 +178,8 @@
// toolBar()->insertButton(Icon("editpaste.xpm"), ID_EDIT_PASTE, true, i18n("Paste"));
// toolBar()->insertSeparator();
- toolBar()->insertButton( QPixmap( axes ), ID_GENERAL, true, i18n("Axes options"));
- toolBar()->insertButton( QPixmap( toggle_icon ), ID_TOGGLE, true, i18n("Toggle surface type"));
+ toolBar()->insertButton( QPixmap( (const char**)axes ), ID_GENERAL, true, i18n("Axes options"));
+ toolBar()->insertButton( QPixmap( (const char**)toggle_icon ), ID_TOGGLE, true, i18n("Toggle surface type"));
toolBar()->insertButton(Icon("help.xpm"), ID_HELP, SIGNAL(pressed()), kapp, SLOT(appHelpActivated()), true, i18n("Help"));
///////////////////////////////////////////////////////////////////

View File

@ -1 +0,0 @@
KDE 3d surface plotting tool

View File

@ -1,8 +0,0 @@
Kplot3d is KDE version of tool for plotting 3d surface
of function z = f(x,y). It supports shaded and grid
(with erasing of invisible lines) modes, fast realtime
surface rotation, printing result image, save images to
local files.
- Chris D. Faulhaber
jedgar@fxp.org

View File

@ -1,16 +0,0 @@
bin/kplot3d
share/applnk/Applications/kplot3d.kdelnk
share/apps/kplot3d/pics/intro.jpg
share/doc/HTML/en/kplot3d/index-1.html
share/doc/HTML/en/kplot3d/index-2.html
share/doc/HTML/en/kplot3d/index-3.html
share/doc/HTML/en/kplot3d/index-4.html
share/doc/HTML/en/kplot3d/index-5.html
share/doc/HTML/en/kplot3d/index-6.html
share/doc/HTML/en/kplot3d/index.html
share/icons/kplot3d.xpm
share/icons/mini/kplot3d.xpm
share/locale/ru/LC_MESSAGES/kplot3d.mo
@dirrm share/doc/HTML/en/kplot3d
@dirrm share/apps/kplot3d/pics
@dirrm share/apps/kplot3d