A little library with functions to encode/decode MIME headers.
This commit is contained in:
parent
46d381e00f
commit
d4f7d7c3ca
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=3044
19
japanese/mimekit/Makefile
Normal file
19
japanese/mimekit/Makefile
Normal file
@ -0,0 +1,19 @@
|
||||
# New ports collection makefile for: mimekit
|
||||
# Version required: 1.1
|
||||
# Date created: 9 April 1996
|
||||
# Whom: Masafumi NAKANE <max@sfc.wide.ad.jp>
|
||||
#
|
||||
# $Id: porting.sgml,v 1.16 1996/03/21 14:15:01 asami Exp $
|
||||
#
|
||||
|
||||
DISTNAME= mimekit1.1
|
||||
PKGNAME= mimekit-1.1
|
||||
CATEGORIES+= japanese mail
|
||||
MASTER_SITES= ftp://etlport.etl.go.jp/pub/ccipr/DeleGate/ \
|
||||
ftp://ftp.iij.ad.jp/pub/mail/mime/
|
||||
|
||||
MAINTAINER= max@sfc.wide.ad.jp
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
|
||||
.include <bsd.port.mk>
|
1
japanese/mimekit/distinfo
Normal file
1
japanese/mimekit/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (mimekit1.1.tar.gz) = a0e945e65f9d2108c7e86d212dafc2bf
|
33
japanese/mimekit/files/patch-aa
Normal file
33
japanese/mimekit/files/patch-aa
Normal file
@ -0,0 +1,33 @@
|
||||
--- ./Makefile.org Fri Dec 1 23:55:07 1995
|
||||
+++ ./Makefile Fri Apr 26 01:15:07 1996
|
||||
@@ -12,7 +12,7 @@
|
||||
MMDIR = ../../../src
|
||||
MMSDIR = ../
|
||||
DGDIR = ../src
|
||||
-INSTDIR = /usr/local/lib
|
||||
+INSTDIR = ${PREFIX}/lib
|
||||
|
||||
LOCALFILES = README \
|
||||
README.jp \
|
||||
@@ -52,7 +52,7 @@
|
||||
ALL = toMime fromMime enMime deMime test.out bench
|
||||
|
||||
CC = cc
|
||||
-CFLAGS = -O
|
||||
+CFLAGS += -O
|
||||
RM = rm -f
|
||||
RANLIB = `./mkranlib`
|
||||
TAR = tar
|
||||
@@ -98,9 +98,9 @@
|
||||
enMime deMime bench.o test.out
|
||||
|
||||
install: fromMime toMime $(LIBMKIT)
|
||||
- install -o bin -g bin -m 755 fromMime $(INSTDIR)
|
||||
- install -o bin -g bin -m 755 toMime $(INSTDIR)
|
||||
- install -o root -g staff -m 644 $(LIBMKIT) $(INSTDIR)
|
||||
+ install -cs -o bin -g bin -m 755 fromMime $(INSTDIR)
|
||||
+ install -cs -o bin -g bin -m 755 toMime $(INSTDIR)
|
||||
+ install -o bin -g bin -m 644 $(LIBMKIT) $(INSTDIR)
|
||||
$(RANLIB) $(INSTDIR)/$(LIBMKIT)
|
||||
|
||||
config.h:; ln -s $(MMDIR)/config.h .
|
1
japanese/mimekit/pkg-comment
Normal file
1
japanese/mimekit/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Library to handle messages with MIME-encoded headers.
|
6
japanese/mimekit/pkg-descr
Normal file
6
japanese/mimekit/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
This library contains functions to encode/decode MIME header.
|
||||
|
||||
It provides functions ``MIME_strHeaderEncode'' and
|
||||
``MIME_strHeaderEncode''.
|
||||
|
||||
- Masafumi
|
3
japanese/mimekit/pkg-plist
Normal file
3
japanese/mimekit/pkg-plist
Normal file
@ -0,0 +1,3 @@
|
||||
lib/fromMime
|
||||
lib/toMime
|
||||
lib/libmimekit.a
|
Loading…
Reference in New Issue
Block a user