Add cplay-1.45

cplay is a curses based front-end to various audioplayers.

Supported players currently include:
        - mpg123
        - ogg123
        - madplay
        - mikmod
        - mpg321
        - splay

Submitted by:	Jochem Kossen <j.kossen@home.nl>
PR:		ports/31773
This commit is contained in:
Kris Kennaway 2002-05-25 10:54:18 +00:00
parent b6d473b7f1
commit d4e087ffcc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=59971
8 changed files with 119 additions and 0 deletions

View File

@ -29,6 +29,7 @@
SUBDIR += cheesetracker
SUBDIR += chordpack
SUBDIR += cmp3
SUBDIR += cplay
SUBDIR += csound
SUBDIR += csound-manual
SUBDIR += cymbaline

81
audio/cplay/Makefile Normal file
View File

@ -0,0 +1,81 @@
# New ports collection makefile for: cplay
# Date created: 1 November 2001
# Whom: Jochem Kossen
#
# $FreeBSD$
#
PORTNAME= cplay
PORTVERSION= 1.45
CATEGORIES= audio
MASTER_SITES= http://www.tf.hut.fi/~flu/cplay/
MAINTAINER= j.kossen@home.nl
RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
USE_GMAKE= yes
USE_PYTHON= yes
MAN1= cplay.1
MAKE_ARGS+= PREFIX="${PREFIX}"
.if defined(WITH_VORBIS)
RUN_DEPENDS+= ogg123:${PORTSDIR}/audio/vorbis-tools
.endif
.if defined(WITH_MADPLAY)
RUN_DEPENDS+= madplay:${PORTSDIR}/audio/mad
.endif
.if defined(WITH_MIKMOD)
RUN_DEPENDS+= mikmod:${PORTSDIR}/audio/mikmod
.endif
.if defined(WITH_MPG321)
RUN_DEPENDS+= mpg321:$(PORTSDIR)/audio/mpg321
.endif
.if defined(WITH_SPLAY)
RUN_DEPENDS+= splay:${PORTSDIR}/audio/splay
.endif
pre-everything:
.if !defined(WITH_VORBIS) || !defined(WITH_MADPLAY) || !defined(WITH_MIKMOD) || defined(WITH_MPG321) || !defined(WITH_SPLAY)
@${ECHO_MSG}
.if !defined(WITH_VORBIS)
@${ECHO_MSG} "If you want to have OGG VORBIS support,"
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_VORBIS=yes\""
@${ECHO_MSG}
.endif
.if !defined(WITH_MADPLAY)
@${ECHO_MSG} "If you want to have MADPLAY support,"
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_MADPLAY=yes\""
@${ECHO_MSG}
.endif
.if !defined(WITH_MIKMOD)
@${ECHO_MSG} "If you want to have MIKMOD support,"
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_MIKMOD=yes\""
@${ECHO_MSG}
.endif
.if !defined(WITH_MPG321)
@${ECHO_MSG} "If you want to have MPG321 support,"
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_MPG321=yes\""
@${ECHO_MSG}
.endif
.if !defined(WITH_SPLAY)
@${ECHO_MSG} "If you want to have SPLAY support,"
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_SPLAY=yes\""
@${ECHO_MSG}
.endif
.endif
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/cplay
${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/cplay
${INSTALL_MAN} ${WRKSRC}/ChangeLog ${PREFIX}/share/doc/cplay
${INSTALL_MAN} ${WRKSRC}/TODO ${PREFIX}/share/doc/cplay
.endif
.include <bsd.port.mk>

1
audio/cplay/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (cplay-1.45.tar.gz) = 79d2157739dc38e91312a037b9885dc8

View File

@ -0,0 +1,9 @@
--- Makefile.orig Fri Nov 2 11:07:31 2001
+++ Makefile Fri Nov 2 11:10:33 2001
@@ -14,5 +14,5 @@
recursive-all recursive-install recursive-clean:
@target=$@; \
for i in $(SUBDIRS); do \
- (cd $$i && make $(ENV) $${target#recursive-}); \
+ (cd $$i && $(MAKE) $(ENV) $${target#recursive-}); \
done

1
audio/cplay/pkg-comment Normal file
View File

@ -0,0 +1 @@
A curses based front-end for various audio players

11
audio/cplay/pkg-descr Normal file
View File

@ -0,0 +1,11 @@
cplay is a curses based front-end to various audioplayers.
Supported players currently include:
- mpg123
- ogg123
- madplay
- mikmod
- mpg321
- splay
WWW: http://www.tf.hut.fi/~flu/cplay/

6
audio/cplay/pkg-plist Normal file
View File

@ -0,0 +1,6 @@
bin/cplay
%%PORTDOCS%%share/doc/cplay/README
%%PORTDOCS%%share/doc/cplay/ChangeLog
%%PORTDOCS%%share/doc/cplay/TODO
share/locale/de/LC_MESSAGES/cplay.mo
%%PORTDOCS%%@dirrm share/doc/cplay

View File

@ -0,0 +1,9 @@
bin/cplay
%%PORTDOCS%%share/doc/cplay/README
%%PORTDOCS%%share/doc/cplay/ChangeLog
%%PORTDOCS%%share/doc/cplay/TODO
share/locale/de/LC_MESSAGES/cplay.mo
%%PORTDOCS%%share@dirrm share/doc/cplay
@dirrm share/locale/de/LC_MESSAGES
@dirrm share/locale/de
@dirrm share/locale