New port: graphics/blend2d: 2D Vector Graphics Engine Powered by a JIT Compiler

This commit is contained in:
Yuri Victorovich 2020-01-10 05:53:27 +00:00
parent ceee9a8344
commit d477ab1952
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=522556
6 changed files with 76 additions and 0 deletions

View File

@ -67,6 +67,7 @@
SUBDIR += barcode
SUBDIR += batik
SUBDIR += bitmap
SUBDIR += blend2d
SUBDIR += blender
SUBDIR += blender-doc
SUBDIR += bmeps

22
graphics/blend2d/Makefile Normal file
View File

@ -0,0 +1,22 @@
# $FreeBSD$
PORTNAME= blend2d
DISTVERSION= g20200108
CATEGORIES= graphics
MAINTAINER= yuri@FreeBSD.org
COMMENT= 2D Vector Graphics Engine Powered by a JIT Compiler
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/LICENSE.md
LIB_DEPENDS= libasmjit.so:devel/asmjit
USES= cmake localbase
USE_GITHUB= yes
GH_TAGNAME= 592d1ba52672bbf6365aba476bfe26b7bd2dfab8
USE_LDCONFIG= yes
LDFLAGS+= ${LOCALBASE}/lib/libasmjit.so # see https://github.com/blend2d/blend2d/issues/57
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1578632852
SHA256 (blend2d-blend2d-g20200108-592d1ba52672bbf6365aba476bfe26b7bd2dfab8_GH0.tar.gz) = d46a87c10a81218ee15b36e9689de37a689f79bc867019f2a4a615e7aea4abd9
SIZE (blend2d-blend2d-g20200108-592d1ba52672bbf6365aba476bfe26b7bd2dfab8_GH0.tar.gz) = 651784

View File

@ -0,0 +1,11 @@
--- CMakeLists.txt.orig 2020-01-10 05:21:39 UTC
+++ CMakeLists.txt
@@ -299,7 +299,7 @@ if ("${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
endif()
# Find asmjit dependency if building with JIT support.
-if (NOT BLEND2D_BUILD_NO_JIT)
+if (FALSE AND NOT BLEND2D_BUILD_NO_JIT)
if (NOT DEFINED ASMJIT_DIR)
foreach(dir "${BLEND2D_DIR}/3rdparty/asmjit"
"${CMAKE_CURRENT_LIST_DIR}/../asmjit")

View File

@ -0,0 +1,10 @@
Blend2D is a high performance 2D vector graphics engine written in C++ and
released under the Zlib license. It has a built-in JIT compiler that generates
optimized pipelines at runtime. Additionally, the engine features a new
rasterizer that has been written from scratch. It delivers superior performance
while quality is comparable to rasterizers used by AGG and FreeType. The
performance has been optimized by using an innovative approach to index data
that is built during rasterization and scanned during composition. The
rasterizer is robust and excels in rendering complex vector art and text.
WWW: https://blend2d.com/

View File

@ -0,0 +1,29 @@
include/blend2d-debug.h
include/blend2d-impl.h
include/blend2d.h
include/blend2d/api-impl.h
include/blend2d/api.h
include/blend2d/array.h
include/blend2d/bitarray.h
include/blend2d/context.h
include/blend2d/filesystem.h
include/blend2d/font.h
include/blend2d/fontdefs.h
include/blend2d/fontmanager.h
include/blend2d/format.h
include/blend2d/geometry.h
include/blend2d/glyphbuffer.h
include/blend2d/gradient.h
include/blend2d/image.h
include/blend2d/imagecodec.h
include/blend2d/matrix.h
include/blend2d/path.h
include/blend2d/pattern.h
include/blend2d/pixelconverter.h
include/blend2d/random.h
include/blend2d/region.h
include/blend2d/rgba.h
include/blend2d/runtime.h
include/blend2d/string.h
include/blend2d/variant.h
lib/libblend2d.so