ports/math/asir2000 do not build. This probrem has two reasons.

1) ports/matn/pari-devel update.
2) 5-current do not build. This reasion is thread problem.

This send-pr solved that problems.

PR:		ports/44308
Submitted by:	Saito Tomokatsu <saito@asir.org>
This commit is contained in:
Edwin Groothuis 2002-11-07 13:16:35 +00:00
parent 4a9e91a892
commit d44c501b21
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=69661
5 changed files with 34 additions and 26 deletions

View File

@ -6,9 +6,10 @@
#
PORTNAME= asir
PORTVERSION= 20020910
PORTVERSION= 20021020
CATEGORIES= math
MASTER_SITES= ftp://ftp.asir.org/pub/asir/src/
MASTER_SITES= ftp://ftp.jssac.org/pub/distfiles/asir/ \
ftp://ftp.asir.org/pub/asir/src/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${ASIR_DOC}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@ -24,7 +25,7 @@ CONFIGURE_ENV= OLD_PARI_VERSION=${OLD_PARI_VERSION} \
PARI_VERSION=${PARI_VERSION} \
LAPACK_VERSION=${LAPACK_VERSION}
CONFIGURE_ARGS= -oxhome ${PREFIX} -plot ${PARI} -fep -interval ${LAPACK}
ASIR_DOC_VERSION= 20020910
ASIR_DOC_VERSION= 20021020
ASIR_DOC= asirdoc-${ASIR_DOC_VERSION}.tar.gz
MAN1= asir.1
@ -36,7 +37,7 @@ LIB_DEPENDS= # dummy
OLD_PARI_DIR= ${PORTSDIR}/math/pari
OLD_PARI_VERSION= `${GREP} PORTVERSION ${OLD_PARI_DIR}/Makefile | cut -f 2`
PARI_DIR= ${PORTSDIR}/math/pari-devel
PARI_VERSION= `${GREP} PORTVERSION ${PARI_DIR}/Makefile | cut -f 2`
PARI_VERSION= `${GREP} MAJOR_VERSION ${PARI_DIR}/Makefile | ${GREP} -v { | cut -f 2`.`${GREP} MINOR_VERSION ${PARI_DIR}/Makefile | ${GREP} -v { | cut -f 2`.`${GREP} REV_VERSION ${PARI_DIR}/Makefile | ${GREP} -v { | cut -f 2`.alpha
.if defined(USE_OLDPARI)
LIB_DEPENDS+= pari.1:${OLD_PARI_DIR}

View File

@ -1,2 +1,2 @@
MD5 (asir-20020910.tar.gz) = bb89246a7a8d2130e96e596dd6140507
MD5 (asirdoc-20020910.tar.gz) = 31976cc7f276c99e4c073872fffac1e3
MD5 (asir-20021020.tar.gz) = 16466840115d8e8ab94297b63467279e
MD5 (asirdoc-20021020.tar.gz) = f72afe8d5360e3ea69548306185433d7

View File

@ -1,8 +1,10 @@
--- include/version.h.orig Fri Mar 1 09:40:52 2002
+++ include/version.h Sat Mar 2 20:09:47 2002
@@ -48,4 +48,4 @@
* $OpenXM: OpenXM_contrib2/asir2000/include/version.h,v 1.61 2002/03/01 00:40:52 noro Exp $
--- include/version.h.orig Thu Oct 3 10:12:46 2002
+++ include/version.h Wed Oct 9 01:37:03 2002
@@ -47,5 +47,5 @@
*
* $OpenXM: OpenXM_contrib2/asir2000/include/version.h,v 1.75 2002/10/03 01:12:46 noro Exp $
*/
#define ASIR_VERSION 20020301
-#define ASIR_VERSION 20021003
-#define ASIR_DISTRIBUTION "Kobe"
+#define ASIR_VERSION 20021020
+#define ASIR_DISTRIBUTION "Plotting Group"

View File

@ -1,5 +1,5 @@
--- configure.orig Thu Jul 25 17:53:13 2002
+++ configure Fri Jul 26 14:44:17 2002
+++ configure Thu Oct 17 11:18:59 2002
@@ -4,6 +4,7 @@
use_plot=0
use_pari=0
@ -29,20 +29,26 @@
libname=$libname"_pari"
libpari=pari-2.2
echo "#define USE_PARI" >> include/config.h
+echo "#define PARI_VERSION \"PARI ${PARI_VERSION}, copyright (C) 2000,
+echo "#define PARI_DEVEL_VERSION \"PARI ${PARI_VERSION}, copyright (C) 2000,
+ C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier\"" >> include/version.h
fi
if [ $use_plot != 0 ]; then
@@ -59,6 +66,11 @@
if [ $use_interval != 0 ]; then
libname=$libname"_itv"
@@ -61,6 +68,11 @@
echo "#define USE_INTERVAL" >> include/config.h
+fi
+
fi
+if [ $use_lapack != 0 ]; then
+echo "#define USE_LAPACK" >> include/config.h
+echo "#define LAPACK_VERSION \"LAPACK Project Version ${LAPACK_VERSION}\"" >> include/version.h
fi
+fi
+
if [ $use_fep != 0 ]; then
echo "#define USE_FEP" >> include/config.h
fi
@@ -68,4 +80,4 @@
echo LIBPARI=$libpari >> include/config.h
echo LIBASIR=$libname.a >> include/config.h
-(cd gc; ./configure)
+(cd gc; ./configure --disable-threads)

View File

@ -1,5 +1,5 @@
--- parse/glob.c.orig Fri Jul 26 09:33:03 2002
+++ parse/glob.c Fri Jul 26 14:38:01 2002
--- parse/glob.c.orig Wed Sep 11 17:57:21 2002
+++ parse/glob.c Thu Oct 17 11:19:30 2002
@@ -51,6 +51,7 @@
#include "al.h"
#include "parse.h"
@ -8,14 +8,13 @@
#if PARI
#include "genpari.h"
#endif
@@ -669,8 +670,12 @@
@@ -669,7 +670,12 @@
printf("Copyright (C) 1994-2000, all rights reserved, FUJITSU LABORATORIES LIMITED.\n");
printf("Copyright 2000,2001, Risa/Asir committers, http://www.openxm.org/.\n");
printf("GC 6.1(alpha5) copyright 2001, H-J. Boehm, A. J. Demers, Xerox, SGI, HP.\n");
- printf("PARI 2.2.1(alpha), copyright (C) 2000,\n");
- printf(" C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier.\n");
- printf("PARI 2.2.4, copyright (C) 2002 The PARI Group.\n");
+#if PARI
+ printf("%s.\n",PARI_VERSION);
+ printf("%s.\n",PARI_DEVEL_VERSION);
+#endif
+#if LAPACK
+ printf("%s.\n",LAPACK_VERSION);