Fix build of ossec-hids-agent with -fno-common

Update the referenced master port and included version.mk file.

The patches are not relevant for ossec-hids-local, but have to be added
there to become effective in ossec-hids-agents.
This commit is contained in:
Stefan Eßer 2020-09-21 18:57:18 +00:00
parent d78009b2cf
commit d443b0b243
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=549478
7 changed files with 79 additions and 1 deletions

View File

@ -0,0 +1,18 @@
--- src/addagent/main.c.orig 2020-02-14 19:46:22 UTC
+++ src/addagent/main.c
@@ -17,6 +17,7 @@ static void print_banner(void);
static void manage_shutdown(int sig) __attribute__((noreturn));
#endif
+int willchroot;
#if defined(__MINGW32__)
static int setenv(const char *name, const char *val, __attribute__((unused)) int overwrite)
@@ -104,7 +105,6 @@ int main(int argc, char **argv)
int ret;
#endif
- extern int willchroot;
willchroot = 1;
/* Set the name */

View File

@ -0,0 +1,8 @@
--- src/addagent/manage_agents.h.orig 2020-02-14 19:46:22 UTC
+++ src/addagent/manage_agents.h
@@ -147,4 +147,4 @@ extern fpos_t fp_pos;
#define GMF_UNKN_ERROR ARGV0 ": Could not run GetModuleFileName which returned (%ld).\n"
-int willchroot;
+extern int willchroot;

View File

@ -0,0 +1,19 @@
--- src/client-agent/agentd.c.orig 2020-02-14 19:46:22 UTC
+++ src/client-agent/agentd.c
@@ -15,6 +15,8 @@
#include "os_dns/os_dns.h"
#endif //WIN32
+struct imsgbuf server_ibuf;
+
/* Start the agent daemon */
void AgentdStart(const char *dir, int uid, int gid, const char *user, const char *group)
{
@@ -39,7 +41,6 @@ void AgentdStart(const char *dir, int uid, int gid, co
merror("starting imsg stuff");
/* Prepare for os_dns */
struct imsgbuf osdns_ibuf;
- extern struct imsgbuf server_ibuf;
//struct imsgbuf osdns_ibuf;
int imsg_fds[2];
merror("Creating socketpair()");

View File

@ -0,0 +1,11 @@
--- src/client-agent/agentd.h.orig 2020-02-14 19:46:22 UTC
+++ src/client-agent/agentd.h
@@ -83,7 +83,7 @@ extern int run_foreground;
extern keystore keys;
extern agent *agt;
#ifndef WIN32
-struct imsgbuf server_ibuf;
+extern struct imsgbuf server_ibuf;
#endif //WIN32
#endif /* __AGENTD_H */

View File

@ -0,0 +1,12 @@
--- src/client-agent/config.c.orig 2020-02-14 19:46:22 UTC
+++ src/client-agent/config.c
@@ -17,8 +17,8 @@
time_t available_server;
int run_foreground;
keystore keys;
-agent *agt;
+extern agent *agt;
/* Read the config file (for the remote client) */
int ClientConf(const char *cfgfile)

View File

@ -0,0 +1,10 @@
--- src/os_net/os_net.c.orig 2020-02-14 19:46:22 UTC
+++ src/os_net/os_net.c
@@ -14,6 +14,7 @@
#include <errno.h>
#include "shared.h"
#include "os_net.h"
+
agent *agt;
/* Prototypes */

View File

@ -1,6 +1,6 @@
PORTNAME= ossec-hids
PORTVERSION= 3.6.0
PORTREVISION?= 0
PORTREVISION?= 1
CATEGORIES= security
MAINTAINER= dominik.lisiak@bemsoft.pl