Update subversion to new version 1.14.0.
1.14.0 is LTS, but `devel/subversion-lts' is still 1.10.x, because it allows to build `devel/py-subversion' with Python 2.7. `devel/py-subversion' will be built with Python 3.5+ for version 1.14.0.
This commit is contained in:
parent
262a7fa640
commit
d3e7b575c2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=537554
@ -9,7 +9,7 @@ COMMENT= Perl bindings for Version control system
|
||||
USES= perl5
|
||||
USE_PERL5= build run
|
||||
|
||||
PORTREVISION_113= 0
|
||||
PORTREVISION_114= 0
|
||||
PORTREVISION_LTS= 0
|
||||
|
||||
SVN_BUILD_BINDINGS= yes
|
||||
|
@ -7,10 +7,12 @@ PORTREVISION= 0
|
||||
MAINTAINER= lev@FreeBSD.org
|
||||
COMMENT= Python bindings for version control system
|
||||
|
||||
USES+= python:2.7
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/py3c.h:devel/py3c
|
||||
|
||||
USES= python:${BINDINGS_PYTHON_VERSION}
|
||||
USE_PYTHON= flavors py3kplist
|
||||
|
||||
PORTREVISION_113= 0
|
||||
PORTREVISION_114= 0
|
||||
PORTREVISION_LTS= 0
|
||||
|
||||
SVN_BUILD_BINDINGS= yes
|
||||
@ -19,11 +21,19 @@ SVN_BUILD_BINDINGS= yes
|
||||
|
||||
CATEGORIES+= python
|
||||
|
||||
.if ${WITH_SUBVERSION_VER} == 114
|
||||
BINDINGS_PYTHON_VERSION= 3.5+
|
||||
.elif ${WITH_SUBVERSION_VER} == LTS
|
||||
BINDINGS_PYTHON_VERSION= 2.7
|
||||
.else
|
||||
BROKEN= Wrong WITH_SUBVERSION_VER=${WITH_SUBVERSION_VER}, only 114 (default) and LTS are supported
|
||||
.endif
|
||||
|
||||
CONFIGURE_ARGS+= --without-gnome-keyring \
|
||||
--without-kwallet \
|
||||
--with-apxs=no
|
||||
|
||||
ALL_TARGET= swig-py-lib swig-py check-swig-py
|
||||
ALL_TARGET= swig-py check-swig-py
|
||||
INSTALL_TARGET= install-swig-py
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -8,7 +8,7 @@ COMMENT= Ruby bindings for version control system
|
||||
|
||||
USE_RUBY= yes
|
||||
|
||||
PORTREVISION_113= 0
|
||||
PORTREVISION_114= 0
|
||||
PORTREVISION_LTS= 0
|
||||
|
||||
SVN_BUILD_BINDINGS= yes
|
||||
|
@ -1,7 +1,7 @@
|
||||
# Created by: rooneg@electricjellyfish.net
|
||||
# $FreeBSD$
|
||||
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 0
|
||||
|
||||
MAINTAINER= lev@FreeBSD.org
|
||||
COMMENT= Version control system
|
||||
@ -32,7 +32,7 @@ OPTIONS_DEFAULT=FREEBSD_TEMPLATE GPG_AGENT SERF TOOLS
|
||||
FREEBSD_TEMPLATE_DESC= FreeBSD Project log template
|
||||
GPG_AGENT_DESC= Enable GPG agent password store
|
||||
SERF_DESC= WebDAV/Delta-V (HTTP/HTTPS) repo access module
|
||||
STATIC_DESC= Build static version (no shared libs)
|
||||
STATIC_DESC= No shared libs (disables SVN integration)
|
||||
SVNSERVE_WRAPPER_DESC= Enable svnserve wrapper (umask setter)
|
||||
TEST_DESC= Run subversion test suite
|
||||
TOOLS_DESC= Install several tools
|
||||
@ -41,7 +41,7 @@ TOOLS_DESC= Install several tools
|
||||
FREEBSD_TEMPLATE_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-fbsd-template
|
||||
SVNSERVE_WRAPPER_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-svnserve-wrapper
|
||||
|
||||
USES+= shebangfix python:2.7,env
|
||||
USES+= shebangfix python:3.5+,env
|
||||
python_OLD_CMD+= "/bin/env python"
|
||||
SHEBANG_REGEX= ./tools/.*
|
||||
|
||||
@ -219,7 +219,7 @@ _mkrepos: .USE
|
||||
.endif
|
||||
|
||||
svn-build-outputs-hack:
|
||||
(cd ${WRKSRC} && python2.7 gen-make.py --release --installed-libs libsvn_client,libsvn_delta,libsvn_diff,libsvn_fs,libsvn_fs_x,libsvn_ra,libsvn_repos,libsvn_subr,libsvn_wc)
|
||||
(cd ${WRKSRC} && python gen-make.py --release --installed-libs libsvn_client,libsvn_delta,libsvn_diff,libsvn_fs,libsvn_fs_x,libsvn_ra,libsvn_repos,libsvn_subr,libsvn_wc)
|
||||
${MV} ${WRKSRC}/build-outputs.mk ${FILESDIR}/build-outputs.mk.addons
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,19 +1,19 @@
|
||||
# Created by: lev@FreeBSD.org
|
||||
# $FreeBSD$
|
||||
|
||||
WITH_SUBVERSION_VER?= 113
|
||||
WITH_SUBVERSION_VER?= 114
|
||||
|
||||
PKGDIR= ${.CURDIR}
|
||||
|
||||
SVN_BUILD_ADDONS= yes
|
||||
|
||||
.if ${WITH_SUBVERSION_VER} == 113
|
||||
.if ${WITH_SUBVERSION_VER} == 114
|
||||
CONFLICTS_BUILD+= ${PORTNAME}-1.[0-9].[0-9]* \
|
||||
${PORTNAME}-1.[^1][0-9].[0-9]* \
|
||||
${PORTNAME}-1.1[0-1].[0-9]* \
|
||||
${PORTNAME}-lts-1.[0-9][0-9].[0-9]*
|
||||
PORTREVISION= ${PORTREVISION_113:U0}
|
||||
PLIST_SUB+= SVN113="" SVNLTS="@comment "
|
||||
PORTREVISION= ${PORTREVISION_114:U0}
|
||||
PLIST_SUB+= SVN115="" SVNLTS="@comment "
|
||||
LIB_DEPENDS+= libsvn_client-1.so:devel/subversion
|
||||
OPTIONS_NAME= devel_subversion
|
||||
MASTERDIR= ${.CURDIR}/../../devel/subversion
|
||||
@ -23,11 +23,11 @@ PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-lts
|
||||
CONFLICTS_BUILD+= ${PORTNAME}-1.[0-9].[0-9]* \
|
||||
${PORTNAME}-1.[0-9][0-9].[0-9]*
|
||||
PORTREVISION= ${PORTREVISION_LTS:U0}
|
||||
PLIST_SUB+= SVN113="@comment " SVNLTS=""
|
||||
PLIST_SUB+= SVN114="@comment " SVNLTS=""
|
||||
LIB_DEPENDS+= libsvn_client-1.so:devel/subversion-lts
|
||||
OPTIONS_NAME= devel_subversion-lts
|
||||
MASTERDIR= ${.CURDIR}/../../devel/subversion-lts
|
||||
.include "${MASTERDIR}/Makefile.common"
|
||||
.else
|
||||
BROKEN= Wrong WITH_SUBVERSION_VER=${WITH_SUBVERSION_VER}, only 113 (default) and LTS are supported
|
||||
BROKEN= Wrong WITH_SUBVERSION_VER=${WITH_SUBVERSION_VER}, only 114 (default) and LTS are supported
|
||||
.endif
|
||||
|
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME?= subversion
|
||||
PORTVERSION= 1.13.0
|
||||
PORTVERSION= 1.14.0
|
||||
PORTREVISION?= 0
|
||||
CATEGORIES+= devel
|
||||
MASTER_SITES= APACHE/subversion
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1572818775
|
||||
SHA256 (subversion-1.13.0.tar.bz2) = bc50ce2c3faa7b1ae9103c432017df98dfd989c4239f9f8270bb3a314ed9e5bd
|
||||
SIZE (subversion-1.13.0.tar.bz2) = 8508122
|
||||
TIMESTAMP = 1590841247
|
||||
SHA256 (subversion-1.14.0.tar.bz2) = 6ba8e218f9f97a83a799e58a3c6da1221d034b18d9d8cbbcb6ec52ab11722102
|
||||
SIZE (subversion-1.14.0.tar.bz2) = 8497531
|
||||
|
File diff suppressed because one or more lines are too long
@ -1,11 +1,17 @@
|
||||
--- Makefile.in.orig 2015-09-18 15:56:29.000000000 +0300
|
||||
+++ Makefile.in 2015-10-15 01:29:59.889146000 +0300
|
||||
@@ -86,7 +86,7 @@
|
||||
swig_pydir_extra = @libdir@/svn-python/svn
|
||||
--- Makefile.in.orig 2020-05-31 20:53:15 UTC
|
||||
+++ Makefile.in
|
||||
@@ -89,11 +89,11 @@ swig_pl_libdir = @libdir@
|
||||
swig_rb_libdir = @libdir@
|
||||
|
||||
### these possibly need further discussion
|
||||
-swig_pydir = @libdir@/svn-python/libsvn
|
||||
-swig_pydir_extra = @libdir@/svn-python/svn
|
||||
+swig_pydir = /usr/local/lib/python3.7/site-packages/libsvn
|
||||
+swig_pydir_extra = /usr/local/lib/python3.7/site-packages/svn
|
||||
swig_pldir = @libdir@/svn-perl
|
||||
swig_rbdir = $(SWIG_RB_SITE_ARCH_DIR)/svn/ext
|
||||
-toolsdir = @bindir@/svn-tools
|
||||
+toolsdir = @bindir@
|
||||
|
||||
# where to install pkg-config files
|
||||
pkgconfig_dir = $(datadir)/pkgconfig
|
||||
pkgconfig_dir = $(prefix)/libdata/pkgconfig
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- build.conf.orig 2019-01-16 17:57:54.750177000 +0300
|
||||
+++ build.conf 2019-01-16 17:58:16.348788000 +0300
|
||||
@@ -430,7 +430,7 @@
|
||||
--- build.conf.orig 2020-04-08 04:00:55 UTC
|
||||
+++ build.conf
|
||||
@@ -434,7 +434,7 @@ type = apache-mod
|
||||
path = tools/server-side/mod_dontdothat
|
||||
nonlibs = mod_dav_svn apr aprutil
|
||||
libs = libsvn_subr libhttpd
|
||||
|
310
devel/subversion/files/patch-configure
Normal file
310
devel/subversion/files/patch-configure
Normal file
@ -0,0 +1,310 @@
|
||||
--- configure.orig 2020-05-20 12:21:55 UTC
|
||||
+++ configure
|
||||
@@ -24462,46 +24462,52 @@ $as_echo "$ac_cv_python_libs" >&6; }
|
||||
fi
|
||||
`"
|
||||
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for Python >= 3" >&5
|
||||
+ if test "$SWIG" = "none"; then
|
||||
+ SWIG_PY_ERRMSG=""
|
||||
+ else
|
||||
+ # Look more closely at the SWIG and Python versions to
|
||||
+ # determine SWIG_PY_OPTS. We can skip this if we already
|
||||
+ # have the SWIG-generated files.
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for Python >= 3" >&5
|
||||
$as_echo_n "checking for Python >= 3... " >&6; }
|
||||
if ${ac_cv_python_is_py3+:} false; then :
|
||||
$as_echo_n "(cached) " >&6
|
||||
else
|
||||
|
||||
- ac_cv_python_is_py3="no"
|
||||
- $PYTHON -c 'import sys; sys.exit(0x3000000 > sys.hexversion)' && \
|
||||
- ac_cv_python_is_py3="yes"
|
||||
+ ac_cv_python_is_py3="no"
|
||||
+ $PYTHON -c 'import sys; sys.exit(0x3000000 > sys.hexversion)' && \
|
||||
+ ac_cv_python_is_py3="yes"
|
||||
|
||||
fi
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_python_is_py3" >&5
|
||||
$as_echo "$ac_cv_python_is_py3" >&6; }
|
||||
|
||||
- if test "$ac_cv_python_is_py3" = "yes"; then
|
||||
- if test "$SWIG_VERSION" -ge "300010"; then
|
||||
- SWIG_PY_ERRMSG=""
|
||||
- else
|
||||
- SWIG_PY_ERRMSG="SWIG version is not suitable"
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Subversion Python bindings for Python 3 require SWIG 3.0.10 or newer" >&5
|
||||
+ if test "$ac_cv_python_is_py3" = "yes"; then
|
||||
+ if test "$SWIG_VERSION" -ge "300010"; then
|
||||
+ SWIG_PY_ERRMSG=""
|
||||
+ else
|
||||
+ SWIG_PY_ERRMSG="SWIG version is not suitable"
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Subversion Python bindings for Python 3 require SWIG 3.0.10 or newer" >&5
|
||||
$as_echo "$as_me: WARNING: Subversion Python bindings for Python 3 require SWIG 3.0.10 or newer" >&2;}
|
||||
- fi
|
||||
- if test "$SWIG_VERSION" -lt "400000"; then
|
||||
- SWIG_PY_OPTS="-python -py3 -nofastunpack -modern"
|
||||
+ fi
|
||||
+ if test "$SWIG_VERSION" -lt "400000"; then
|
||||
+ SWIG_PY_OPTS="-python -py3 -nofastunpack -modern"
|
||||
+ else
|
||||
+ SWIG_PY_OPTS="-python -py3 -nofastunpack"
|
||||
+ fi
|
||||
else
|
||||
- SWIG_PY_OPTS="-python -py3 -nofastunpack"
|
||||
- fi
|
||||
- else
|
||||
- if test "$SWIG_VERSION" -lt "400000"; then
|
||||
- SWIG_PY_OPTS="-python -classic"
|
||||
- SWIG_PY_ERRMSG=""
|
||||
- else
|
||||
- SWIG_PY_OPTS="-python -nofastunpack"
|
||||
- SWIG_PY_ERRMSG="SWIG version is not suitable"
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Subversion Python bindings for Python 2 require 1.3.24 <= SWIG < 4.0.0" >&5
|
||||
+ if test "$SWIG_VERSION" -lt "400000"; then
|
||||
+ SWIG_PY_OPTS="-python -classic"
|
||||
+ SWIG_PY_ERRMSG=""
|
||||
+ else
|
||||
+ SWIG_PY_OPTS="-python -nofastunpack"
|
||||
+ SWIG_PY_ERRMSG="SWIG version is not suitable"
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Subversion Python bindings for Python 2 require 1.3.24 <= SWIG < 4.0.0" >&5
|
||||
$as_echo "$as_me: WARNING: Subversion Python bindings for Python 2 require 1.3.24 <= SWIG < 4.0.0" >&2;}
|
||||
+ fi
|
||||
fi
|
||||
fi
|
||||
fi
|
||||
-
|
||||
fi
|
||||
fi
|
||||
|
||||
@@ -25093,46 +25099,52 @@ $as_echo "$ac_cv_python_libs" >&6; }
|
||||
fi
|
||||
`"
|
||||
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for Python >= 3" >&5
|
||||
+ if test "$SWIG" = "none"; then
|
||||
+ SWIG_PY_ERRMSG=""
|
||||
+ else
|
||||
+ # Look more closely at the SWIG and Python versions to
|
||||
+ # determine SWIG_PY_OPTS. We can skip this if we already
|
||||
+ # have the SWIG-generated files.
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for Python >= 3" >&5
|
||||
$as_echo_n "checking for Python >= 3... " >&6; }
|
||||
if ${ac_cv_python_is_py3+:} false; then :
|
||||
$as_echo_n "(cached) " >&6
|
||||
else
|
||||
|
||||
- ac_cv_python_is_py3="no"
|
||||
- $PYTHON -c 'import sys; sys.exit(0x3000000 > sys.hexversion)' && \
|
||||
- ac_cv_python_is_py3="yes"
|
||||
+ ac_cv_python_is_py3="no"
|
||||
+ $PYTHON -c 'import sys; sys.exit(0x3000000 > sys.hexversion)' && \
|
||||
+ ac_cv_python_is_py3="yes"
|
||||
|
||||
fi
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_python_is_py3" >&5
|
||||
$as_echo "$ac_cv_python_is_py3" >&6; }
|
||||
|
||||
- if test "$ac_cv_python_is_py3" = "yes"; then
|
||||
- if test "$SWIG_VERSION" -ge "300010"; then
|
||||
- SWIG_PY_ERRMSG=""
|
||||
- else
|
||||
- SWIG_PY_ERRMSG="SWIG version is not suitable"
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Subversion Python bindings for Python 3 require SWIG 3.0.10 or newer" >&5
|
||||
+ if test "$ac_cv_python_is_py3" = "yes"; then
|
||||
+ if test "$SWIG_VERSION" -ge "300010"; then
|
||||
+ SWIG_PY_ERRMSG=""
|
||||
+ else
|
||||
+ SWIG_PY_ERRMSG="SWIG version is not suitable"
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Subversion Python bindings for Python 3 require SWIG 3.0.10 or newer" >&5
|
||||
$as_echo "$as_me: WARNING: Subversion Python bindings for Python 3 require SWIG 3.0.10 or newer" >&2;}
|
||||
- fi
|
||||
- if test "$SWIG_VERSION" -lt "400000"; then
|
||||
- SWIG_PY_OPTS="-python -py3 -nofastunpack -modern"
|
||||
+ fi
|
||||
+ if test "$SWIG_VERSION" -lt "400000"; then
|
||||
+ SWIG_PY_OPTS="-python -py3 -nofastunpack -modern"
|
||||
+ else
|
||||
+ SWIG_PY_OPTS="-python -py3 -nofastunpack"
|
||||
+ fi
|
||||
else
|
||||
- SWIG_PY_OPTS="-python -py3 -nofastunpack"
|
||||
- fi
|
||||
- else
|
||||
- if test "$SWIG_VERSION" -lt "400000"; then
|
||||
- SWIG_PY_OPTS="-python -classic"
|
||||
- SWIG_PY_ERRMSG=""
|
||||
- else
|
||||
- SWIG_PY_OPTS="-python -nofastunpack"
|
||||
- SWIG_PY_ERRMSG="SWIG version is not suitable"
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Subversion Python bindings for Python 2 require 1.3.24 <= SWIG < 4.0.0" >&5
|
||||
+ if test "$SWIG_VERSION" -lt "400000"; then
|
||||
+ SWIG_PY_OPTS="-python -classic"
|
||||
+ SWIG_PY_ERRMSG=""
|
||||
+ else
|
||||
+ SWIG_PY_OPTS="-python -nofastunpack"
|
||||
+ SWIG_PY_ERRMSG="SWIG version is not suitable"
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Subversion Python bindings for Python 2 require 1.3.24 <= SWIG < 4.0.0" >&5
|
||||
$as_echo "$as_me: WARNING: Subversion Python bindings for Python 2 require 1.3.24 <= SWIG < 4.0.0" >&2;}
|
||||
+ fi
|
||||
fi
|
||||
fi
|
||||
fi
|
||||
-
|
||||
fi
|
||||
fi
|
||||
|
||||
@@ -25724,46 +25736,52 @@ $as_echo "$ac_cv_python_libs" >&6; }
|
||||
fi
|
||||
`"
|
||||
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for Python >= 3" >&5
|
||||
+ if test "$SWIG" = "none"; then
|
||||
+ SWIG_PY_ERRMSG=""
|
||||
+ else
|
||||
+ # Look more closely at the SWIG and Python versions to
|
||||
+ # determine SWIG_PY_OPTS. We can skip this if we already
|
||||
+ # have the SWIG-generated files.
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for Python >= 3" >&5
|
||||
$as_echo_n "checking for Python >= 3... " >&6; }
|
||||
if ${ac_cv_python_is_py3+:} false; then :
|
||||
$as_echo_n "(cached) " >&6
|
||||
else
|
||||
|
||||
- ac_cv_python_is_py3="no"
|
||||
- $PYTHON -c 'import sys; sys.exit(0x3000000 > sys.hexversion)' && \
|
||||
- ac_cv_python_is_py3="yes"
|
||||
+ ac_cv_python_is_py3="no"
|
||||
+ $PYTHON -c 'import sys; sys.exit(0x3000000 > sys.hexversion)' && \
|
||||
+ ac_cv_python_is_py3="yes"
|
||||
|
||||
fi
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_python_is_py3" >&5
|
||||
$as_echo "$ac_cv_python_is_py3" >&6; }
|
||||
|
||||
- if test "$ac_cv_python_is_py3" = "yes"; then
|
||||
- if test "$SWIG_VERSION" -ge "300010"; then
|
||||
- SWIG_PY_ERRMSG=""
|
||||
- else
|
||||
- SWIG_PY_ERRMSG="SWIG version is not suitable"
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Subversion Python bindings for Python 3 require SWIG 3.0.10 or newer" >&5
|
||||
+ if test "$ac_cv_python_is_py3" = "yes"; then
|
||||
+ if test "$SWIG_VERSION" -ge "300010"; then
|
||||
+ SWIG_PY_ERRMSG=""
|
||||
+ else
|
||||
+ SWIG_PY_ERRMSG="SWIG version is not suitable"
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Subversion Python bindings for Python 3 require SWIG 3.0.10 or newer" >&5
|
||||
$as_echo "$as_me: WARNING: Subversion Python bindings for Python 3 require SWIG 3.0.10 or newer" >&2;}
|
||||
- fi
|
||||
- if test "$SWIG_VERSION" -lt "400000"; then
|
||||
- SWIG_PY_OPTS="-python -py3 -nofastunpack -modern"
|
||||
+ fi
|
||||
+ if test "$SWIG_VERSION" -lt "400000"; then
|
||||
+ SWIG_PY_OPTS="-python -py3 -nofastunpack -modern"
|
||||
+ else
|
||||
+ SWIG_PY_OPTS="-python -py3 -nofastunpack"
|
||||
+ fi
|
||||
else
|
||||
- SWIG_PY_OPTS="-python -py3 -nofastunpack"
|
||||
- fi
|
||||
- else
|
||||
- if test "$SWIG_VERSION" -lt "400000"; then
|
||||
- SWIG_PY_OPTS="-python -classic"
|
||||
- SWIG_PY_ERRMSG=""
|
||||
- else
|
||||
- SWIG_PY_OPTS="-python -nofastunpack"
|
||||
- SWIG_PY_ERRMSG="SWIG version is not suitable"
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Subversion Python bindings for Python 2 require 1.3.24 <= SWIG < 4.0.0" >&5
|
||||
+ if test "$SWIG_VERSION" -lt "400000"; then
|
||||
+ SWIG_PY_OPTS="-python -classic"
|
||||
+ SWIG_PY_ERRMSG=""
|
||||
+ else
|
||||
+ SWIG_PY_OPTS="-python -nofastunpack"
|
||||
+ SWIG_PY_ERRMSG="SWIG version is not suitable"
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Subversion Python bindings for Python 2 require 1.3.24 <= SWIG < 4.0.0" >&5
|
||||
$as_echo "$as_me: WARNING: Subversion Python bindings for Python 2 require 1.3.24 <= SWIG < 4.0.0" >&2;}
|
||||
+ fi
|
||||
fi
|
||||
fi
|
||||
fi
|
||||
-
|
||||
fi
|
||||
fi
|
||||
|
||||
@@ -26358,46 +26376,52 @@ $as_echo "$ac_cv_python_libs" >&6; }
|
||||
fi
|
||||
`"
|
||||
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for Python >= 3" >&5
|
||||
+ if test "$SWIG" = "none"; then
|
||||
+ SWIG_PY_ERRMSG=""
|
||||
+ else
|
||||
+ # Look more closely at the SWIG and Python versions to
|
||||
+ # determine SWIG_PY_OPTS. We can skip this if we already
|
||||
+ # have the SWIG-generated files.
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for Python >= 3" >&5
|
||||
$as_echo_n "checking for Python >= 3... " >&6; }
|
||||
if ${ac_cv_python_is_py3+:} false; then :
|
||||
$as_echo_n "(cached) " >&6
|
||||
else
|
||||
|
||||
- ac_cv_python_is_py3="no"
|
||||
- $PYTHON -c 'import sys; sys.exit(0x3000000 > sys.hexversion)' && \
|
||||
- ac_cv_python_is_py3="yes"
|
||||
+ ac_cv_python_is_py3="no"
|
||||
+ $PYTHON -c 'import sys; sys.exit(0x3000000 > sys.hexversion)' && \
|
||||
+ ac_cv_python_is_py3="yes"
|
||||
|
||||
fi
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_python_is_py3" >&5
|
||||
$as_echo "$ac_cv_python_is_py3" >&6; }
|
||||
|
||||
- if test "$ac_cv_python_is_py3" = "yes"; then
|
||||
- if test "$SWIG_VERSION" -ge "300010"; then
|
||||
- SWIG_PY_ERRMSG=""
|
||||
- else
|
||||
- SWIG_PY_ERRMSG="SWIG version is not suitable"
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Subversion Python bindings for Python 3 require SWIG 3.0.10 or newer" >&5
|
||||
+ if test "$ac_cv_python_is_py3" = "yes"; then
|
||||
+ if test "$SWIG_VERSION" -ge "300010"; then
|
||||
+ SWIG_PY_ERRMSG=""
|
||||
+ else
|
||||
+ SWIG_PY_ERRMSG="SWIG version is not suitable"
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Subversion Python bindings for Python 3 require SWIG 3.0.10 or newer" >&5
|
||||
$as_echo "$as_me: WARNING: Subversion Python bindings for Python 3 require SWIG 3.0.10 or newer" >&2;}
|
||||
- fi
|
||||
- if test "$SWIG_VERSION" -lt "400000"; then
|
||||
- SWIG_PY_OPTS="-python -py3 -nofastunpack -modern"
|
||||
+ fi
|
||||
+ if test "$SWIG_VERSION" -lt "400000"; then
|
||||
+ SWIG_PY_OPTS="-python -py3 -nofastunpack -modern"
|
||||
+ else
|
||||
+ SWIG_PY_OPTS="-python -py3 -nofastunpack"
|
||||
+ fi
|
||||
else
|
||||
- SWIG_PY_OPTS="-python -py3 -nofastunpack"
|
||||
- fi
|
||||
- else
|
||||
- if test "$SWIG_VERSION" -lt "400000"; then
|
||||
- SWIG_PY_OPTS="-python -classic"
|
||||
- SWIG_PY_ERRMSG=""
|
||||
- else
|
||||
- SWIG_PY_OPTS="-python -nofastunpack"
|
||||
- SWIG_PY_ERRMSG="SWIG version is not suitable"
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Subversion Python bindings for Python 2 require 1.3.24 <= SWIG < 4.0.0" >&5
|
||||
+ if test "$SWIG_VERSION" -lt "400000"; then
|
||||
+ SWIG_PY_OPTS="-python -classic"
|
||||
+ SWIG_PY_ERRMSG=""
|
||||
+ else
|
||||
+ SWIG_PY_OPTS="-python -nofastunpack"
|
||||
+ SWIG_PY_ERRMSG="SWIG version is not suitable"
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Subversion Python bindings for Python 2 require 1.3.24 <= SWIG < 4.0.0" >&5
|
||||
$as_echo "$as_me: WARNING: Subversion Python bindings for Python 2 require 1.3.24 <= SWIG < 4.0.0" >&2;}
|
||||
+ fi
|
||||
fi
|
||||
fi
|
||||
fi
|
||||
-
|
||||
fi
|
||||
fi
|
||||
|
@ -359,7 +359,6 @@ man/man8/svnserve.8.gz
|
||||
%%DATADIR%%/dist/backport_tests_py.py
|
||||
%%DATADIR%%/dist/changes-to-html.py
|
||||
%%DATADIR%%/dist/checksums.py
|
||||
%%DATADIR%%/dist/create-minor-release-branch.py
|
||||
%%DATADIR%%/dist/detect-conflicting-backports.py
|
||||
%%DATADIR%%/dist/dist.sh
|
||||
%%DATADIR%%/dist/edit-N-log-messages
|
||||
@ -368,6 +367,7 @@ man/man8/svnserve.8.gz
|
||||
%%DATADIR%%/dist/nightly.sh
|
||||
%%DATADIR%%/dist/nominate.pl
|
||||
%%DATADIR%%/dist/rat-excludes
|
||||
%%DATADIR%%/dist/release-lines.yaml
|
||||
%%DATADIR%%/dist/release.py
|
||||
%%DATADIR%%/dist/security/__init__.py
|
||||
%%DATADIR%%/dist/security/_gnupg.py
|
||||
@ -375,9 +375,12 @@ man/man8/svnserve.8.gz
|
||||
%%DATADIR%%/dist/security/mailer.py
|
||||
%%DATADIR%%/dist/security/mailinglist.py
|
||||
%%DATADIR%%/dist/security/parser.py
|
||||
%%DATADIR%%/dist/templates/STATUS.ezt
|
||||
%%DATADIR%%/dist/templates/download.ezt
|
||||
%%DATADIR%%/dist/templates/rc-news.ezt
|
||||
%%DATADIR%%/dist/templates/rc-release-ann.ezt
|
||||
%%DATADIR%%/dist/templates/release-notes-lts.ezt
|
||||
%%DATADIR%%/dist/templates/release-notes.ezt
|
||||
%%DATADIR%%/dist/templates/stable-news.ezt
|
||||
%%DATADIR%%/dist/templates/stable-release-ann.ezt
|
||||
%%DATADIR%%/dist/test.sh
|
||||
|
@ -7,7 +7,7 @@ CATEGORIES= java
|
||||
MAINTAINER= lev@FreeBSD.org
|
||||
COMMENT= Java bindings for Version control system
|
||||
|
||||
USES+= compiler
|
||||
USES= compiler
|
||||
|
||||
USE_JAVA= yes
|
||||
JAVA_OS= native
|
||||
@ -15,7 +15,7 @@ JAVA_BUILD= yes
|
||||
JAVA_RUN= yes
|
||||
|
||||
|
||||
PORTREVISION_113= 0
|
||||
PORTREVISION_114= 0
|
||||
PORTREVISION_LTS= 0
|
||||
|
||||
SVN_BUILD_BINDINGS= yes
|
||||
|
@ -7,7 +7,7 @@ CATEGORIES= security gnome
|
||||
MAINTAINER= lev@FreeBSD.org
|
||||
COMMENT= Gnome Keyring integration for Version control system
|
||||
|
||||
PORTREVISION_113= 0
|
||||
PORTREVISION_114= 0
|
||||
PORTREVISION_LTS= 0
|
||||
|
||||
.include "${.CURDIR}/../../devel/subversion/Makefile.addons"
|
||||
|
Loading…
Reference in New Issue
Block a user