Fix build on powerpc64
While her let "make test" execute the port's test Reported by: linimon
This commit is contained in:
parent
f79727b9b6
commit
d37db18065
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=549987
@ -4,7 +4,7 @@
|
||||
PORTNAME= hexpeek
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 1.0.20200804
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= https://www.hexpeek.com/releases/${DISTNAME}/
|
||||
|
||||
@ -30,4 +30,7 @@ do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/etc/hexpeek.1 ${STAGEDIR}${MANPREFIX}/share/man/man1
|
||||
|
||||
do-test:
|
||||
${MAKE} -C ${WRKSRC}/test test
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- Makefile.orig 2020-08-04 05:58:52 UTC
|
||||
+++ Makefile
|
||||
@@ -26,13 +26,10 @@
|
||||
@@ -26,15 +26,15 @@
|
||||
|
||||
# Note that libedit is optional. To build hexpeek without it, remove
|
||||
# -DHEXPEEK_EDITABLE_CONSOLE and -ledit.
|
||||
@ -11,10 +11,21 @@
|
||||
-CFLAGS := -I$(SRCDIR) -O3 -Wall -fPIC
|
||||
-DFLAGS := -DHEXPEEK_EDITABLE_CONSOLE
|
||||
-LIBS := -ledit #-ltermcap
|
||||
+SRCDIR = src
|
||||
+BINDIR = bin
|
||||
+EXEC = $(BINDIR)/hexpeek
|
||||
+LIBS = -ledit
|
||||
+SRCDIR = src
|
||||
+BINDIR = bin
|
||||
+EXEC = $(BINDIR)/hexpeek
|
||||
+LIBS = -ledit
|
||||
+DFLAGS = -DHEXPEEK_EDITABLE_CONSOLE
|
||||
|
||||
all: $(EXEC)
|
||||
+
|
||||
+test: test/simplediff
|
||||
make -C test
|
||||
|
||||
clear:
|
||||
@@ -44,4 +44,4 @@ clear:
|
||||
$(EXEC): $(SRCDIR)/*.c $(SRCDIR)/*.h
|
||||
mkdir -p $(BINDIR)
|
||||
$(CC) $(CFLAGS) $(DFLAGS) -o $(EXEC) $(SRCDIR)/*.c $(LIBS)
|
||||
- cd $(BINDIR) ; ln -f -s hexpeek hexview ; ln -f -s hexpeek hexDump ; ln -f -s hexpeek hexpack ; ln -f -s hexpeek hexdiff ; cd ..
|
||||
+ cd $(BINDIR) ; ln -f -s hexpeek hexview ; ln -f -s hexpeek hexDump ; ln -f -s hexpeek hexpack ; ln -f -s hexpeek hexdiff
|
||||
|
@ -1,22 +1,17 @@
|
||||
--- test/Makefile.orig 2020-08-04 05:58:52 UTC
|
||||
+++ test/Makefile
|
||||
@@ -24,11 +24,7 @@
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
-SRCDIR := .
|
||||
-BINDIR := .
|
||||
-EXEC := $(BINDIR)/simplediff
|
||||
-CC ?= clang
|
||||
@@ -28,10 +28,13 @@ SRCDIR := .
|
||||
BINDIR := .
|
||||
EXEC := $(BINDIR)/simplediff
|
||||
CC ?= clang
|
||||
-CFLAGS := -O3 -Wall #-fPIC
|
||||
+EXEC = simplediff
|
||||
+CFLAGS ?= -O3 -Wall #-fPIC
|
||||
|
||||
all: $(EXEC)
|
||||
make -C base
|
||||
@@ -37,5 +33,4 @@ clear:
|
||||
rm -f $(EXEC)
|
||||
make -C base clear
|
||||
+
|
||||
+test: all
|
||||
+ sh run
|
||||
|
||||
-$(BINDIR)/simplediff: $(SRCDIR)/simplediff.c
|
||||
- $(CC) $(CFLAGS) -o $@ $(SRCDIR)/simplediff.c
|
||||
+$(EXEC): simplediff.c
|
||||
clear:
|
||||
rm -f $(EXEC)
|
||||
|
11
sysutils/hexpeek/files/patch-test_base_Makefile
Normal file
11
sysutils/hexpeek/files/patch-test_base_Makefile
Normal file
@ -0,0 +1,11 @@
|
||||
--- test/base/Makefile.orig 2020-08-04 05:58:52 UTC
|
||||
+++ test/base/Makefile
|
||||
@@ -28,7 +28,7 @@ SRCDIR := src
|
||||
BINDIR := bin
|
||||
EXEC := $(BINDIR)/server $(BINDIR)/client
|
||||
CC ?= clang
|
||||
-CFLAGS := -O3 -Wall #-fPIC
|
||||
+CFLAGS ?= -O3 -Wall #-fPIC
|
||||
|
||||
all: $(EXEC)
|
||||
|
Loading…
Reference in New Issue
Block a user