mod_memcache manages the parsing of memcached server configuration and

exports a single function for use by other modules to access a
configured apr_memcache object.

WWW:	http://code.google.com/p/modmemcache/

PR:		ports/130272
Submitted by:	Gea-Suan Lin <gslin at gslin.org>
This commit is contained in:
Martin Wilke 2009-01-10 15:02:48 +00:00
parent 5f5613977c
commit d367f15350
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=225650
6 changed files with 46 additions and 0 deletions

View File

@ -459,6 +459,7 @@
SUBDIR += mod_macro
SUBDIR += mod_macro2
SUBDIR += mod_macro22
SUBDIR += mod_memcache
SUBDIR += mod_mp3
SUBDIR += mod_musicindex
SUBDIR += mod_mya

22
www/mod_memcache/Makefile Normal file
View File

@ -0,0 +1,22 @@
# New ports collection makefile for: mod_memcache
# Date created: 2009-01-06
# Whom: Gea-Suan Lin <gslin@gslin.org>
#
# $FreeBSD$
#
PORTNAME= mod_memcache
PORTVERSION= 0.1.0
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= gslin@gslin.org
COMMENT= Apache 2.2.x module to manage apr_memcache connections
LIB_DEPENDS= apr-1:${PORTSDIR}/devel/apr
GNU_CONFIGURE= yes
PROJECTHOST= modmemcache
USE_APACHE= 2.2+
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (mod_memcache-0.1.0.tar.gz) = 9954ce906620d3367bd2fd123b1b94d5
SHA256 (mod_memcache-0.1.0.tar.gz) = 719aa73ea768889bf16d84450296486d3be9865fd35ecbf1d8e154f239408acd
SIZE (mod_memcache-0.1.0.tar.gz) = 291514

View File

@ -0,0 +1,11 @@
--- configure.orig 2009-01-06 11:53:39.000000000 +0800
+++ configure 2009-01-06 11:54:03.000000000 +0800
@@ -20143,7 +20143,7 @@
for x in $test_paths ; do
echo "$as_me:$LINENO: checking for apr_memcache library in ${x}" >&5
echo $ECHO_N "checking for apr_memcache library in ${x}... $ECHO_C" >&6
- if test -f ${x}/include/apr_memcache-0/apr_memcache.h; then
+ if test -f ${x}/include/apr-1/apr_memcache.h; then
echo "$as_me:$LINENO: result: yes" >&5
echo "${ECHO_T}yes" >&6
APR_MEMCACHE_LIBS="-R${x}/lib -L${x}/lib -lapr_memcache"

View File

@ -0,0 +1,5 @@
mod_memcache manages the parsing of memcached server configuration and
exports a single function for use by other modules to access a
configured apr_memcache object.
WWW: http://code.google.com/p/modmemcache/

View File

@ -0,0 +1,4 @@
@comment $FreeBSD$
%%APACHEMODDIR%%/mod_memcache.so
%%APACHEMODDIR%%/mod_memcache_example.so
@dirrmtry %%APACHEMODDIR%%