Update to 0.1.10.

This commit is contained in:
MANTANI Nobutaka 2005-10-08 14:09:03 +00:00
parent 196bc9aa21
commit d366fd7b79
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=144574
5 changed files with 12 additions and 48 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= libdvdnav
PORTVERSION= 0.1.9
PORTREVISION= 1
PORTVERSION= 0.1.10
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= dvd
@ -17,12 +16,11 @@ COMMENT= The library for the xine-dvdnav plugin
LIB_DEPENDS= dvdread.3:${PORTSDIR}/multimedia/libdvdread
GNU_CONFIGURE= yes
CONFIGURE_ENV= THREAD_CFLAGS="${PTHREAD_CFLAGS}" \
THREAD_LIBS="${PTHREAD_LIBS}"
CONFIGURE_ARGS= --program-transform-name=''
INSTALLS_SHLIB= yes
USE_INC_LIBTOOL_VER=13
USE_LIBTOOL_VER=15
USE_REINPLACE= yes
post-patch:
@ -30,11 +28,8 @@ post-patch:
's|THREAD_LIBS=.*$$|THREAD_LIBS="\$$THREAD_LIBS"|g ; \
s|THREAD_CFLAGS=.*$$|THREAD_CFLAGS="\$$THREAD_CFLAGS"|g ; \
s|-L/usr/local/lib|-L${LOCALBASE}/lib|g ; \
s|-I/usr/local/include|-I${LOCALBASE}/include|g ; \
s|aclocal-1.7|${TRUE}|g ; \
s|automake-1.7|${TRUE}|g ; \
s|autoconf|${TRUE}|g ; \
s|autoheader|${TRUE}|g' ${WRKSRC}/configure \
${WRKSRC}/missing ${WRKSRC}/aclocal.m4 ${WRKSRC}/autogen.sh
s|-I/usr/local/include|-I${LOCALBASE}/include|g' \
${WRKSRC}/configure ${WRKSRC}/missing \
${WRKSRC}/aclocal.m4 ${WRKSRC}/autogen.sh
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
MD5 (libdvdnav-0.1.9.tar.gz) = 5b0d168d87f66f8c8d7b2b51e16ff9d8
SIZE (libdvdnav-0.1.9.tar.gz) = 381749
MD5 (libdvdnav-0.1.10.tar.gz) = c8ddee96ba1182d73447eaf0bb6fde81
SIZE (libdvdnav-0.1.10.tar.gz) = 539803

View File

@ -1,32 +0,0 @@
--- ltmain.sh.orig Tue May 20 23:20:02 2003
+++ ltmain.sh Thu Feb 12 20:46:44 2004
@@ -973,6 +973,7 @@
;;
-avoid-version)
+ build_old_libs=no
avoid_version=yes
continue
;;
@@ -2501,7 +2502,7 @@
*)
# Add libc to deplibs on all other systems if necessary.
if test $build_libtool_need_lc = "yes"; then
- deplibs="$deplibs -lc"
+ deplibs="$deplibs"
fi
;;
esac
@@ -4325,10 +4326,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -1,5 +1,5 @@
--- src/vm.c.orig Fri Feb 20 00:49:57 2004
+++ src/vm.c Fri Feb 20 00:54:31 2004
--- src/vm/vm.c.orig Fri Feb 20 00:49:57 2004
+++ src/vm/vm.c Fri Feb 20 00:54:31 2004
@@ -47,6 +47,10 @@
#define lseek64 lseek
#endif /* _MSC_VER */

View File

@ -1,15 +1,16 @@
bin/dvdnav-config
include/dvdnav/dvd_reader.h
include/dvdnav/dvd_types.h
include/dvdnav/dvd_udf.h
include/dvdnav/dvdnav.h
include/dvdnav/dvdnav_events.h
include/dvdnav/ifo_print.h
include/dvdnav/ifo_read.h
include/dvdnav/ifo_types.h
include/dvdnav/nav_print.h
include/dvdnav/nav_read.h
include/dvdnav/nav_types.h
lib/libdvdnav.a
lib/libdvdnav.so
lib/libdvdnav.so.3
lib/libdvdnav.so.4
share/aclocal/dvdnav.m4
@dirrm include/dvdnav