- Update Gnuastro to version 0.10 (switch to the .tar.lz distfile)
- Stop patching `lib/gnuastro/table.h' for missing #include <time.h> which was not needed since version 0.9 (r501098); remove patches that were integrated upstream
This commit is contained in:
parent
38447593be
commit
d3668be3bf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=508090
@ -2,8 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gnuastro
|
||||
PORTVERSION= 0.9
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.10
|
||||
CATEGORIES= astro
|
||||
MASTER_SITES= GNU
|
||||
|
||||
@ -19,7 +18,7 @@ LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
|
||||
libpng.so:graphics/png \
|
||||
libtiff.so:graphics/tiff
|
||||
|
||||
USES= gmake jpeg libtool:build localbase
|
||||
USES= gmake jpeg libtool:build localbase tar:lz
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
TEST_TARGET= check
|
||||
@ -32,8 +31,6 @@ OPTIONS_DEFINE= DOCS
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's,gcc,${CC},' ${WRKSRC}/bin/buildprog/buildprog.c
|
||||
@${REINPLACE_CMD} -e 's,/bash,/sh,' ${WRKSRC}/doc/Makefile.in
|
||||
@${REINPLACE_CMD} -e '31s,^,#include <time.h>,' \
|
||||
${WRKSRC}/lib/gnuastro/table.h
|
||||
|
||||
post-install:
|
||||
@${FIND} ${STAGEDIR}${PREFIX}/etc -name \*.conf \
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1555520218
|
||||
SHA256 (gnuastro-0.9.tar.gz) = c98dba97f022960d1792ffdba1f3bd411fb2945cd577902f79c73296799b6818
|
||||
SIZE (gnuastro-0.9.tar.gz) = 5312132
|
||||
TIMESTAMP = 1564793993
|
||||
SHA256 (gnuastro-0.10.tar.lz) = 2ba06b23a61a1a142cb0d40f7509ac1992067276ae3448285662b5e601acb03e
|
||||
SIZE (gnuastro-0.10.tar.lz) = 3467563
|
||||
|
@ -1,53 +0,0 @@
|
||||
--- bin/script/sort-by-night.in.orig 2019-04-11 18:40:12 UTC
|
||||
+++ bin/script/sort-by-night.in
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/bash
|
||||
+#!/bin/sh
|
||||
|
||||
# Separate input datasets into multiple nights, run with `--help', or see
|
||||
# description under `print_help' (below) for more.
|
||||
@@ -127,7 +127,7 @@ EOF
|
||||
|
||||
|
||||
# Functions to check option values and complain if necessary.
|
||||
-function on_off_option_error() {
|
||||
+on_off_option_error() {
|
||||
if [ "x$2" = x ]; then
|
||||
echo "$scriptname: '$1' doesn't take any values."
|
||||
else
|
||||
@@ -136,7 +136,7 @@ function on_off_option_error() {
|
||||
exit 1
|
||||
}
|
||||
|
||||
-function check_v() {
|
||||
+check_v() {
|
||||
if [ x"$2" = x ]; then
|
||||
echo "$scriptname: option '$1' requires an argument."
|
||||
echo "Try '$scriptname --help' for more information."
|
||||
@@ -172,7 +172,7 @@ function check_v() {
|
||||
# if a value is appended to the short format it should crash. So in the
|
||||
# second test for these (`-l*') will account for both the case where we
|
||||
# have an equal sign and where we don't.
|
||||
-while [[ $# -gt 0 ]]
|
||||
+while [ $# -gt 0 ]
|
||||
do
|
||||
case "$1" in
|
||||
# Input parameters.
|
||||
@@ -242,8 +242,8 @@ fi
|
||||
list=$(for f in $inputs; do
|
||||
astfits $f --datetosec=$key --hdu=$hdu -q \
|
||||
| awk -vh=$hour \
|
||||
- '{d=int($1/86400); print "'$f'", $1, \
|
||||
- int($1)%86400<(h*3600) ? d-1 : d }'
|
||||
+ '{d=int($1/86400); print "'$f'", $1; \
|
||||
+ if (int($1)%86400<(h*3600)) print d-1; else print d }'
|
||||
done)
|
||||
|
||||
|
||||
@@ -302,5 +302,5 @@ echo "$unique" | while read l; do
|
||||
done
|
||||
|
||||
# Increment the night-counter.
|
||||
- ((counter++))
|
||||
+ counter=$((counter+1))
|
||||
done
|
@ -55,6 +55,7 @@ include/gnuastro/permutation.h
|
||||
include/gnuastro/pointer.h
|
||||
include/gnuastro/polygon.h
|
||||
include/gnuastro/qsort.h
|
||||
include/gnuastro/speclines.h
|
||||
include/gnuastro/statistics.h
|
||||
include/gnuastro/table.h
|
||||
include/gnuastro/threads.h
|
||||
@ -65,8 +66,8 @@ include/gnuastro/type.h
|
||||
include/gnuastro/wcs.h
|
||||
lib/libgnuastro.a
|
||||
lib/libgnuastro.so
|
||||
lib/libgnuastro.so.7
|
||||
lib/libgnuastro.so.7.0.0
|
||||
lib/libgnuastro.so.8
|
||||
lib/libgnuastro.so.8.0.0
|
||||
libdata/pkgconfig/gnuastro.pc
|
||||
man/man1/astarithmetic.1.gz
|
||||
man/man1/astbuildprog.1.gz
|
||||
|
Loading…
Reference in New Issue
Block a user