- Update to 2.6
- Use OPTIONS helpers - Convert pkg-plist to PLIST_FILES
This commit is contained in:
parent
a9e3d3d9cb
commit
d35d2175c6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=374944
10
UPDATING
10
UPDATING
@ -5,6 +5,16 @@ they are unavoidable.
|
||||
You should get into the habit of checking this file for changes each time
|
||||
you update your ports collection, before attempting any port upgrades.
|
||||
|
||||
20141219:
|
||||
AFFECTS: users of audio/abcde
|
||||
AUTHOR: gblach@FreeBSD.org
|
||||
|
||||
In audio/abcde dependency has been changed from audio/py-eyed3-06
|
||||
to audio/py-eyed3. Before updating audio/abcde to 2.6 you must manually
|
||||
deinstall audio/py-eyed-06.
|
||||
|
||||
# pkg delete -f pyXX-eyed3-06
|
||||
|
||||
20141218:
|
||||
AFFECTS: users of security/openssh-portable
|
||||
AUTHOR: bdrewery@FreeBSD.org
|
||||
|
@ -2,10 +2,9 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= abcde
|
||||
PORTVERSION= 2.5.4
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 2.6
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= GOOGLE_CODE
|
||||
MASTER_SITES= http://abcde.einval.com/download/
|
||||
|
||||
MAINTAINER= gblach@FreeBSD.org
|
||||
COMMENT= Front-end shell script to encode CDs in flac/mp3/ogg/speex format
|
||||
@ -14,66 +13,40 @@ LICENSE= GPLv2
|
||||
|
||||
RUN_DEPENDS= cd-discid:${PORTSDIR}/audio/cd-discid \
|
||||
cdparanoia:${PORTSDIR}/audio/cdparanoia \
|
||||
${PYTHON_PKGNAMEPREFIX}eyed3-06>0:${PORTSDIR}/audio/py-eyed3-06 \
|
||||
lame:${PORTSDIR}/audio/lame \
|
||||
oggenc:${PORTSDIR}/audio/vorbis-tools \
|
||||
lame:${PORTSDIR}/audio/lame \
|
||||
${PYTHON_PKGNAMEPREFIX}eyed3>=0.7:${PORTSDIR}/audio/py-eyed3 \
|
||||
bash:${PORTSDIR}/shells/bash
|
||||
|
||||
NO_BUILD= yes
|
||||
|
||||
OPTIONS_DEFINE= CDDA2WAV DAGRAB EJECT FLAC MPP NORMALIZE REPLAYGAIN SPEEX
|
||||
|
||||
EJECT_DESC?= Enable auto-eject support
|
||||
NORMALIZE_DESC?= Enable normalize support
|
||||
REPLAYGAIN_DESC?= Enable (vorbis|mp3)gain support
|
||||
|
||||
USES= python:run shebangfix
|
||||
SHEBANG_FILES= ${PORTNAME} cddb-tool
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
OPTIONS_GROUP= CODEC RIPPER
|
||||
OPTIONS_GROUP_CODEC= AAC FLAC MPP OPUS SPEEX
|
||||
OPTIONS_GROUP_RIPPER= CDDA2WAV DAGRAB
|
||||
OPTIONS_DEFINE= NORMALIZE REPLAYGAIN
|
||||
|
||||
.if ${PORT_OPTIONS:MCDDA2WAV}
|
||||
RUN_DEPENDS+= cdda2wav:${PORTSDIR}/sysutils/cdrtools
|
||||
.endif
|
||||
NORMALIZE_DESC?= Enable normalize support
|
||||
REPLAYGAIN_DESC?= Enable (vorbis|mp3)gain support
|
||||
|
||||
.if ${PORT_OPTIONS:MDAGRAB}
|
||||
RUN_DEPENDS+= dagrab:${PORTSDIR}/audio/dagrab
|
||||
.endif
|
||||
AAC_RUN_DEPENDS+= faac:${PORTSDIR}/audio/faac
|
||||
FLAC_RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
|
||||
MPP_RUN_DEPENDS+= mpcenc:${PORTSDIR}/audio/musepack
|
||||
OPUS_RUN_DEPENDS+= opusenc:${PORTSDIR}/audio/opus-tools
|
||||
SPEEX_RUN_DEPENDS+= speexenc:${PORTSDIR}/audio/speex
|
||||
CDDA2WAV_RUN_DEPENDS+= cdda2wav:${PORTSDIR}/sysutils/cdrtools
|
||||
DAGRAB_RUN_DEPENDS+= dagrab:${PORTSDIR}/audio/dagrab
|
||||
NORMALIZE_RUN_DEPENDS+= normalize:${PORTSDIR}/audio/normalize
|
||||
REPLAYGAIN_RUN_DEPENDS+=mp3gain:${PORTSDIR}/audio/mp3gain \
|
||||
vorbisgain:${PORTSDIR}/audio/vorbisgain
|
||||
|
||||
.if ${PORT_OPTIONS:MEJECT}
|
||||
RUN_DEPENDS+= eject:${PORTSDIR}/sysutils/eject
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MFLAC}
|
||||
RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MNORMALIZE}
|
||||
RUN_DEPENDS+= normalize:${PORTSDIR}/audio/normalize
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MSPEEX}
|
||||
RUN_DEPENDS+= speexenc:${PORTSDIR}/audio/speex
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MAAC}
|
||||
RUN_DEPENDS+= faac:${PORTSDIR}/audio/faac
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MMPP}
|
||||
RUN_DEPENDS+= mpcenc:${PORTSDIR}/audio/musepack
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MREPLAYGAIN}
|
||||
RUN_DEPENDS+= mp3gain:${PORTSDIR}/audio/mp3gain \
|
||||
vorbisgain:${PORTSDIR}/audio/vorbisgain
|
||||
.endif
|
||||
PLIST_FILES= bin/abcde bin/cddb-tool etc/abcde.conf.sample \
|
||||
man/man1/abcde.1.gz man/man1/cddb-tool.1.gz
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's#/etc/#${PREFIX}/etc/#g' \
|
||||
${WRKSRC}/abcde.1
|
||||
${REINPLACE_CMD} -e 's#/etc/#${PREFIX}/etc/#g' \
|
||||
${WRKSRC}/abcde
|
||||
${WRKSRC}/abcde ${WRKSRC}/abcde.1
|
||||
|
||||
do-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/abcde ${STAGEDIR}${PREFIX}/bin
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (abcde-2.5.4.tar.gz) = 85b679b970e728a986487adcbff7c51eb0e72f9fa10c4450521f8e029fa6e591
|
||||
SIZE (abcde-2.5.4.tar.gz) = 104229
|
||||
SHA256 (abcde-2.6.tar.gz) = 683ea7e215142784a28afcda4a18d9a2b8f7ef7bcd9c2881ee110a3b86784c78
|
||||
SIZE (abcde-2.6.tar.gz) = 105609
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- abcde.conf.orig 2012-04-19 22:57:19.000000000 +0200
|
||||
+++ abcde.conf 2013-02-22 21:53:52.000000000 +0100
|
||||
@@ -136,8 +136,8 @@
|
||||
--- abcde.conf.orig 2014-12-18 17:39:40.000000000 +0100
|
||||
+++ abcde.conf 2014-12-18 17:45:51.000000000 +0100
|
||||
@@ -141,13 +141,13 @@
|
||||
#CDDAFS=cp
|
||||
#CDDISCID=cd-discid
|
||||
#CDDBTOOL=cddb-tool
|
||||
@ -11,53 +11,41 @@
|
||||
#DISTMP3=distmp3
|
||||
#VORBISCOMMENT=vorbiscomment
|
||||
#METAFLAC=metaflac
|
||||
@@ -170,7 +170,8 @@
|
||||
|
||||
# Ogg:
|
||||
#VORBIZEOPTS=
|
||||
-#OGGENCOPTS=
|
||||
+#OFFENCOPTS=
|
||||
+OGGENCOPTS="-q 5"
|
||||
|
||||
# FLAC:
|
||||
#FLACOPTS="-f"
|
||||
@@ -193,7 +194,7 @@
|
||||
#CDDA2WAVOPTS=
|
||||
#NORMALIZE=normalize-audio
|
||||
-#CDSPEED=eject
|
||||
+CDSPEED=cdcontrol
|
||||
#VORBISGAIN=vorbisgain
|
||||
#MKCUE=mkcue
|
||||
#MKTOC=cdrdao
|
||||
@@ -215,10 +215,10 @@
|
||||
#PIRDOPTS="-p"
|
||||
#CDDAFSOPTS="-f"
|
||||
#CDDBTOOLOPTS=
|
||||
-#EJECTOPTS=
|
||||
+EJECTOPTS="eject"
|
||||
#DISTMP3OPTS=
|
||||
#NORMALIZEOPTS=
|
||||
#CDSPEEDOPTS="-x"
|
||||
@@ -238,7 +239,7 @@
|
||||
|
||||
# OUTPUTTYPE can be either "ogg", "mp3", "flac" or "spx", or a combination
|
||||
# of them separated with ",": "ogg,mp3".
|
||||
-#OUTPUTTYPE=ogg
|
||||
+OUTPUTTYPE=ogg
|
||||
|
||||
# Output filename format - change this to reflect your inner desire to
|
||||
# organize things differently than everyone else :)
|
||||
@@ -251,9 +252,11 @@
|
||||
# to the files. Remove it from your user defined string if you are getting
|
||||
# files like ".ogg.ogg".
|
||||
#OUTPUTFORMAT='${ARTISTFILE}-${ALBUMFILE}/${TRACKNUM}.${TRACKFILE}'
|
||||
+OUTPUTFORMAT='${ARTISTFILE}-${ALBUMFILE}/${ARTISTFILE}-${TRACKNUM}-${TRACKFILE}'
|
||||
|
||||
# Like OUTPUTFORMAT but for Various Artists discs.
|
||||
#VAOUTPUTFORMAT='Various-${ALBUMFILE}/${TRACKNUM}.${ARTISTFILE}-${TRACKFILE}'
|
||||
+VAOUTPUTFORMAT='${ARTISTFILE}/${ARTISTFILE}-${TRACKNUM}-${TRACKFILE}'
|
||||
|
||||
# Like OUTPUTFORMAT and VAOUTPUTFORMAT but for the ONEFILE rips.
|
||||
#ONETRACKOUTPUTFORMAT=$OUTPUTFORMAT
|
||||
@@ -319,8 +322,7 @@
|
||||
-#CDSPEEDOPTS="-x"
|
||||
+CDSPEEDOPTS="speed"
|
||||
#CDSPEEDVALUE=""
|
||||
#MKCUEOPTS=""
|
||||
#MKTOCOPTS=""
|
||||
@@ -245,7 +245,7 @@
|
||||
# CD device you want to read from
|
||||
# It can be defined as a singletrack flac file, but since it might change from
|
||||
# file to file it makes little sense to define it here.
|
||||
-#CDROM=/dev/cdrom
|
||||
+CDROM=/dev/cd0
|
||||
# If we are using the IDE bus, we need CDPARANOIACDROMBUS defined as "d"
|
||||
# If we are using the ide-scsi emulation layer, we need to define a "g"
|
||||
#CDPARANOIACDROMBUS="d"
|
||||
@@ -343,8 +343,7 @@
|
||||
# Custom pre-read function
|
||||
# By default it does nothing.
|
||||
# You can set some things to get abcde function in better ways:
|
||||
-# * Close the CD tray using eject -t (if available in eject and supported by
|
||||
-# your CD device.
|
||||
+# * Close the CD tray using cdcontrol close
|
||||
+# * Close the CD tray using cdcontrol close (if supported by your CD device).
|
||||
# * Set the CD speed. You can also use the built-in options, but you can also
|
||||
# set it here. In Debian, eject -x and cdset -x do the job.
|
||||
# KEEP IN MIND that executables included in pre_read must be in your $PATH or
|
||||
|
@ -7,4 +7,4 @@ MP3,... and will use one single rip to create as many output formats as you want
|
||||
|
||||
Many other useful features are supported.
|
||||
|
||||
WWW: http://code.google.com/p/abcde/
|
||||
WWW: http://abcde.einval.com/
|
||||
|
@ -1,5 +0,0 @@
|
||||
bin/abcde
|
||||
bin/cddb-tool
|
||||
etc/abcde.conf.sample
|
||||
man/man1/abcde.1.gz
|
||||
man/man1/cddb-tool.1.gz
|
Loading…
Reference in New Issue
Block a user