- Update to 3.10

This commit is contained in:
Diane Bruce 2009-01-18 00:56:45 +00:00
parent 0540456a45
commit d35746cefb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=226344
9 changed files with 82 additions and 14 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= fldigi
PORTVERSION= 3.03
PORTVERSION= 3.10
CATEGORIES= comms hamradio
MASTER_SITES= http://www.w1hkj.com/fldigi-distro/ \
${MASTER_SITE_LOCAL}
@ -27,7 +27,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64" && ${OSVERSION} < 700000
.if ${OSVERSION} < 700000
USE_GCC= 4.2+
.endif
.if ${ARCH} == "sparc64"
@ -36,6 +36,7 @@ BROKEN= Fails to install
post-configure:
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|' \
-e 's|^CPPFLAGS|#CPPFLAGS|' \
${WRKSRC}/src/Makefile
post-install:

View File

@ -1,3 +1,3 @@
MD5 (fldigi-3.03.tar.gz) = f4e87a30ba83b6ef2ed8bc183d45574e
SHA256 (fldigi-3.03.tar.gz) = 56a6bbd6ee1736014958776f97dc673b6b13e0f8eb9b4f6201a63e056b1bd7c8
SIZE (fldigi-3.03.tar.gz) = 711226
MD5 (fldigi-3.10.tar.gz) = eb8eb8ff6d750eadfaa8804998d733c2
SHA256 (fldigi-3.10.tar.gz) = 0f689105ae710912cfe4582cb51b6b96c2644d684d47464926e9b6681d73dcd5
SIZE (fldigi-3.10.tar.gz) = 935017

View File

@ -0,0 +1,20 @@
--- src/dialogs/fl_digi.cxx.orig 2009-01-17 09:32:22.000000000 -0500
+++ src/dialogs/fl_digi.cxx 2009-01-17 14:53:39.000000000 -0500
@@ -1288,7 +1288,7 @@
Fl::repeat_timeout(st, ztimer);
struct tm tm;
- gmtime_r(&tv.tv_sec, &tm);
+ gmtime_r((const time_t *)&tv.tv_sec, &tm);
if (!strftime(ztbuf, sizeof(ztbuf), "%Y%m%d %H%M", &tm))
memset(ztbuf, 0, sizeof(ztbuf));
else
@@ -2727,7 +2727,7 @@
#if defined (__CYGWIN__)
fl_digi_main->icon((char*)LoadIcon(fl_display, MAKEINTRESOURCE(IDI_ICON)));
-#elif defined (__linux__)
+#elif defined (__linux__) || defined (__FreeBSD__)
make_pixmap(&fldigi_icon_pixmap, fldigi_icon);
fl_digi_main->icon((char *)fldigi_icon_pixmap);
#endif

View File

@ -0,0 +1,11 @@
--- src/fileselector/fileselect.cxx.orig 2009-01-17 14:56:02.000000000 -0500
+++ src/fileselector/fileselect.cxx 2009-01-17 15:04:34.000000000 -0500
@@ -67,7 +67,7 @@
const char* FSEL::get_file(void)
{
// Calling directory() is apparently not enough on Linux
-#ifdef __linux__
+#if defined(__linux__) || defined(__FreeBSD__)
const char* preset = chooser->preset_file();
if (preset && *preset != '/' && chooser->directory()) {
filename = chooser->directory();

View File

@ -0,0 +1,13 @@
--- src/include/configuration.h.orig 2009-01-17 14:58:24.000000000 -0500
+++ src/include/configuration.h 2009-01-17 14:59:32.000000000 -0500
@@ -12,6 +12,10 @@
# define DEFAULT_PTTDEV "/dev/ttyS0"
# define DEFAULT_CWFSKPORT "/dev/ttyS1"
# define DEFAULT_HAMRIGDEVICE "/dev/ttyS0"
+#elif defined(__FreeBSD__)
+# define DEFAULT_PTTDEV "/dev/ttyd0"
+# define DEFAULT_CWFSKPORT "/dev/ttyd1"
+# define DEFAULT_HAMRIGDEVICE "/dev/ttyd0"
#elif defined(__CYGWIN__)
# define DEFAULT_PTTDEV "COM1"
# define DEFAULT_CWFSKPORT "COM2"

View File

@ -1,20 +1,20 @@
--- src/include/threads.h.orig 2008-09-14 09:26:15.000000000 -0400
+++ src/include/threads.h 2008-09-23 08:50:48.000000000 -0400
@@ -46,6 +46,7 @@
--- src/include/threads.h.orig 2009-01-05 14:01:07.000000000 -0500
+++ src/include/threads.h 2009-01-16 11:56:12.000000000 -0500
@@ -4,6 +4,7 @@
#include <config.h>
#include <pthread.h>
+#include <stdint.h>
typedef pthread_t Fl_Thread;
typedef pthread_mutex_t Fl_Mutex;
@@ -88,7 +89,8 @@
extern pthread_key_t thread_id_;
# define CREATE_THREAD_ID() pthread_key_create(&thread_id_, 0);
#include <semaphore.h>
#if !HAVE_SEM_TIMEDWAIT
@@ -32,7 +33,8 @@
# define THREAD_ID_TYPE pthread_key_t
# define CREATE_THREAD_ID() pthread_key_create(&thread_id_, 0)
# define SET_THREAD_ID(x) pthread_setspecific(thread_id_, (void *)(x))
-# define GET_THREAD_ID() (int)pthread_getspecific(thread_id_)
+//# define GET_THREAD_ID() (int)pthread_getspecific(thread_id_)
+# define GET_THREAD_ID() (uintptr_t)pthread_getspecific(thread_id_)
#endif // USE_TLS
#include "fl_lock.h"

View File

@ -0,0 +1,11 @@
--- src/main.cxx.orig 2009-01-17 14:54:56.000000000 -0500
+++ src/main.cxx 2009-01-17 14:55:05.000000000 -0500
@@ -723,7 +723,7 @@
void set_platform_ui(void)
{
-#if defined (__linux__)
+#if defined (__linux__) || defined(__FreeBSD__)
FL_NORMAL_SIZE = 12;
#elif defined(__APPLE__)
FL_NORMAL_SIZE = 12;

View File

@ -0,0 +1,11 @@
--- src/spot/pskrep.cxx.orig 2009-01-17 14:45:24.000000000 -0500
+++ src/spot/pskrep.cxx 2009-01-17 14:50:02.000000000 -0500
@@ -64,7 +64,7 @@
// It must define at least two capturing groups, the second of which is the
// spotted callsign.
#define CALLSIGN_RE "[[:alnum:]]?[[:alpha:]/]+[[:digit:]]+[[:alnum:]/]+"
-#ifdef __linux__
+#ifdef __linux__ || __FreeBSD__
# define PSKREP_RE "(de|cq|qrz)[^[:alnum:]/\n]+" "(" CALLSIGN_RE ")" " +(.* +)?\\2[^[:alnum:]]+$"
#else
# define PSKREP_RE "(de|cq|qrz)[^[:alnum:]/\n]+" "(" CALLSIGN_RE ")" " +(.* +)?" \

View File

@ -1,5 +1,6 @@
bin/fldigi
share/applications/fldigi.desktop
share/locale/fr/LC_MESSAGES/fldigi.mo
share/pixmaps/fldigi.xpm
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%@dirrm %%DOCSDIR%%