Use SYSTEM_OSS on the Alpha too. Also include errno.h so this build on

FreeBSD/Alpha.
This commit is contained in:
Steve Price 1999-09-20 02:24:29 +00:00
parent 519f9f2da8
commit d345f42834
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=21809
2 changed files with 18 additions and 4 deletions

View File

@ -1,5 +1,5 @@
--- /tmp/rosegarden-2.1/configure.in Wed Oct 15 20:42:59 1997
+++ ./configure.in Fri May 14 20:29:22 1999
--- configure.in.orig Wed Oct 15 13:42:59 1997
+++ configure.in Sat Sep 18 16:15:13 1999
@@ -4,6 +4,14 @@
AC_CONFIG_HEADER(config.h)
@ -38,12 +38,14 @@
if test -n "$TCL_MIDI_CHECK"
then
Petal=""
@@ -153,8 +161,8 @@
@@ -152,9 +160,9 @@
*freebsd*)
defines="-DNO_SYS_ERRLIST"
AC_CHECK_HEADER(sys/soundcard.h, sound_system="-DSYSTEM_FREEBSD")
- AC_CHECK_HEADER(sys/soundcard.h, sound_system="-DSYSTEM_FREEBSD")
- extra_libs="-lmalloc"
- # LDFLAGS="-L/usr/lib -L/usr/X11R6/lib"
+ AC_CHECK_HEADER(sys/soundcard.h, sound_system="-DSYSTEM_OSS")
+ # extra_libs="-lmalloc"
+ LDFLAGS="-L/usr/lib -L/usr/X11R6/lib"

View File

@ -0,0 +1,12 @@
--- mapper/src/Mapper_OSS.c.orig Sat Sep 18 16:18:42 1999
+++ mapper/src/Mapper_OSS.c Sat Sep 18 16:19:17 1999
@@ -13,6 +13,9 @@
#include <sys/stat.h>
#include <unistd.h>
#include <fcntl.h>
+#ifdef __FreeBSD__
+#include <errno.h>
+#endif
#include <MidiFile.h>
#include <MidiErrorHandler.h>