MFH: r553984
www/osrm-backend: Update to v5.23.0 ChangeLog: https://github.com/Project-OSRM/osrm-backend/releases/tag/v5.23.0 PR: 250620 Submitted by: freebsd@mosedal.net (maintainer) Approved by: ports-secteam (blanket, runtime fixes)
This commit is contained in:
parent
a128f798f4
commit
d3328d01cb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q4/; revision=553985
@ -2,21 +2,15 @@
|
||||
|
||||
PORTNAME= osrm-backend
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 5.22.0
|
||||
PORTREVISION= 9
|
||||
DISTVERSION= 5.23.0
|
||||
CATEGORIES= www
|
||||
|
||||
PATCH_SITES= https://github.com/Project-OSRM/osrm-backend/commit/
|
||||
PATCHFILES= 38700e207e076a391f30ef66ad90d03e7543006e.patch:-p1 \
|
||||
018a9bc80449d85c0e40fa5215377d8a03264c88.patch:-p1
|
||||
|
||||
MAINTAINER= freebsd@mosedal.net
|
||||
COMMENT= Open Source Routing Machine (Backend)
|
||||
|
||||
LICENSE= BSD2CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libstxxl.a:devel/stxxl
|
||||
LIB_DEPENDS= libboost_chrono.so:devel/boost-libs \
|
||||
libboost_date_time.so:devel/boost-libs \
|
||||
libboost_filesystem.so:devel/boost-libs \
|
||||
@ -33,15 +27,15 @@ LIB_DEPENDS= libboost_chrono.so:devel/boost-libs \
|
||||
USES= cmake compiler:c++14-lang lua:53
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= Project-OSRM
|
||||
OPTIONS_DEFINE= DEBUG
|
||||
|
||||
USE_RC_SUBR= osrm
|
||||
|
||||
CMAKE_ON= BUILD_STATIC_LIBS
|
||||
|
||||
USERS= osrm
|
||||
GROUPS= osrm
|
||||
|
||||
CMAKE_ON= BUILD_STATIC_LIBS
|
||||
|
||||
OPTIONS_DEFINE= DEBUG
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 1300084
|
||||
|
@ -1,6 +1,6 @@
|
||||
TIMESTAMP = 1597690747
|
||||
SHA256 (Project-OSRM-osrm-backend-v5.22.0_GH0.tar.gz) = df0987a04bcf65d74f9c4e18f34a01982bf3bb97aa47f9d86cfb8b35f17a6a55
|
||||
SIZE (Project-OSRM-osrm-backend-v5.22.0_GH0.tar.gz) = 6492998
|
||||
TIMESTAMP = 1603522319
|
||||
SHA256 (Project-OSRM-osrm-backend-v5.23.0_GH0.tar.gz) = 8527ce7d799123a9e9e99551936821cc0025baae6f2120dbf2fbc6332c709915
|
||||
SIZE (Project-OSRM-osrm-backend-v5.23.0_GH0.tar.gz) = 9155384
|
||||
SHA256 (38700e207e076a391f30ef66ad90d03e7543006e.patch) = 2c353e7e942df92091cf138f9c47135a74dc6f70bcad6897b118b312ca226ad6
|
||||
SIZE (38700e207e076a391f30ef66ad90d03e7543006e.patch) = 2165
|
||||
SHA256 (018a9bc80449d85c0e40fa5215377d8a03264c88.patch) = 7ad04466e0ac4a5dcafc5bb38a1ac20039339c73f0e32475c25d4614b353ec61
|
||||
|
11
www/osrm-backend/files/patch-src_util_timezones.cpp
Normal file
11
www/osrm-backend/files/patch-src_util_timezones.cpp
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/util/timezones.cpp.orig 2020-11-03 05:31:40 UTC
|
||||
+++ src/util/timezones.cpp
|
||||
@@ -154,7 +154,7 @@ boost::optional<struct tm> Timezoner::op
|
||||
{
|
||||
std::vector<rtree_t::value_type> result;
|
||||
rtree.query(boost::geometry::index::intersects(point), std::back_inserter(result));
|
||||
- for (const auto v : result)
|
||||
+ for (const auto& v : result)
|
||||
{
|
||||
const auto index = v.second;
|
||||
if (boost::geometry::within(point, local_times[index].first))
|
@ -5,6 +5,20 @@ bin/osrm-datastore
|
||||
bin/osrm-extract
|
||||
bin/osrm-partition
|
||||
bin/osrm-routed
|
||||
include/flatbuffers/base.h
|
||||
include/flatbuffers/code_generators.h
|
||||
include/flatbuffers/flatbuffers.h
|
||||
include/flatbuffers/flatc.h
|
||||
include/flatbuffers/flexbuffers.h
|
||||
include/flatbuffers/grpc.h
|
||||
include/flatbuffers/hash.h
|
||||
include/flatbuffers/idl.h
|
||||
include/flatbuffers/minireflect.h
|
||||
include/flatbuffers/reflection.h
|
||||
include/flatbuffers/reflection_generated.h
|
||||
include/flatbuffers/registry.h
|
||||
include/flatbuffers/stl_emulation.h
|
||||
include/flatbuffers/util.h
|
||||
include/mapbox/optional.hpp
|
||||
include/mapbox/recursive_wrapper.hpp
|
||||
include/mapbox/variant.hpp
|
||||
@ -20,6 +34,7 @@ include/osrm/coordinate.hpp
|
||||
include/osrm/customizer.hpp
|
||||
include/osrm/customizer_config.hpp
|
||||
include/osrm/engine/api/base_parameters.hpp
|
||||
include/osrm/engine/api/base_result.hpp
|
||||
include/osrm/engine/api/match_parameters.hpp
|
||||
include/osrm/engine/api/nearest_parameters.hpp
|
||||
include/osrm/engine/api/route_parameters.hpp
|
||||
@ -69,6 +84,7 @@ include/osrm/util/typedefs.hpp
|
||||
%%LUA_LIBDIR%%/%%LUA_LIBDIR%%osrm_contract.a
|
||||
%%LUA_LIBDIR%%/%%LUA_LIBDIR%%osrm_customize.a
|
||||
%%LUA_LIBDIR%%/%%LUA_LIBDIR%%osrm_extract.a
|
||||
%%LUA_LIBDIR%%/%%LUA_LIBDIR%%osrm_guidance.a
|
||||
%%LUA_LIBDIR%%/%%LUA_LIBDIR%%osrm_partition.a
|
||||
%%LUA_LIBDIR%%/%%LUA_LIBDIR%%osrm_store.a
|
||||
%%LUA_LIBDIR%%/%%LUA_LIBDIR%%osrm_update.a
|
||||
|
Loading…
Reference in New Issue
Block a user