math/yices: Update 2.6.2 -> 2.6.4
Reported by: portscout
This commit is contained in:
parent
768d017078
commit
d300ca06c3
@ -1,5 +1,5 @@
|
||||
PORTNAME= yices
|
||||
DISTVERSION= 2.6.2
|
||||
DISTVERSION= 2.6.4
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= https://yices.csl.sri.com/releases/${DISTVERSION}/
|
||||
DISTNAME= ${PORTNAME}-${DISTVERSION}-src
|
||||
@ -8,24 +8,23 @@ MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= SMT solver
|
||||
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
||||
|
||||
BUILD_DEPENDS= gperf:devel/gperf
|
||||
LIB_DEPENDS= libgmp.so:math/gmp
|
||||
|
||||
USES= compiler:c11 gmake localbase
|
||||
USES= autoreconf compiler:c11 gmake localbase
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-pic-gmp=${LOCALBASE}/lib/libgmp.so
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
MAKE_ARGS= YICES_MAKE_INCLUDE=configs/make.include.${CONFIGURE_TARGET}
|
||||
CFLAGS+= -fPIC
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
|
||||
WRKSRC= ${WRKDIR}/yices2-Yices-${DISTVERSION}
|
||||
|
||||
post-install:
|
||||
post-install: # strip binaries
|
||||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
|
||||
@${RM} ${STAGEDIR}${PREFIX}/lib/*.a
|
||||
@cd ${STAGEDIR}${PREFIX}/lib && ${LN} -s libyices.so.2.6 libyices.so && ${LN} -s libyices.so.2.6 libyices.so.2
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1586295390
|
||||
SHA256 (yices-2.6.2-src.tar.gz) = 1f205c056dd430f830c688fba6c87d8bd07bd8fa05f65936e12c27e71fa3576a
|
||||
SIZE (yices-2.6.2-src.tar.gz) = 6014634
|
||||
TIMESTAMP = 1643217873
|
||||
SHA256 (yices-2.6.4-src.tar.gz) = 533a24e020ecb7d64c03a965d598430d193651e2887e6f46924dec5786db78cb
|
||||
SIZE (yices-2.6.4-src.tar.gz) = 10186909
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- Makefile.build.orig 2018-06-29 04:11:11 UTC
|
||||
--- Makefile.build.orig 2021-10-20 22:20:35 UTC
|
||||
+++ Makefile.build
|
||||
@@ -131,7 +131,7 @@ static_objsubdirs := $(srcsubdirs:%=$(st
|
||||
@@ -137,7 +137,7 @@ static_dll_objsubdirs := $(srcsubdirs:%=$(static_dll_o
|
||||
# build_dir/dist: binaries + libraries with distribution not linked with GMP
|
||||
# build_dir/static_dist: includes GMP (statically linked)
|
||||
#
|
||||
@ -9,7 +9,7 @@
|
||||
static_dist_dir = $(build_dir)/static_dist
|
||||
|
||||
|
||||
@@ -448,7 +448,7 @@ install-default:
|
||||
@@ -481,7 +481,7 @@ install-default:
|
||||
$(MKDIR_P) $(DESTDIR)$(bindir)
|
||||
$(MKDIR_P) $(DESTDIR)$(libdir)
|
||||
$(MKDIR_P) $(DESTDIR)$(includedir)
|
||||
@ -18,11 +18,3 @@
|
||||
$(INSTALL) $(dist_dir)/bin/* $(DESTDIR)$(bindir)
|
||||
$(INSTALL) $(dist_dir)/lib/* $(DESTDIR)$(libdir)
|
||||
|
||||
@@ -467,7 +467,6 @@ install-linux install-unix: install-defa
|
||||
# be added to the hints file.' In other words, ldconfig on FreeBSD doesn't create the symbolic link,
|
||||
# as on Linux.
|
||||
install-freebsd: install-default
|
||||
- $(LDCONFIG) -m $(DESTDIR)$(libdir) && (cd $(DESTDIR)$(libdir) && $(LN_S) -f libyices.so.$(MAJOR).$(MINOR) libyices.so)
|
||||
|
||||
#
|
||||
# cygwin and mingw install: copy the DLLs in $(bindir)
|
||||
|
@ -9,6 +9,6 @@ include/yices.h
|
||||
include/yices_exit_codes.h
|
||||
include/yices_limits.h
|
||||
include/yices_types.h
|
||||
lib/libyices.a
|
||||
lib/libyices.so
|
||||
lib/libyices.so.2
|
||||
lib/libyices.so.2.6
|
||||
|
Loading…
Reference in New Issue
Block a user