rezerwar is a puzzle game that could be quickly described as the

illegitimate child of a known tetromino game and the average pipe
game. The goal of this game is basically to create networks of water
to make them disappear, a couple tricks and techniques will help
you achieve this goal faster.

WWW: http://tamentis.com/projects/rezerwar/
This commit is contained in:
Dmitry Marakasov 2009-07-17 23:08:44 +00:00
parent e4e77645b5
commit d2ecaaf2ee
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=238009
8 changed files with 144 additions and 1 deletions

View File

@ -729,9 +729,10 @@
SUBDIR += r1q2
SUBDIR += race
SUBDIR += reminiscence
SUBDIR += rezerwar
SUBDIR += rfksay
SUBDIR += rigsofrods
SUBDIR += ri-li
SUBDIR += rigsofrods
SUBDIR += robocode
SUBDIR += robotfindskitten
SUBDIR += rockdodger

48
games/rezerwar/Makefile Normal file
View File

@ -0,0 +1,48 @@
# New ports collection makefile for: rezerwar
# Date created: 09 Jul 2009
# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= rezerwar
PORTVERSION= 0.2
CATEGORIES= games
MASTER_SITES= http://tamentis.com/projects/rezerwar/files/ \
http://mirror.amdmi3.ru/distfiles/
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Puzzle game involving organizing blocks with pipes
USE_GMAKE= yes
USE_SDL= sdl mixer
HAS_CONFIGURE= yes
CONFIGURE_ARGS= Unix
MAKE_JOBS_SAFE= yes
PORTDOCS= README
post-patch:
@${REINPLACE_CMD} -e 's|make|$${MAKE}|' ${WRKSRC}/mkfiles/Makefile.unix \
${WRKSRC}/data/Makefile ${WRKSRC}/data/gfx/Makefile
@${REINPLACE_CMD} -e 's|/usr/share/games/rezerwar/data|${DATADIR}|' \
${WRKSRC}/mkfiles/config_h_unix
@${REINPLACE_CMD} -e 's|hiscore.dat|.rezerwar.hiscore|' \
${WRKSRC}/src/hiscore.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/rezerwar ${PREFIX}/bin/
${MKDIR} ${DATADIR}/gfx
cd ${WRKSRC}/data/gfx && ${COPYTREE_SHARE} . ${DATADIR}/gfx "-name *\.bmp"
${MKDIR} ${DATADIR}/sfx
${INSTALL_DATA} ${WRKSRC}/data/sfx/*.wav ${DATADIR}/sfx/
${MKDIR} ${DATADIR}/music
${INSTALL_DATA} ${WRKSRC}/data/music/*.mp3 ${DATADIR}/music/
${MKDIR} ${DATADIR}/levels
${INSTALL_DATA} ${WRKSRC}/data/levels/*.lvl ${DATADIR}/levels/
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/README ${DOCSDIR}
.endif
.include <bsd.port.mk>

3
games/rezerwar/distinfo Normal file
View File

@ -0,0 +1,3 @@
MD5 (rezerwar-0.2.tar.gz) = 434ee07a27625a0ee57e0ac7289c3101
SHA256 (rezerwar-0.2.tar.gz) = b5e89937bc07aa5456369789afc14fd9be2532040f7934e36673444fd3aeef33
SIZE (rezerwar-0.2.tar.gz) = 7606388

View File

@ -0,0 +1,15 @@
--- mkfiles/Makefile.unix.orig 2009-07-10 06:58:20.000000000 +0400
+++ mkfiles/Makefile.unix 2009-07-17 21:45:32.000000000 +0400
@@ -10,10 +10,10 @@
all: data_build build
build:
- make -C src
+ ${MAKE} -C src
data_build:
- make -C data/
+ ${MAKE} -C data/
clean:
make -C data/ clean

View File

@ -0,0 +1,17 @@
--- mkfiles/MkConf.unix.orig 2009-07-10 06:58:20.000000000 +0400
+++ mkfiles/MkConf.unix 2009-07-17 21:43:04.000000000 +0400
@@ -4,11 +4,11 @@
# Copyright (c) 2009 Bertrand Janin
#
-CC=gcc
+CC?=gcc
# Standard
-CFLAGS=`sdl-config --cflags` -Wall -O2
-LIBS=`sdl-config --libs` -lSDL_mixer
+CFLAGS+=`${SDL_CONFIG} --cflags` -Wall
+LIBS+=`${SDL_CONFIG} --libs` -lSDL_mixer
# Debug (no optimization)
# CFLAGS=`sdl-config --cflags` -Wall -ggdb

View File

@ -0,0 +1,22 @@
--- src/main.c.orig 2009-07-10 06:58:20.000000000 +0400
+++ src/main.c 2009-07-18 03:03:19.000000000 +0400
@@ -26,6 +26,9 @@
*/
+#include <unistd.h>
+#include <err.h>
+#include <sys/stat.h>
#include <stdio.h>
#include <time.h>
#ifdef __WII__
@@ -203,6 +206,9 @@
int
main(int ac, char **av)
{
+ if (chdir(getenv("HOME")) != 0)
+ err(1, "cannot cd to $HOME");
+
int status = MTYPE_SUBMENU;
bool loop = true;
char *path;

7
games/rezerwar/pkg-descr Normal file
View File

@ -0,0 +1,7 @@
rezerwar is a puzzle game that could be quickly described as the
illegitimate child of a known tetromino game and the average pipe
game. The goal of this game is basically to create networks of water
to make them disappear, a couple tricks and techniques will help
you achieve this goal faster.
WWW: http://tamentis.com/projects/rezerwar/

30
games/rezerwar/pkg-plist Normal file
View File

@ -0,0 +1,30 @@
bin/rezerwar
%%DATADIR%%/gfx/a_chimneys/chimneys_01.bmp
%%DATADIR%%/gfx/a_sky/sky.bmp
%%DATADIR%%/gfx/gameback.bmp
%%DATADIR%%/gfx/gamemenu.bmp
%%DATADIR%%/gfx/splash/tdc.bmp
%%DATADIR%%/gfx/sprites.bmp
%%DATADIR%%/levels/tuto_01.lvl
%%DATADIR%%/levels/tuto_02.lvl
%%DATADIR%%/levels/tuto_03.lvl
%%DATADIR%%/levels/tuto_04.lvl
%%DATADIR%%/levels/tuto_05.lvl
%%DATADIR%%/levels/tuto_06.lvl
%%DATADIR%%/music/level1.mp3
%%DATADIR%%/music/menu.mp3
%%DATADIR%%/sfx/boom.ogg.wav
%%DATADIR%%/sfx/horn.ogg.wav
%%DATADIR%%/sfx/lazer.ogg.wav
%%DATADIR%%/sfx/menunav.ogg.wav
%%DATADIR%%/sfx/menuselect.ogg.wav
%%DATADIR%%/sfx/tack1.ogg.wav
%%DATADIR%%/sfx/tick1.ogg.wav
@dirrm %%DATADIR%%/sfx
@dirrm %%DATADIR%%/music
@dirrm %%DATADIR%%/levels
@dirrm %%DATADIR%%/gfx/splash
@dirrm %%DATADIR%%/gfx/a_sky
@dirrm %%DATADIR%%/gfx/a_chimneys
@dirrm %%DATADIR%%/gfx
@dirrm %%DATADIR%%