- Fix build on 5-x !386 systems

PR:		ports/64225
Submitted by:	Hendrik Scholz <hendrik@scholz.net>
This commit is contained in:
Kirill Ponomarev 2004-03-13 23:22:59 +00:00
parent c6f4893b02
commit d2e3a1c9e0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=103910
3 changed files with 56 additions and 2 deletions

View File

@ -34,8 +34,8 @@ MAKE_ENV= PREFIX=${LOCALBASE} USE_GTK=0
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386" || ${OSVERSION} < 500000
BROKEN= "Does not compile on !i386 or 4.x"
.if ${OSVERSION} < 500000
BROKEN= "Does not compile on 4.x"
.endif
pre-everything::

View File

@ -0,0 +1,12 @@
--- src/gpscontrol.c.orig Sat Nov 15 22:44:45 2003
+++ src/gpscontrol.c Sun Mar 14 00:15:19 2004
@@ -37,6 +37,9 @@
#include <unistd.h>
#include <fcntl.h>
#include <termios.h>
+#ifdef __FreeBSD__
+#include <string.h>
+#endif
#include <strings.h>
#include "gpscontrol.h"

View File

@ -0,0 +1,42 @@
--- src/speaker.c.orig Mon Nov 17 21:47:38 2003
+++ src/speaker.c Sun Mar 14 00:15:30 2004
@@ -31,16 +31,29 @@
* $Id: stumbler.c,v 1.5 2003/11/14 15:54:29 pancake Exp $
*/
+#ifdef __FreeBSD__
+#ifdef __i386__
+#define _HAVE_SPEAKER
+#endif
+#elif __NetBSD__
+#define _HAVE_SPEAKER
+#endif
+
+
#include <stdio.h>
#include <string.h>
#include <unistd.h>
#include <stdlib.h>
#ifdef __FreeBSD__
+#ifdef _HAVE_SPEAKER
#include <machine/speaker.h>
+#endif
#else
#include <machine/spkr.h>
#endif
+#ifdef _HAVE_SPEAKER
+
#define SPKR_DEV "/dev/speaker"
#define SPKR_SPD "L08"
@@ -100,4 +113,8 @@
//}
fclose(fd);
}
-
+#else
+ /* no speaker support */
+void swap_beep(void) {}
+void do_beep(int pc) {}
+#endif