Upgrade from 2.0.4 to 2.0.5.

Sort pkg-plist.
This commit is contained in:
Sergey A. Osokin 2017-05-03 21:37:40 +00:00
parent 364afa529d
commit d2d15a57a8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=440048
6 changed files with 26 additions and 42 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= luajit
DISTVERSION= 2.0.4
PORTREVISION= 1
DISTVERSION= 2.0.5
CATEGORIES= lang
MASTER_SITES= http://luajit.org/download/
DISTNAME= LuaJIT-${DISTVERSION}

View File

@ -1,2 +1,3 @@
SHA256 (LuaJIT-2.0.4.tar.gz) = 620fa4eb12375021bef6e4f237cbd2dd5d49e56beb414bee052c746beef1807d
SIZE (LuaJIT-2.0.4.tar.gz) = 847615
TIMESTAMP = 1493823315
SHA256 (LuaJIT-2.0.5.tar.gz) = 874b1f8297c697821f561f9b73b57ffd419ed8f4278c82e05b48806d30c1e979
SIZE (LuaJIT-2.0.5.tar.gz) = 849845

View File

@ -1,5 +1,5 @@
--- Makefile.orig 2014-03-12 16:10:00.000000000 +0400
+++ Makefile 2014-08-16 18:57:38.000000000 +0400
--- Makefile.orig 2017-05-01 14:11:00.000000000 -0400
+++ Makefile 2017-05-03 11:14:26.850889000 -0400
@@ -24,7 +24,7 @@
# Change the installation path as needed. This automatically adjusts
# the paths in src/luaconf.h, too. Note: PREFIX must be an absolute path!
@ -17,7 +17,7 @@
INSTALL_LJLIBD= $(INSTALL_SHARE)/luajit-$(VERSION)
INSTALL_JITLIB= $(INSTALL_LJLIBD)/jit
@@ -40,14 +41,14 @@
@@ -40,8 +41,7 @@
INSTALL_LMOD= $(INSTALL_LMODD)/$(ABIVER)
INSTALL_CMODD= $(INSTALL_LIB)/lua
INSTALL_CMOD= $(INSTALL_CMODD)/$(ABIVER)
@ -27,20 +27,7 @@
INSTALL_TNAME= luajit-$(VERSION)
INSTALL_TSYMNAME= luajit
INSTALL_ANAME= libluajit-$(ABIVER).a
INSTALL_SONAME= libluajit-$(ABIVER).so.$(MAJVER).$(MINVER).$(RELVER)
-INSTALL_SOSHORT= libluajit-$(ABIVER).so
+INSTALL_SOSHORT= libluajit-$(ABIVER).so.$(MAJVER)
+INSTALL_SOSHORT2= libluajit-$(ABIVER).so
INSTALL_DYLIBNAME= libluajit-$(ABIVER).$(MAJVER).$(MINVER).$(RELVER).dylib
INSTALL_DYLIBSHORT1= libluajit-$(ABIVER).dylib
INSTALL_DYLIBSHORT2= libluajit-$(ABIVER).$(MAJVER).dylib
@@ -57,12 +58,13 @@
INSTALL_DYN= $(INSTALL_LIB)/$(INSTALL_SONAME)
INSTALL_SHORT1= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
+INSTALL_SHORT3= $(INSTALL_LIB)/$(INSTALL_SOSHORT2)
INSTALL_T= $(INSTALL_BIN)/$(INSTALL_TNAME)
@@ -62,8 +62,8 @@
INSTALL_TSYM= $(INSTALL_BIN)/$(INSTALL_TSYMNAME)
INSTALL_PC= $(INSTALL_PKGCONFIG)/$(INSTALL_PCNAME)
@ -51,20 +38,18 @@
UNINSTALL_DIRS= $(INSTALL_JITLIB) $(INSTALL_LJLIBD) $(INSTALL_INC) \
$(INSTALL_LMOD) $(INSTALL_LMODD) $(INSTALL_CMOD) $(INSTALL_CMODD)
@@ -112,10 +114,9 @@
@@ -118,10 +118,8 @@
$(RM) $(INSTALL_TSYM) $(INSTALL_DYN) $(INSTALL_SHORT1) $(INSTALL_SHORT2)
cd src && test -f $(FILE_SO) && \
$(INSTALL_X) $(FILE_SO) $(INSTALL_DYN) && \
- $(LDCONFIG) $(INSTALL_LIB) && \
$(SYMLINK) $(INSTALL_SONAME) $(INSTALL_SHORT1) && \
- $(SYMLINK) $(INSTALL_SONAME) $(INSTALL_SHORT2) || :
$(SYMLINK) $(INSTALL_SONAME) $(INSTALL_SHORT2) || :
- cd etc && $(INSTALL_F) $(FILE_MAN) $(INSTALL_MAN)
+ $(SYMLINK) $(INSTALL_SONAME) $(INSTALL_SHORT2) && \
+ $(SYMLINK) $(INSTALL_SONAME) $(INSTALL_SHORT3) || :
cd etc && $(SED_PC) $(FILE_PC) > $(FILE_PC).tmp && \
$(INSTALL_F) $(FILE_PC).tmp $(INSTALL_PC) && \
$(RM) $(FILE_PC).tmp
@@ -133,7 +134,6 @@
@@ -139,7 +137,6 @@
for file in $(FILES_INC); do \
$(UNINSTALL) $(INSTALL_INC)/$$file; \
done

View File

@ -1,5 +1,5 @@
--- etc/luajit.pc.orig 2015-05-02 20:12:57.483801000 +0300
+++ etc/luajit.pc 2015-05-02 20:13:06.917300000 +0300
--- etc/luajit.pc.orig 2017-05-03 11:00:21.130353000 -0400
+++ etc/luajit.pc 2017-05-03 11:00:54.763566000 -0400
@@ -21,5 +21,5 @@
Version: ${version}
Requires:

View File

@ -1,15 +1,15 @@
--- src/Makefile.orig 2012-10-16 22:30:00.000000000 +0400
+++ src/Makefile 2012-10-18 22:06:48.000000000 +0400
@@ -25,7 +25,7 @@
--- src/Makefile.orig 2017-05-03 11:08:48.482664000 -0400
+++ src/Makefile 2017-05-03 11:09:44.473112000 -0400
@@ -24,7 +24,7 @@
# removing the '#' in front of them. Make sure you force a full recompile
# with "make clean", followed by "make" if you change any options.
#
# LuaJIT builds as a native 32 or 64 bit binary by default.
-CC= gcc
+#CC= gcc
-DEFAULT_CC = gcc
+DEFAULT_CC = cc
#
# Use this if you want to force a 32 bit build on a 64 bit multilib OS.
#CC= gcc -m32
@@ -34,7 +34,7 @@
# LuaJIT builds as a native 32 or 64 bit binary by default.
CC= $(DEFAULT_CC)
@@ -36,7 +36,7 @@
# to slow down the C part by not omitting it. Debugging, tracebacks and
# unwinding are not affected -- the assembler part has frame unwind
# information and GCC emits it where needed (x64) or with -g (see CCDEBUG).
@ -18,13 +18,12 @@
# Use this if you want to generate a smaller binary (but it's slower):
#CCOPT= -Os -fomit-frame-pointer
# Note: it's no longer recommended to use -O3 with GCC 4.x.
@@ -48,7 +48,8 @@
@@ -50,7 +50,7 @@
# x86/x64 only: For GCC 4.2 or higher and if you don't intend to distribute
# the binaries to a different machine you could also use: -march=native
#
-CCOPT_x86= -march=i686
+#CCOPT_x86= -march=i686
+CCOPT_x86=
CCOPT_x64=
CCOPT_arm=
CCOPT_ppc=

View File

@ -1,11 +1,11 @@
bin/luajit
bin/luajit-%%VERSION%%
include/luajit-2.0/lauxlib.h
include/luajit-2.0/lua.h
include/luajit-2.0/lua.hpp
include/luajit-2.0/luaconf.h
include/luajit-2.0/luajit.h
include/luajit-2.0/lualib.h
include/luajit-2.0/lauxlib.h
include/luajit-2.0/lua.hpp
lib/libluajit-5.1.a
lib/libluajit-5.1.so
lib/libluajit-5.1.so.2
@ -16,9 +16,9 @@ share/luajit-%%VERSION%%/jit/bcsave.lua
share/luajit-%%VERSION%%/jit/dis_arm.lua
share/luajit-%%VERSION%%/jit/dis_mips.lua
share/luajit-%%VERSION%%/jit/dis_mipsel.lua
share/luajit-%%VERSION%%/jit/dis_ppc.lua
share/luajit-%%VERSION%%/jit/dis_x64.lua
share/luajit-%%VERSION%%/jit/dis_x86.lua
share/luajit-%%VERSION%%/jit/dis_ppc.lua
share/luajit-%%VERSION%%/jit/dump.lua
share/luajit-%%VERSION%%/jit/v.lua
share/luajit-%%VERSION%%/jit/vmdef.lua