BackupPC::XS implements various BackupPC functions in a perl-callable module.

This module is required for BackupPC V4+.

WWW: http://backuppc.sourceforge.net

PR:		ports/182403
Submitted by:	Alexander Moisseev <moiseev@mezonplus.ru>
This commit is contained in:
Philippe Audeoud 2013-11-18 14:08:08 +00:00
parent dc20ad9d05
commit d2afd50c6a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=334197
6 changed files with 67 additions and 0 deletions

View File

@ -576,6 +576,7 @@
SUBDIR += p5-BSD-Jail-Object
SUBDIR += p5-BSD-Process
SUBDIR += p5-BSD-Sysctl
SUBDIR += p5-BackupPC-XS
SUBDIR += p5-Brackup
SUBDIR += p5-Dir-Purge
SUBDIR += p5-File-DirCompare

View File

@ -0,0 +1,21 @@
# Created by: Alexander Moisseev <moiseev@mezonplus.ru>
# $FreeBSD$
PORTNAME= BackupPC-XS
PORTVERSION= 0.20
CATEGORIES= sysutils perl5
MASTER_SITES= SF
MASTER_SITE_SUBDIR= backuppc/backuppc-beta/4.0.0alpha2
PKGNAMEPREFIX= p5-
MAINTAINER= moiseev@mezonplus.ru
COMMENT= Perl extension for BackupPC libraries
LICENSE= GPLv3
USES= perl5
USE_PERL5= configure
MAKE_JOBS_UNSAFE=yes
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
SHA256 (BackupPC-XS-0.20.tar.gz) = b80745bac2a0d8c3d8e4c0be72d68e2d4450926f065d8b9af62cbee555d83f87
SIZE (BackupPC-XS-0.20.tar.gz) = 281081

View File

@ -0,0 +1,31 @@
--- Makefile.PL.orig 2013-05-26 11:32:01.000000000 +0400
+++ Makefile.PL 2013-09-26 09:38:14.000000000 +0400
@@ -14,10 +14,6 @@
bpc_refCount$(OBJ_EXT)
];
$object =~ s/[\n\r\s]+/ /g;
-my $ldfrom = $object;
-$ldfrom =~ s{(\w+)/}{}g;
-$ldfrom .= ' zlib/libzlib$(LIB_EXT)';
-$ldfrom .= ' md5/libmd5$(LIB_EXT)';
WriteMakefile(
NAME => 'BackupPC::XS',
@@ -28,7 +24,7 @@
DEFINE => '', # e.g., '-DHAVE_SOMETHING'
INC => '-I.', # e.g., '-I. -I/usr/include/other'
OBJECT => $object,
- LDFROM => $ldfrom,
+ MYEXTLIB => 'zlib/libzlib$(LIB_EXT) md5/libmd5$(LIB_EXT)',
DIR => ['md5', 'zlib'],
depend => { 'BackupPC_XS.o' => 'config.h' },
clean => { FILES => "config.log config.status config.h" },
@@ -38,7 +34,7 @@
return <<'EOF';
zlib/libzlib$(LIB_EXT): zlib/Makefile config.h
- cd md5 && $(MAKE) $(PASSTHRU)
+ cd zlib && $(MAKE) $(PASSTHRU)
md5/libmd5$(LIB_EXT): md5/Makefile config.h
cd md5 && $(MAKE) $(PASSTHRU)

View File

@ -0,0 +1,4 @@
BackupPC::XS implements various BackupPC functions in a perl-callable module.
This module is required for BackupPC V4+.
WWW: http://backuppc.sourceforge.net

View File

@ -0,0 +1,8 @@
%%PERL5_MAN3%%/BackupPC::XS.3.gz
%%SITE_PERL%%/mach/BackupPC/XS.pm
%%SITE_PERL%%/mach/auto/BackupPC/XS/.packlist
%%SITE_PERL%%/mach/auto/BackupPC/XS/XS.bs
%%SITE_PERL%%/mach/auto/BackupPC/XS/XS.so
@dirrm %%SITE_PERL%%/mach/auto/BackupPC/XS
@dirrm %%SITE_PERL%%/mach/auto/BackupPC
@dirrmtry %%SITE_PERL%%/mach/BackupPC