chinese/cdrtools and chinese/mkisofs are superseded by sysutils/cdrtools-cjk.
Note: Contrary to its purpose, chinese/cdrtools also never (during the time it was connected to the build) installed the ISO-9660 tools. Diagnosis by: marius Let's remove them by: netchild
This commit is contained in:
parent
81d5c2f5f1
commit
d25f6d7e83
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=111011
2
MOVED
2
MOVED
@ -1137,3 +1137,5 @@ sysutils/mkisofs-devel|sysutils/cdrtools-devel|2004-06-02|merged
|
||||
lang/squeak3|lang/squeak|2004-06-03|New stable version
|
||||
net-mgmt/dhcpconf||2004-06-03|Obsolete and no longer maintained
|
||||
net/samba-devel|net/samba3|2004-06-07|considered stable
|
||||
chinese/mkisofs|sysutils/cdrtools-cjk|2004-06-07|replaced by a superset
|
||||
chinese/cdrtools|sysutils/cdrtools-cjk|2004-06-07|replaced by a superset
|
||||
|
@ -1,20 +0,0 @@
|
||||
# New ports collection makefile for: zh-cdrtools
|
||||
# Date created: 29 March 2003
|
||||
# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
CATEGORIES= chinese sysutils audio
|
||||
|
||||
PATCH_SITES= ftp://freebsd.sinica.edu.tw/pub/statue/cdrtools/
|
||||
PATCHFILES= cdrtools-1.11-NLS-2byte.patch.gz
|
||||
PATCH_DIST_STRIP= -p1
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../sysutils/cdrtools
|
||||
|
||||
MD5_FILE= ${.CURDIR}/distinfo
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,4 +0,0 @@
|
||||
MD5 (cdrtools-2.00.3.tar.gz) = c0cdfa2dbe9f4c977b0a71fb08ddff0e
|
||||
SIZE (cdrtools-2.00.3.tar.gz) = 1638876
|
||||
MD5 (cdrtools-1.11-NLS-2byte.patch.gz) = 4481090bf1e75fa32ba6ba7d8323eac8
|
||||
SIZE (cdrtools-1.11-NLS-2byte.patch.gz) = 523226
|
@ -1,30 +0,0 @@
|
||||
# New ports collection makefile for: zh-mkisofs
|
||||
# Date created: 19 Oct 2000
|
||||
# Whom: Jing-Tang Keith Jang <keith@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= mkisofs
|
||||
PORTVERSION= 1.12b5
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= chinese sysutils
|
||||
MASTER_SITES= ftp://freebsd.sinica.edu.tw/pub/keith/
|
||||
PKGNAMEPREFIX= zh-
|
||||
|
||||
PATCH_SITES= ftp://freebsd.sinica.edu.tw/pub/keith/
|
||||
PATCHFILES= mkisofs-1.12b5.big5patch.gz
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Create ISO9660/JOLIET/Rock Ridge filesystems, Big5 compatible
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
ALL_TARGET= World
|
||||
MAN8= mkisofs-zh.8
|
||||
PLIST_FILES= bin/mkisofs-zh
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/mkisofs ${PREFIX}/bin/mkisofs-zh
|
||||
@${INSTALL_MAN} ${WRKSRC}/mkisofs.8 ${PREFIX}/man/man8/mkisofs-zh.8
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,4 +0,0 @@
|
||||
MD5 (mkisofs-1.12b5.tar.gz) = 176b5f7f2499d8f2b32e55befdd13f69
|
||||
SIZE (mkisofs-1.12b5.tar.gz) = 140651
|
||||
MD5 (mkisofs-1.12b5.big5patch.gz) = 8aa012761b9bf7d6c4d79c7051028ff6
|
||||
SIZE (mkisofs-1.12b5.big5patch.gz) = 71862
|
@ -1,26 +0,0 @@
|
||||
--- include/mconfig.h.orig Mon Mar 1 18:42:26 1999
|
||||
+++ include/mconfig.h Sat May 8 17:00:07 1999
|
||||
@@ -28,6 +28,10 @@
|
||||
#ifndef _MCONFIG_H
|
||||
#define _MCONFIG_H
|
||||
|
||||
+#if (defined(__unix__) || defined(unix)) && !defined(USG)
|
||||
+# include <sys/param.h>
|
||||
+#endif
|
||||
+
|
||||
/*
|
||||
* This hack that is needed as long as VMS has no POSIX shell.
|
||||
*/
|
||||
@@ -77,6 +81,12 @@
|
||||
/*
|
||||
* Some magic that cannot (yet) be figured out with autoconf.
|
||||
*/
|
||||
+
|
||||
+#if (defined(BSD) && (BSD >= 199103))
|
||||
+# ifndef HAVE_FLOCK
|
||||
+# define HAVE_FLOCK
|
||||
+# endif
|
||||
+#endif
|
||||
|
||||
#ifdef sparc
|
||||
# ifndef HAVE_LDSTUB
|
@ -1,26 +0,0 @@
|
||||
--- defaults.h.orig Mon Oct 13 04:21:11 1997
|
||||
+++ defaults.h Thu Dec 4 21:14:16 1997
|
||||
@@ -39,6 +39,22 @@
|
||||
#define SYSTEM_ID_DEFAULT "AIX"
|
||||
#endif
|
||||
|
||||
-#ifndef SYSTEM_ID_DEFAULT
|
||||
+#ifdef __linux__
|
||||
#define SYSTEM_ID_DEFAULT "LINUX"
|
||||
+#endif
|
||||
+
|
||||
+#ifdef __FreeBSD__
|
||||
+#define SYSTEM_ID_DEFAULT "FreeBSD"
|
||||
+#endif
|
||||
+
|
||||
+#ifdef __OpenBSD__
|
||||
+#define SYSTEM_ID_DEFAULT "OpenBSD"
|
||||
+#endif
|
||||
+
|
||||
+#ifdef __NetBSD__
|
||||
+#define SYSTEM_ID_DEFAULT "NetBSD"
|
||||
+#endif
|
||||
+
|
||||
+#ifndef SYSTEM_ID_DEFAULT
|
||||
+#define SYSTEM_ID_DEFAULT "Unknown"
|
||||
#endif
|
@ -1,127 +0,0 @@
|
||||
--- joliet.c.orig Fri Mar 3 15:33:48 2000
|
||||
+++ joliet.c Fri Mar 3 15:54:48 2000
|
||||
@@ -78,6 +78,9 @@
|
||||
#include <stdlib.h>
|
||||
#include <time.h>
|
||||
|
||||
+/* Big5 to Unicode mapping table */
|
||||
+#include "big52uni.h"
|
||||
+
|
||||
static int jpath_table_index;
|
||||
static struct directory ** jpathlist;
|
||||
static int next_jpath_index = 1;
|
||||
@@ -88,6 +91,9 @@
|
||||
static void DECL(assign_joliet_directory_addresses, (struct directory * node));
|
||||
static int jroot_gen __PR((void));
|
||||
|
||||
+static u_int16_t unicode_table[] = CHINESE_UNICODE;
|
||||
+static u_int16_t big5_table[] = CHINESE_BIG5;
|
||||
+
|
||||
/*
|
||||
* Function: convert_to_unicode
|
||||
*
|
||||
@@ -101,6 +107,8 @@
|
||||
unsigned char * tmpbuf;
|
||||
int i;
|
||||
int j;
|
||||
+ int p;
|
||||
+ u_int16_t code, unicode;
|
||||
|
||||
/*
|
||||
* If we get a NULL pointer for the source, it means we have an inplace
|
||||
@@ -156,6 +164,31 @@
|
||||
break;
|
||||
}
|
||||
}
|
||||
+ /******//* big5 to unicode patch*/
|
||||
+
|
||||
+ if( tmpbuf[j] >= 0xA1 ){
|
||||
+
|
||||
+ /* **** 00 A4 00 A4 00 A4 00 E5 **** */
|
||||
+ /* **** ¤¤ ¤å **** */
|
||||
+ /* ***j=A4 A4 A4 E5 --> code=0xa4a4 ->find unicode **** */
|
||||
+ /* **** 4E 2D 65 87 <--- result **** */
|
||||
+
|
||||
+ code = tmpbuf[j];
|
||||
+ code = code << 8;
|
||||
+ code += tmpbuf[j+1];
|
||||
+ for (p=0;p<BIG5_TABLE_SIZE;p++) {
|
||||
+ if (big5_table[p] == code){
|
||||
+ unicode = unicode_table[p];
|
||||
+ buffer[i] = unicode >> 8;
|
||||
+ buffer[i+1] = unicode ;
|
||||
+ j++;
|
||||
+ break;
|
||||
+ }
|
||||
+ /*else {
|
||||
+ return (u_int16_t)'?';
|
||||
+ }*/
|
||||
+ }
|
||||
+ }
|
||||
}
|
||||
|
||||
if( source == NULL )
|
||||
@@ -176,8 +209,48 @@
|
||||
static int FDECL1(joliet_strlen, const char *, string)
|
||||
{
|
||||
int rtn;
|
||||
+ unsigned char * tmpbuf;
|
||||
+ int i;
|
||||
+ int j;
|
||||
+
|
||||
+ int p;
|
||||
+ u_int16_t code, unicode;
|
||||
+ int tmpsize ;
|
||||
|
||||
rtn = strlen(string) << 1;
|
||||
+ tmpsize = rtn;
|
||||
+
|
||||
+ tmpbuf = (u_char *)string;
|
||||
+ tmpsize = rtn;
|
||||
+ j=0;
|
||||
+ for(i=0; i < tmpsize ; i += 2, j++)
|
||||
+ {
|
||||
+ /******//* big5 to unicode patch*/
|
||||
+
|
||||
+ if( tmpbuf[j] >= 0xA1 ){
|
||||
+
|
||||
+ /* **** 00 A4 00 A4 00 A4 00 E5 **** */
|
||||
+ /* **** ¤¤ ¤å **** */
|
||||
+ /* ***j=A4 A4 A4 E5 --> code=0xa4a4 ->find unicode **** */
|
||||
+ /* **** 4E 2D 65 87 <--- result **** */
|
||||
+
|
||||
+ code = tmpbuf[j];
|
||||
+ code = code << 8;
|
||||
+ code += tmpbuf[j+1];
|
||||
+ for (p=0;p<BIG5_TABLE_SIZE;p++) {
|
||||
+ if (big5_table[p] == code){
|
||||
+ tmpsize -= 2;
|
||||
+ unicode = unicode_table[p];
|
||||
+ j++;
|
||||
+ break;
|
||||
+ }
|
||||
+ /*else {
|
||||
+ return (u_int16_t)'?';
|
||||
+ }
|
||||
+ */
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
|
||||
/*
|
||||
* We do clamp the maximum length of a Joliet string to be the
|
||||
@@ -185,11 +258,11 @@
|
||||
* bolix things up with very long paths. The Joliet specs say
|
||||
* that the maximum length is 128 bytes, or 64 unicode characters.
|
||||
*/
|
||||
- if( rtn > 0x80)
|
||||
+ if( tmpsize > 0x80)
|
||||
{
|
||||
- rtn = 0x80;
|
||||
+ tmpsize = 0x80;
|
||||
}
|
||||
- return rtn;
|
||||
+ return tmpsize;
|
||||
}
|
||||
|
||||
/*
|
@ -1,19 +0,0 @@
|
||||
--- name.c.orig Fri Mar 3 15:33:43 2000
|
||||
+++ name.c Fri Mar 3 15:45:25 2000
|
||||
@@ -213,6 +213,7 @@
|
||||
}
|
||||
if(current_length < 30)
|
||||
{
|
||||
+/*
|
||||
if( *pnt < 0 )
|
||||
{
|
||||
*result++ = '_';
|
||||
@@ -221,6 +222,8 @@
|
||||
{
|
||||
*result++ = (islower((unsigned char)*pnt) ? toupper((unsigned char)*pnt) : *pnt);
|
||||
}
|
||||
+*/
|
||||
+ *result++ = *pnt;
|
||||
}
|
||||
}
|
||||
else
|
@ -1,7 +0,0 @@
|
||||
mkisofs is effectively a pre-mastering program to generate the iso9660
|
||||
filesystem - it takes a snapshot of a given directory tree, and generates
|
||||
a binary image which will correspond to an iso9660 filesystem when written
|
||||
to a block device.
|
||||
|
||||
This port can also generate Big5 filenames on Joliet filesystems. Use
|
||||
the -J option to activate it.
|
Loading…
Reference in New Issue
Block a user