- Use PLIST_FILES
- Avoid excessive Makefile-patching
This commit is contained in:
Volker Stolz 2005-03-20 19:14:18 +00:00
parent 82b6c236e8
commit d254587b03
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=131775
8 changed files with 7 additions and 73 deletions

View File

@ -15,13 +15,10 @@ COMMENT= A simulation of the Ziff-Davis netbench benchmark
WRKSRC= ${WRKDIR}/dbench
USE_REINPLACE= yes
post-patch:
@${REINPLACE_CMD} -e 's/^CFLAGS.+//g' ${WRKSRC}/Makefile
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
PLIST_FILES= dbench tbench tbench_srv
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dbench ${PREFIX}/bin/dbench
${INSTALL_PROGRAM} ${WRKSRC}/tbench ${PREFIX}/bin/tbench
${INSTALL_PROGRAM} ${WRKSRC}/tbench_srv ${PREFIX}/bin/tbench_srv
cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PLIST_FILES} ${PREFIX}/bih
.include <bsd.port.mk>

View File

@ -1,29 +0,0 @@
--- Makefile.orig Sun Sep 9 21:21:01 2001
+++ Makefile Thu Aug 22 20:21:37 2002
@@ -1,7 +1,7 @@
VERSION = 1.2.01
-CC = gcc
-CFLAGS = -O2 -Wall
+CC ?= gcc
+
CPPFLAGS = "-DVERSION=\"$(VERSION)\""
DB_OBJS = fileio.o util.o dbench.o child.o
@@ -11,13 +11,13 @@
all: dbench tbench tbench_srv
dbench: $(DB_OBJS)
- $(CC) -o $@ $(DB_OBJS)
+ $(CC) $(CFLAGS) -o $@ $(DB_OBJS)
tbench: $(TB_OBJS)
- $(CC) -o $@ $(TB_OBJS)
+ $(CC) $(CFLAGS) -o $@ $(TB_OBJS)
tbench_srv: $(SRV_OBJS)
- $(CC) -o $@ $(SRV_OBJS)
+ $(CC) $(CFLAGS) -o $@ $(SRV_OBJS)
clean:
rm -f *.o *~ dbench tbench tbench_srv

View File

@ -1,3 +0,0 @@
bin/dbench
bin/tbench
bin/tbench_srv

View File

@ -18,14 +18,8 @@ COMMENT= Serial line protocol analyzer (need two serial interfaces)
WRKSRC= ${WRKDIR}/${PORTNAME}/build
GNU_CONFIGURE= yes
post-extract:
@${RM} -f ${WRKSRC}/.depend
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/snooper
${INSTALL_DATA} ${WRKSRC}/../README ${PREFIX}/share/doc/snooper
.endif
MAKE_ARGS= OPTFLAG=""
PLIST_FILES= bin/snooper
PORTDOCS= README
.include <bsd.port.mk>

View File

@ -1,20 +0,0 @@
--- Makefile.in.orig Wed Aug 12 23:31:56 1998
+++ Makefile.in Thu Jan 18 02:54:00 2001
@@ -2,7 +2,7 @@
srcdir=@srcdir@/..
CC= @CC@
OPTFLAG=@OPTFLAG@
-CFLAGS= -c $(OPTFLAG) -I. -I$(srcdir)/include @CFLAGS@
+CFLAGS= -c -I. -I$(srcdir)/include @CFLAGS@
LDFLAGS=@LDFLAGS@
INSTALL=@INSTALL@
@@ -26,7 +26,7 @@
uucplock.o: ../src/uucplock.c
depend:
- mkdep ${CFLAGS:M-[ID]*} $(srcdir)/src/*.c
+# mkdep ${CFLAGS:M-[ID]*} $(srcdir)/src/*.c
install:
[ -d $(bindir) ] || (mkdir $(bindir))

View File

@ -1,3 +0,0 @@
bin/snooper
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%@dirrm %%DOCSDIR%%

View File

@ -27,6 +27,7 @@ EXTRACT_AFTER_ARGS= |sh
NO_WRKSUBDIR= yes
MAKEFILE= makefile
MAN1= zmrx.1 zmtx.1
PLIST_FILES= bin/zmrx bin/zmtx
do-install:
.for f in zmrx zmtx

View File

@ -1,3 +0,0 @@
@comment $FreeBSD$
bin/zmrx
bin/zmtx