cleanup: Remove expired ports:

2022-06-30 security/py-pycrypto: Unmaintained, obsolete, and contains security vulnerabilities. Use security/py-pycryptodome instead
This commit is contained in:
Rene Ladan 2022-12-31 15:59:13 +01:00
parent e80bca6425
commit d22a54819a
8 changed files with 1 additions and 1429 deletions

1
MOVED
View File

@ -17742,3 +17742,4 @@ x11-toolkits/wxgtk28|x11-toolkits/wxgtk30|2022-12-31|Has expired: Upstream suppo
www/py-txrequests|www/py-requests-futures|2022-12-31|Has expired: Use www/py-requests-futures as upstream is unmaintained since 2018
sysutils/py-ansible-core211||2022-12-31|Has expired: Depends on expired security/py-pycrypto
sysutils/ansible4||2022-12-31|Has expired: Depends on expired security/py-pycrypto (via sysutils/py-ansible-core211)
security/py-pycrypto|security/py-pycryptodome|2022-12-31|Has expired: Unmaintained, obsolete, and contains security vulnerabilities. Use security/py-pycryptodome instead

View File

@ -938,7 +938,6 @@
SUBDIR += py-pyaxo
SUBDIR += py-pyblake2
SUBDIR += py-pyclamd
SUBDIR += py-pycrypto
SUBDIR += py-pycryptodome
SUBDIR += py-pycryptodome-test-vectors
SUBDIR += py-pycryptodomex

View File

@ -1,45 +0,0 @@
PORTNAME= pycrypto
PORTVERSION= 2.6.1
PORTREVISION= 3
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Python Cryptography Toolkit
WWW= https://pycrypto.org
LICENSE= PD
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
DEPRECATED= Unmaintained, obsolete, and contains security vulnerabilities. Use security/py-pycryptodome instead
EXPIRATION_DATE=2022-06-30
USES= cpe python:3.6-3.10
USE_PYTHON= distutils autoplist
CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}pycryptodome
CPE_VENDOR= dlitz
GNU_CONFIGURE= yes
OPTIONS_DEFINE= GMP
OPTIONS_DEFAULT= GMP
GMP_DESC= Use GMP for faster DSA/RSA operations
GMP_CONFIGURE_WITH= gmp
GMP_CPPFLAGS= -I${LOCALBASE}/include
GMP_LDFLAGS= -L${LOCALBASE}/lib
GMP_LIB_DEPENDS= libgmp.so:math/gmp
pre-patch:
@${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/setup.py
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/Crypto/*/*.so
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (pycrypto-2.6.1.tar.gz) = f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c
SIZE (pycrypto-2.6.1.tar.gz) = 446240

File diff suppressed because it is too large Load Diff

View File

@ -1,37 +0,0 @@
--- lib/Crypto/SelfTest/Util/test_number.py.orig 2013-10-14 21:38:10 UTC
+++ lib/Crypto/SelfTest/Util/test_number.py
@@ -276,6 +276,11 @@ class MiscTests(unittest.TestCase):
self.assertEqual(number.size(0xa2ba40),8*3)
self.assertEqual(number.size(0xa2ba40ee07e3b2bd2f02ce227f36a195024486e49c19cb41bbbdfbba98b22b0e577c2eeaffa20d883a76e65e394c69d4b3c05a1e8fadda27edb2a42bc000fe888b9b32c22d15add0cd76b3e7936e19955b220dd17d4ea904b1ec102b2e4de7751222aa99151024c7cb41cc5ea21d00eeb41f7c800834d2c6e06bce3bce7ea9a5L), 1024)
+class FastmathTests(unittest.TestCase):
+ def setUp(self):
+ global number
+ from Crypto.Util import number
+
def test_negative_number_roundtrip_mpzToLongObj_longObjToMPZ(self):
"""Test that mpzToLongObj and longObjToMPZ (internal functions) roundtrip negative numbers correctly."""
n = -100000000000000000000000000000000000L
@@ -286,7 +291,21 @@ class MiscTests(unittest.TestCase):
def get_tests(config={}):
from Crypto.SelfTest.st_common import list_test_cases
- return list_test_cases(MiscTests)
+ tests = list_test_cases(MiscTests)
+ try:
+ from Crypto.PublicKey import _fastmath
+ tests += list_test_cases(FastmathTests)
+ except ImportError:
+ from distutils.sysconfig import get_config_var
+ import inspect, os.path
+ _fm_path = os.path.normpath(os.path.dirname(os.path.abspath(
+ inspect.getfile(inspect.currentframe())))
+ +"/../../PublicKey/_fastmath"+get_config_var("SO"))
+ if os.path.exists(_fm_path):
+ raise ImportError("While the _fastmath module exists, importing "+
+ "it failed. This may point to the gmp or mpir shared library "+
+ "not being in the path. _fastmath was found at "+_fm_path)
+ return tests
if __name__ == '__main__':
suite = lambda: unittest.TestSuite(get_tests())

View File

@ -1,10 +0,0 @@
--- setup.py.orig 2013-10-14 21:38:10 UTC
+++ setup.py
@@ -136,6 +136,7 @@ class PCTBuildExt (build_ext):
# especially helps the DES modules.
self.__add_compiler_option("-O3")
self.__add_compiler_option("-fomit-frame-pointer")
+ self.__add_compiler_option("-D_WCHAR_T_DEFINED")
# Don't include debug symbols unless debugging
self.__remove_compiler_option("-g")
# Don't include profiling information (incompatible with

View File

@ -1,5 +0,0 @@
Python Cryptography Toolkit (pycrypto)
This is a collection of both secure hash functions (such as MD5 and
SHA), and various encryption algorithms (AES, DES, ElGamal, etc.) for
Python.