- Update to 0.995

- Add a patch to fix build error with Ruby 1.8 [1]
- Add LICENSE section
- Adopt OptionsNG
- Trim Makefile header
- Remove Author: line from pkg-descr
- Replace tab with space WWW: line in pkg-descr
- Update WWW: line in pkg-descr

PR:		ports/175257
Submitted by:	Yasuhiro KIMURA <yasu_AT_utahime_DOT_org>
Obtained from:	http://code.google.com/p/mecab/issues/detail?id=3 [1]
This commit is contained in:
TAKATSU Tomonari 2013-03-20 12:40:53 +00:00
parent f1c95ec4c3
commit d1ef8e6200
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=314726
4 changed files with 28 additions and 12 deletions

View File

@ -1,12 +1,8 @@
# New ports collection makefile for: ruby-mecab
# Date created: 23 April 2003
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
# $FreeBSD$
#
PORTNAME= mecab
PORTVERSION= 0.994
PORTVERSION= 0.995
CATEGORIES= japanese textproc ruby
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTNAME= ${PORTNAME}-ruby-${PORTVERSION}
@ -14,6 +10,12 @@ DISTNAME= ${PORTNAME}-ruby-${PORTVERSION}
MAINTAINER= ruby@FreeBSD.org
COMMENT= MeCab library module for Ruby
LICENSE= BSD GPLv2 LGPL21
LICENSE_COMB= dual
LICENSE_FILE_BSD= ${WRKSRC}/BSD
LICENSE_FILE_GPLv2= ${WRKSRC}/GPL
LICENSE_FILE_LGPL21= ${WRKSRC}/LGPL
LIB_DEPENDS= mecab:${PORTSDIR}/japanese/mecab
USE_RUBY= yes
@ -21,16 +23,19 @@ USE_RUBY_EXTCONF= yes
INSTALL_TARGET= site-install
OPTIONS_DEFINE= DOCS EXAMPLES
OPTIONSFILE= ${PORT_DBDIR}/ja-ruby-${PORTNAME}/options
.include <bsd.port.pre.mk>
PKGNAMEPREFIX:= ${PKGNAMEPREFIX}${RUBY_PKGNAMEPREFIX}
post-install:
.if !defined(NOPORTDOCS)
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${RUBY_MODDOCDIR}
${INSTALL_DATA} ${WRKSRC}/bindings.html ${RUBY_MODDOCDIR}/
.endif
.if !defined(NOPORTEXAMPLES)
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${RUBY_MODEXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/test.rb ${RUBY_MODEXAMPLESDIR}/
.endif

View File

@ -1,2 +1,2 @@
SHA256 (mecab-ruby-0.994.tar.gz) = 16f9c6de6a90fb11d07f191ea646217e9006a6aec3f90f386b476ce51e611269
SIZE (mecab-ruby-0.994.tar.gz) = 44483
SHA256 (mecab-ruby-0.995.tar.gz) = d55241f11ad676fe02421c67ad57f5805c1ef893d6b6b91d0209ac9cf0dfa7f0
SIZE (mecab-ruby-0.995.tar.gz) = 48688

View File

@ -0,0 +1,12 @@
--- MeCab_wrap.cpp.orig 2013-01-25 14:07:27.000000000 +0900
+++ MeCab_wrap.cpp 2013-03-20 15:01:31.000000000 +0900
@@ -1856,8 +1856,7 @@
/* Workaround for ruby1.9.x */
#if defined SWIGRUBY
-#include "ruby/version.h"
-#if RUBY_API_VERSION_CODE >= 10900
+#if HAVE_RUBY_ENCODING_H
#include "ruby/encoding.h"
#define rb_str_new rb_external_str_new
#endif

View File

@ -1,4 +1,3 @@
This is the MeCab library module for Ruby.
Author: Taku Kudo <taku@chasen.org>
WWW: http://mecab.sourceforge.net/
WWW: https://code.google.com/p/mecab/