Correct md5 checksum, and portlint.

PR:		ports/9829
Submitted by:	Jeremy Lea <reg@shale.csir.co.za>
This commit is contained in:
Vanilla I. Shu 1999-02-02 13:04:06 +00:00
parent 1afe8587a1
commit d1e1fa4161
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=16493
10 changed files with 170 additions and 52 deletions

View File

@ -3,30 +3,29 @@
# Date created: 21 August 1998
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
# $Id: Makefile,v 1.3 1999/01/17 19:58:37 vanilla Exp $
# $Id: Makefile,v 1.4 1999/01/27 08:31:51 fenner Exp $
#
DISTNAME= ggv-0.26
CATEGORIES= print
CATEGORIES= print gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= ggv
MAINTAINER= nacai@iname.com
BUILD_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
LIB_DEPENDS= gnomeui.1:${PORTSDIR}/x11/gnomelibs
BROKEN= "gnome 0.99.3"
# implicit dependencies:
# gettext, xpm, gtk11-devel, gnomelibs
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
--datadir=${PREFIX}/share/gnome \
--with-gnome=${X11BASE}
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include \
-I${X11BASE}/include" \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
GTK_CONFIG="${X11BASE}/bin/gtk11d-config" \
GLIB_CONFIG="${LOCALBASE}/bin/glib11d-config" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (ggv-0.26.tar.gz) = efe9c011165f0313600e5988b005a6d2
MD5 (ggv-0.26.tar.gz) = ff3cf03289b3effd8fc8fb0e29ab6e03

View File

@ -1,20 +1,43 @@
--- configure.orig Thu Oct 15 04:18:51 1998
+++ configure Thu Oct 15 04:19:37 1998
@@ -925,12 +925,12 @@
--- configure.orig Wed Dec 16 23:06:18 1998
+++ configure Tue Jan 26 14:13:02 1999
@@ -1076,13 +1076,13 @@
fi
if test "$no_gnome_config" = "yes"; then
- echo $ac_n "checking for gnomeConf.sh file in $gnome_prefix""... $ac_c" 1>&6
-echo "configure:1081: checking for gnomeConf.sh file in $gnome_prefix" >&5
- if test -f $gnome_prefix/gnomeConf.sh; then
+ echo $ac_n "checking for gnomeConf.sh file in $prefix/share/gnome""... $ac_c" 1>&6
+echo "configure:1081: checking for gnomeConf.sh file in $prefix/share/gnome" >&5
+ if test -f $prefix/share/gnome/gnomeConf.sh; then
echo "$ac_t""found" 1>&6
echo "loading gnome configuration from" \
- "$gnome_prefix/gnomeConf.sh"
- . $gnome_prefix/gnomeConf.sh
+ "$prefix/share/gnome/gnomeConf.sh"
+ . $prefix/share/gnome/gnomeConf.sh
else
echo "$ac_t""not found" 1>&6
@@ -4024,15 +4024,15 @@
fi
- USE_INCLUDED_LIBINTL=yes
+# USE_INCLUDED_LIBINTL=yes
CATOBJEXT=.gmo
INSTOBJEXT=.mo
DATADIRNAME=share
- INTLDEPS='$(top_builddir)/intl/libintl.a'
- INTLLIBS=$INTLDEPS
- LIBS=`echo $LIBS | sed -e 's/-lintl//'`
- nls_cv_header_intl=intl/libintl.h
- nls_cv_header_libgt=intl/libgettext.h
+# INTLDEPS='$(top_builddir)/intl/libintl.a'
+# INTLLIBS=$INTLDEPS
+# LIBS=`echo $LIBS | sed -e 's/-lintl//'`
+# nls_cv_header_intl=intl/libintl.h
+# nls_cv_header_libgt=intl/libgettext.h
fi
if test "$no_gnome_config" = "yes"; then
- echo $ac_n "checking for gnomeConf.sh file in $gnome_prefix""... $ac_c" 1>&6
-echo "configure:930: checking for gnomeConf.sh file in $gnome_prefix" >&5
- if test -f $gnome_prefix/gnomeConf.sh; then
+ echo $ac_n "checking for gnomeConf.sh file in $prefix/share/gnome""... $ac_c" 1>&6
+echo "configure:930: checking for gnomeConf.sh file in $prefix/share/gnome" >&5
+ if test -f $prefix/share/gnome/gnomeConf.sh; then
echo "$ac_t""found" 1>&6
- echo "loading gnome configuration from $gnome_prefix/gnomeConf.sh"
- . $gnome_prefix/gnomeConf.sh
+ echo "loading gnome configuration from $prefix/share/gnome/gnomeConf.sh"
+ . $prefix/share/gnome/gnomeConf.sh
else
echo "$ac_t""not found" 1>&6
if test "$XGETTEXT" != ":"; then

35
print/ggv/files/patch-ad Normal file
View File

@ -0,0 +1,35 @@
--- ps.h.orig Tue Jan 26 13:58:49 1999
+++ ps.h Tue Jan 26 13:59:06 1999
@@ -40,6 +40,7 @@
/* Constants used to store keywords that are scanned. */
/* NONE is not a keyword, it tells when a field was not set */
+#undef NONE
enum {ATEND = -1, NONE = 0, PORTRAIT, LANDSCAPE, ASCEND, DESCEND, SPECIAL};
#define PSLINELENGTH 257 /* 255 characters + 1 newline + 1 NULL */
--- ps.c.orig Tue Jan 26 14:19:36 1999
+++ ps.c Tue Jan 26 14:20:12 1999
@@ -54,7 +54,10 @@
#endif
#include <ctype.h>
#include <X11/Xos.h> /* #includes the appropriate <string.h> */
+#include <sys/stat.h>
+#include <glib.h>
#include "ps.h"
+#include "file.h"
#ifdef BSD4_2
#define memset(a,b,c) bzero(a,c)
@@ -208,11 +211,6 @@
/* Jake Hamby patch 18/3/98 */
/* Following text added */
-#include <sys/stat.h>
-
-#include <glib.h>
-
-#include "file.h"
int
file_fileIsNotUseful(fn)

View File

@ -1,5 +1,7 @@
bin/ggv
share/gnome/apps/Graphics/ggv.desktop
share/locale/es/LC_MESSAGES/ggv.mo
share/locale/fr/LC_MESSAGES/ggv.mo
share/locale/ko/LC_MESSAGES/ggv.mo
share/locale/no/LC_MESSAGES/ggv.mo
share/locale/pt/LC_MESSAGES/ggv.mo

View File

@ -3,30 +3,29 @@
# Date created: 21 August 1998
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
# $Id: Makefile,v 1.3 1999/01/17 19:58:37 vanilla Exp $
# $Id: Makefile,v 1.4 1999/01/27 08:31:51 fenner Exp $
#
DISTNAME= ggv-0.26
CATEGORIES= print
CATEGORIES= print gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= ggv
MAINTAINER= nacai@iname.com
BUILD_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
LIB_DEPENDS= gnomeui.1:${PORTSDIR}/x11/gnomelibs
BROKEN= "gnome 0.99.3"
# implicit dependencies:
# gettext, xpm, gtk11-devel, gnomelibs
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
--datadir=${PREFIX}/share/gnome \
--with-gnome=${X11BASE}
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include \
-I${X11BASE}/include" \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
GTK_CONFIG="${X11BASE}/bin/gtk11d-config" \
GLIB_CONFIG="${LOCALBASE}/bin/glib11d-config" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (ggv-0.26.tar.gz) = efe9c011165f0313600e5988b005a6d2
MD5 (ggv-0.26.tar.gz) = ff3cf03289b3effd8fc8fb0e29ab6e03

View File

@ -1,20 +1,43 @@
--- configure.orig Thu Oct 15 04:18:51 1998
+++ configure Thu Oct 15 04:19:37 1998
@@ -925,12 +925,12 @@
--- configure.orig Wed Dec 16 23:06:18 1998
+++ configure Tue Jan 26 14:13:02 1999
@@ -1076,13 +1076,13 @@
fi
if test "$no_gnome_config" = "yes"; then
- echo $ac_n "checking for gnomeConf.sh file in $gnome_prefix""... $ac_c" 1>&6
-echo "configure:1081: checking for gnomeConf.sh file in $gnome_prefix" >&5
- if test -f $gnome_prefix/gnomeConf.sh; then
+ echo $ac_n "checking for gnomeConf.sh file in $prefix/share/gnome""... $ac_c" 1>&6
+echo "configure:1081: checking for gnomeConf.sh file in $prefix/share/gnome" >&5
+ if test -f $prefix/share/gnome/gnomeConf.sh; then
echo "$ac_t""found" 1>&6
echo "loading gnome configuration from" \
- "$gnome_prefix/gnomeConf.sh"
- . $gnome_prefix/gnomeConf.sh
+ "$prefix/share/gnome/gnomeConf.sh"
+ . $prefix/share/gnome/gnomeConf.sh
else
echo "$ac_t""not found" 1>&6
@@ -4024,15 +4024,15 @@
fi
- USE_INCLUDED_LIBINTL=yes
+# USE_INCLUDED_LIBINTL=yes
CATOBJEXT=.gmo
INSTOBJEXT=.mo
DATADIRNAME=share
- INTLDEPS='$(top_builddir)/intl/libintl.a'
- INTLLIBS=$INTLDEPS
- LIBS=`echo $LIBS | sed -e 's/-lintl//'`
- nls_cv_header_intl=intl/libintl.h
- nls_cv_header_libgt=intl/libgettext.h
+# INTLDEPS='$(top_builddir)/intl/libintl.a'
+# INTLLIBS=$INTLDEPS
+# LIBS=`echo $LIBS | sed -e 's/-lintl//'`
+# nls_cv_header_intl=intl/libintl.h
+# nls_cv_header_libgt=intl/libgettext.h
fi
if test "$no_gnome_config" = "yes"; then
- echo $ac_n "checking for gnomeConf.sh file in $gnome_prefix""... $ac_c" 1>&6
-echo "configure:930: checking for gnomeConf.sh file in $gnome_prefix" >&5
- if test -f $gnome_prefix/gnomeConf.sh; then
+ echo $ac_n "checking for gnomeConf.sh file in $prefix/share/gnome""... $ac_c" 1>&6
+echo "configure:930: checking for gnomeConf.sh file in $prefix/share/gnome" >&5
+ if test -f $prefix/share/gnome/gnomeConf.sh; then
echo "$ac_t""found" 1>&6
- echo "loading gnome configuration from $gnome_prefix/gnomeConf.sh"
- . $gnome_prefix/gnomeConf.sh
+ echo "loading gnome configuration from $prefix/share/gnome/gnomeConf.sh"
+ . $prefix/share/gnome/gnomeConf.sh
else
echo "$ac_t""not found" 1>&6
if test "$XGETTEXT" != ":"; then

35
print/ggv2/files/patch-ad Normal file
View File

@ -0,0 +1,35 @@
--- ps.h.orig Tue Jan 26 13:58:49 1999
+++ ps.h Tue Jan 26 13:59:06 1999
@@ -40,6 +40,7 @@
/* Constants used to store keywords that are scanned. */
/* NONE is not a keyword, it tells when a field was not set */
+#undef NONE
enum {ATEND = -1, NONE = 0, PORTRAIT, LANDSCAPE, ASCEND, DESCEND, SPECIAL};
#define PSLINELENGTH 257 /* 255 characters + 1 newline + 1 NULL */
--- ps.c.orig Tue Jan 26 14:19:36 1999
+++ ps.c Tue Jan 26 14:20:12 1999
@@ -54,7 +54,10 @@
#endif
#include <ctype.h>
#include <X11/Xos.h> /* #includes the appropriate <string.h> */
+#include <sys/stat.h>
+#include <glib.h>
#include "ps.h"
+#include "file.h"
#ifdef BSD4_2
#define memset(a,b,c) bzero(a,c)
@@ -208,11 +211,6 @@
/* Jake Hamby patch 18/3/98 */
/* Following text added */
-#include <sys/stat.h>
-
-#include <glib.h>
-
-#include "file.h"
int
file_fileIsNotUseful(fn)

View File

@ -1,5 +1,7 @@
bin/ggv
share/gnome/apps/Graphics/ggv.desktop
share/locale/es/LC_MESSAGES/ggv.mo
share/locale/fr/LC_MESSAGES/ggv.mo
share/locale/ko/LC_MESSAGES/ggv.mo
share/locale/no/LC_MESSAGES/ggv.mo
share/locale/pt/LC_MESSAGES/ggv.mo