MFH: r550048
astro/wmglobe: fix 13-CURRENT build Another instance of -fno-common issue. Some minor build warnings fixed. PR: 249389 Submitted by: jd.fbsd@goneja.de (maintainer) Approved by: ports-secteam (blanket, runtime fix, -fno-common)
This commit is contained in:
parent
cb2a4eacc8
commit
d1d2431b4b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q3/; revision=550049
@ -18,8 +18,9 @@ LIB_DEPENDS= libwraster.so:x11-wm/libwraster
|
||||
USES= xorg
|
||||
USE_XORG= x11 xext xpm
|
||||
|
||||
PLIST_FILES= bin/wmglobe \
|
||||
man/man1/wmglobe.1.gz
|
||||
MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
|
||||
|
||||
PLIST_FILES= bin/wmglobe \
|
||||
man/man1/wmglobe.1.gz
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
20
astro/wmglobe/files/patch-src_myconvert.c
Normal file
20
astro/wmglobe/files/patch-src_myconvert.c
Normal file
@ -0,0 +1,20 @@
|
||||
--- src/myconvert.c.orig 2020-09-16 20:04:28 UTC
|
||||
+++ src/myconvert.c
|
||||
@@ -253,7 +253,7 @@ static RXImage *image2PseudoColor(RContext * ctx, RIma
|
||||
const unsigned short bmask = rmask;
|
||||
unsigned short *rtable, *gtable, *btable;
|
||||
const int cpccpc = cpc * cpc;
|
||||
- unsigned char *data;
|
||||
+ char *data;
|
||||
int ofs;
|
||||
/*register unsigned char maxrgb = 0xff; */
|
||||
|
||||
@@ -420,7 +420,7 @@ static RXImage *image2GrayScale(RContext * ctx, RImage
|
||||
const int cpc = ctx->attribs->colors_per_channel;
|
||||
unsigned short gmask;
|
||||
unsigned short *table;
|
||||
- unsigned char *data;
|
||||
+ char *data;
|
||||
int ofs;
|
||||
/*register unsigned char maxrgb = 0xff; */
|
||||
|
23
astro/wmglobe/files/patch-src_rend.c
Normal file
23
astro/wmglobe/files/patch-src_rend.c
Normal file
@ -0,0 +1,23 @@
|
||||
--- src/rend.c.orig 2020-09-15 14:31:47 UTC
|
||||
+++ src/rend.c
|
||||
@@ -33,6 +33,20 @@
|
||||
|
||||
#include "wmglobe.h"
|
||||
|
||||
+/*
|
||||
+ * variables globales
|
||||
+ */
|
||||
+
|
||||
+double solu[DIAMETRE][DIAMETRE][3];
|
||||
+int tabsolu[DIAMETRE][DIAMETRE];
|
||||
+double moon_lat,moon_long;
|
||||
+struct timeval tlast, tnext, trend, tdelay, tini, tbase;
|
||||
+time_t tsunpos;
|
||||
+double center_dist;
|
||||
+double light_x, light_y, light_z; /* vector of sunlight with lengt 1 */
|
||||
+double c_coef, b_coef;
|
||||
+int radius_proj, aml;
|
||||
+
|
||||
static RColor mygetMapColorLinear
|
||||
(double longitude, double latitude, double angle);
|
||||
|
29
astro/wmglobe/files/patch-src_wmglobe.c
Normal file
29
astro/wmglobe/files/patch-src_wmglobe.c
Normal file
@ -0,0 +1,29 @@
|
||||
--- src/wmglobe.c.orig 2001-08-12 15:41:22 UTC
|
||||
+++ src/wmglobe.c
|
||||
@@ -35,7 +35,17 @@
|
||||
#include "defnimap.xpm"
|
||||
#endif
|
||||
|
||||
+/*
|
||||
+ * variables globales
|
||||
+ */
|
||||
|
||||
+Display *dpy;
|
||||
+Pixmap pix, pixmask;
|
||||
+XEvent Event;
|
||||
+RImage *map, *small, *mapnight;
|
||||
+Window iconwin, win;
|
||||
+GC NormalGC;
|
||||
+double marker[MAX_MARKERS][3];
|
||||
|
||||
|
||||
|
||||
@@ -414,7 +424,7 @@ int main(int argc, char *argv[])
|
||||
if (do_something) {
|
||||
if (!myRConvertImage(ctx, small, &pix)) {
|
||||
fprintf(stderr, "crash !?\n");
|
||||
- fprintf(stderr, RMessageForError(RErrorCode));
|
||||
+ fprintf(stderr, "%s", RMessageForError(RErrorCode));
|
||||
exit(1);
|
||||
}
|
||||
wmg.pixmap = pix;
|
141
astro/wmglobe/files/patch-src_wmglobe.h
Normal file
141
astro/wmglobe/files/patch-src_wmglobe.h
Normal file
@ -0,0 +1,141 @@
|
||||
--- src/wmglobe.h.orig 2001-08-12 15:41:22 UTC
|
||||
+++ src/wmglobe.h
|
||||
@@ -34,7 +34,6 @@
|
||||
#include <ctype.h> /*toupper */
|
||||
#include <stdarg.h>
|
||||
#include <time.h>
|
||||
-#include <sys/timeb.h>
|
||||
#include <sys/time.h>
|
||||
#include <sys/types.h>
|
||||
#include <X11/Xlib.h>
|
||||
@@ -83,17 +82,17 @@ typedef struct {
|
||||
int right;
|
||||
} MOUSE_REGION;
|
||||
|
||||
-MOUSE_REGION mouse_region[MAX_MOUSE_REGION];
|
||||
+extern MOUSE_REGION mouse_region[MAX_MOUSE_REGION];
|
||||
|
||||
typedef struct MPO {
|
||||
int r, g, b;
|
||||
} MPO;
|
||||
|
||||
-MPO *md[4], *mn[4];
|
||||
+extern MPO *md[4], *mn[4];
|
||||
|
||||
-double solu[DIAMETRE][DIAMETRE][3];
|
||||
-int tabsolu[DIAMETRE][DIAMETRE];
|
||||
-int solution;
|
||||
+extern double solu[DIAMETRE][DIAMETRE][3];
|
||||
+extern int tabsolu[DIAMETRE][DIAMETRE];
|
||||
+extern int solution;
|
||||
|
||||
typedef struct {
|
||||
Pixmap pixmap;
|
||||
@@ -102,72 +101,72 @@ typedef struct {
|
||||
} XpmIcon;
|
||||
|
||||
|
||||
-Display *dpy;
|
||||
+extern Display *dpy;
|
||||
|
||||
-char *dayfile, *nightfile, *dpy_name;
|
||||
+extern char *dayfile, *nightfile, *dpy_name;
|
||||
|
||||
-Pixmap pix, pixmask;
|
||||
+extern Pixmap pix, pixmask;
|
||||
|
||||
-XEvent Event;
|
||||
+extern XEvent Event;
|
||||
|
||||
-RImage *map, *small, *mapnight;
|
||||
+extern RImage *map, *small, *mapnight;
|
||||
|
||||
-XpmIcon screenpos, scrdate, scrdiv, numpix, txtpix, wmg;
|
||||
+extern XpmIcon screenpos, scrdate, scrdiv, numpix, txtpix, wmg;
|
||||
|
||||
-Window iconwin, win;
|
||||
-int onlyshape, option_iw;
|
||||
-GC NormalGC;
|
||||
+extern Window iconwin, win;
|
||||
+extern int onlyshape, option_iw;
|
||||
+extern GC NormalGC;
|
||||
|
||||
/********* rendering********/
|
||||
|
||||
#if WITH_MARKERS
|
||||
-double marker[MAX_MARKERS][3];
|
||||
-int nb_marker, sun_marker, moon_marker;
|
||||
-RColor sun_col, moon_col;
|
||||
-double moon_lat,moon_long;
|
||||
+extern double marker[MAX_MARKERS][3];
|
||||
+extern int nb_marker, sun_marker, moon_marker;
|
||||
+extern RColor sun_col, moon_col;
|
||||
+extern double moon_lat,moon_long;
|
||||
#endif
|
||||
|
||||
-double delay, time_multi;
|
||||
+extern double delay, time_multi;
|
||||
/*
|
||||
* struct timeval delta_tim, last_tim, next_tim, render_tim, base_tim,
|
||||
* vec_tim;
|
||||
*
|
||||
* time_t beg_time, ini_time,t1901;
|
||||
*/
|
||||
-struct timeval tlast, tnext, trend, tdelay, tini, tbase;
|
||||
-time_t tsunpos;
|
||||
+extern struct timeval tlast, tnext, trend, tdelay, tini, tbase;
|
||||
+extern time_t tsunpos;
|
||||
|
||||
-int sens, fun, funx, funy, oknimap, mratiox, mratioy, gotoscr;
|
||||
+extern int sens, fun, funx, funy, oknimap, mratiox, mratioy, gotoscr;
|
||||
|
||||
-int typecadre, p_type, use_nightmap, use_default_nightmap, use_nmap_ini,
|
||||
-firstTime, stoprand, do_something, iop;
|
||||
+extern int typecadre, p_type, use_nightmap, use_default_nightmap,
|
||||
+ use_nmap_ini, firstTime, stoprand, do_something, iop;
|
||||
|
||||
-double v_lat, v_long, old_dvlat, old_dvlong, dv_lat, dv_long;
|
||||
-double dlat, dlong, addlat, addlong, ratiox, ratioy, dawn;
|
||||
+extern double v_lat, v_long, old_dvlat, old_dvlong, dv_lat, dv_long;
|
||||
+extern double dlat, dlong, addlat, addlong, ratiox, ratioy, dawn;
|
||||
|
||||
-double sun_lat;
|
||||
-double sun_long;
|
||||
+extern double sun_lat;
|
||||
+extern double sun_long;
|
||||
|
||||
-double fov;
|
||||
-double radius;
|
||||
-double proj_dist; /* distance to projection plane */
|
||||
+extern double fov;
|
||||
+extern double radius;
|
||||
+extern double proj_dist; /* distance to projection plane */
|
||||
|
||||
-double center_dist; /* distance to center of earth */
|
||||
+extern double center_dist; /* distance to center of earth */
|
||||
|
||||
-double ambient_light; /* how dark is the dark side? */
|
||||
+extern double ambient_light; /* how dark is the dark side? */
|
||||
|
||||
-double light_x, light_y, light_z; /* vector of sunlight with lengt 1 */
|
||||
+extern double light_x, light_y, light_z; /* vector of sunlight with lengt 1 */
|
||||
|
||||
-double c_coef, b_coef;
|
||||
-double zoom;
|
||||
-int radius_proj, aml; /* radius of sphere on screen */
|
||||
+extern double c_coef, b_coef;
|
||||
+extern double zoom;
|
||||
+extern int radius_proj, aml; /* radius of sphere on screen */
|
||||
|
||||
-RColor noir;
|
||||
+extern RColor noir;
|
||||
#ifdef DEBUG
|
||||
-double minhz;
|
||||
+extern double minhz;
|
||||
#endif
|
||||
|
||||
-int stable;
|
||||
+extern int stable;
|
||||
|
||||
/****************************************************************/
|
||||
/* Function Prototypes */
|
40
astro/wmglobe/files/patch-src_wmgutil.c
Normal file
40
astro/wmglobe/files/patch-src_wmgutil.c
Normal file
@ -0,0 +1,40 @@
|
||||
--- src/wmgutil.c.orig 2020-09-15 14:29:30 UTC
|
||||
+++ src/wmgutil.c
|
||||
@@ -32,6 +32,37 @@
|
||||
#include "scrtime.xpm"
|
||||
#include "scrdiv.xpm"
|
||||
|
||||
+/*
|
||||
+ * variables globales
|
||||
+ */
|
||||
+
|
||||
+MOUSE_REGION mouse_region[MAX_MOUSE_REGION];
|
||||
+MPO *md[4], *mn[4];
|
||||
+int solution;
|
||||
+char *dayfile, *nightfile, *dpy_name;
|
||||
+XpmIcon screenpos, scrdate, scrdiv, numpix, txtpix, wmg;
|
||||
+int onlyshape, option_iw;
|
||||
+int nb_marker, sun_marker, moon_marker;
|
||||
+RColor sun_col, moon_col;
|
||||
+double delay, time_multi;
|
||||
+int sens, fun, funx, funy, oknimap, mratiox, mratioy, gotoscr;
|
||||
+int typecadre, p_type, use_nightmap, use_default_nightmap, use_nmap_ini,
|
||||
+ firstTime, stoprand, do_something, iop;
|
||||
+double v_lat, v_long, old_dvlat, old_dvlong, dv_lat, dv_long;
|
||||
+double dlat, dlong, addlat, addlong, ratiox, ratioy, dawn;
|
||||
+double sun_lat;
|
||||
+double sun_long;
|
||||
+double fov;
|
||||
+double radius;
|
||||
+double proj_dist; /* distance to projection plane */
|
||||
+double ambient_light;
|
||||
+double zoom;
|
||||
+RColor noir;
|
||||
+double minhz;
|
||||
+int stable;
|
||||
+
|
||||
+
|
||||
+
|
||||
static void move_earth(double vla, double vlo);
|
||||
static int flush_expose(Window w);
|
||||
static void mqparam();
|
Loading…
Reference in New Issue
Block a user