Fix build when WINE is installed.
Abort the build when GNU pth is installed. Remove the WITH_MGA knob. PR: 27961 Submitted by: maintainer
This commit is contained in:
parent
82697c520e
commit
d1a6ae4207
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=43642
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= avifile
|
||||
PORTVERSION= 0.60.20010429
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://ernie.eit.uni-kl.de/avifile/ \
|
||||
http://divx.euro.ru/ \
|
||||
@ -34,9 +35,6 @@ CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
|
||||
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS= --with-win32-path=${LOCALBASE}/lib/win32 \
|
||||
--enable-release --with-gnu-ld
|
||||
.if defined(WITH_MGA)
|
||||
CONFIGURE_ARGS+=--enable-mga
|
||||
.endif
|
||||
|
||||
PLIST_SUB= LIB_VERSION="${LIB_VERSION}"
|
||||
|
||||
@ -59,10 +57,11 @@ DIFF?= /usr/bin/diff
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
pre-extract:
|
||||
.if !defined(WITH_MGA)
|
||||
@${ECHO_MSG} "You can enable special MGA support by building with -DWITH_MGA."
|
||||
.endif
|
||||
|
||||
@if [ -f ${LOCALBASE}/lib/libpth.so ]; then \
|
||||
${ECHO_MSG} "Error: This packet does not compile when the \
|
||||
packet 'pth' is installed.";\
|
||||
${FALSE};\
|
||||
fi
|
||||
do-configure:
|
||||
(cd ${WRKSRC} && aclocal && ./autogen.sh &&\
|
||||
${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS})
|
||||
|
10
graphics/avifile/files/patch-Makefile-libwin32Makefile
Normal file
10
graphics/avifile/files/patch-Makefile-libwin32Makefile
Normal file
@ -0,0 +1,10 @@
|
||||
--- plugins/libwin32/Makefile.am.orig Wed Jun 6 00:03:19 2001
|
||||
+++ plugins/libwin32/Makefile.am Wed Jun 6 00:03:37 2001
|
||||
@@ -12,6 +12,6 @@
|
||||
|
||||
libwin32_la_LDFLAGS = -module -version-info 0:0:0
|
||||
|
||||
-CPPFLAGS = @CPPFLAGS@ -Iloader -Iloader/wine -Ivideocodec -Iaudiodec -IDirectShow
|
||||
+CPPFLAGS = -Iloader -Iloader/wine -Ivideocodec -Iaudiodec -IDirectShow @CPPFLAGS@
|
||||
|
||||
LIBS = @AVILIBDEPLIB@
|
@ -7,5 +7,3 @@
|
||||
-#include <SDL/SDL_keysym.h>
|
||||
+#include <SDL11/SDL_keysym.h>
|
||||
#endif
|
||||
|
||||
|
||||
|
10
graphics/avifile/files/patch-videocodecMakefile
Normal file
10
graphics/avifile/files/patch-videocodecMakefile
Normal file
@ -0,0 +1,10 @@
|
||||
--- plugins/libwin32/videocodec/Makefile.am.orig Mon Jun 4 20:47:34 2001
|
||||
+++ plugins/libwin32/videocodec/Makefile.am Mon Jun 4 20:47:52 2001
|
||||
@@ -5,6 +5,6 @@
|
||||
libvideocodec_la_SOURCES=DS_VideoDecoder.cpp VideoEncoder.cpp \
|
||||
VideoDecoder.cpp Module.cpp VideoCodec.cpp
|
||||
|
||||
-CPPFLAGS = @CPPFLAGS@ -I../loader -I../DirectShow
|
||||
+CPPFLAGS = -I../loader -I../DirectShow @CPPFLAGS@
|
||||
|
||||
LIBS=
|
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= avifile
|
||||
PORTVERSION= 0.60.20010429
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://ernie.eit.uni-kl.de/avifile/ \
|
||||
http://divx.euro.ru/ \
|
||||
@ -34,9 +35,6 @@ CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
|
||||
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS= --with-win32-path=${LOCALBASE}/lib/win32 \
|
||||
--enable-release --with-gnu-ld
|
||||
.if defined(WITH_MGA)
|
||||
CONFIGURE_ARGS+=--enable-mga
|
||||
.endif
|
||||
|
||||
PLIST_SUB= LIB_VERSION="${LIB_VERSION}"
|
||||
|
||||
@ -59,10 +57,11 @@ DIFF?= /usr/bin/diff
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
pre-extract:
|
||||
.if !defined(WITH_MGA)
|
||||
@${ECHO_MSG} "You can enable special MGA support by building with -DWITH_MGA."
|
||||
.endif
|
||||
|
||||
@if [ -f ${LOCALBASE}/lib/libpth.so ]; then \
|
||||
${ECHO_MSG} "Error: This packet does not compile when the \
|
||||
packet 'pth' is installed.";\
|
||||
${FALSE};\
|
||||
fi
|
||||
do-configure:
|
||||
(cd ${WRKSRC} && aclocal && ./autogen.sh &&\
|
||||
${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS})
|
||||
|
10
multimedia/avifile/files/patch-Makefile-libwin32Makefile
Normal file
10
multimedia/avifile/files/patch-Makefile-libwin32Makefile
Normal file
@ -0,0 +1,10 @@
|
||||
--- plugins/libwin32/Makefile.am.orig Wed Jun 6 00:03:19 2001
|
||||
+++ plugins/libwin32/Makefile.am Wed Jun 6 00:03:37 2001
|
||||
@@ -12,6 +12,6 @@
|
||||
|
||||
libwin32_la_LDFLAGS = -module -version-info 0:0:0
|
||||
|
||||
-CPPFLAGS = @CPPFLAGS@ -Iloader -Iloader/wine -Ivideocodec -Iaudiodec -IDirectShow
|
||||
+CPPFLAGS = -Iloader -Iloader/wine -Ivideocodec -Iaudiodec -IDirectShow @CPPFLAGS@
|
||||
|
||||
LIBS = @AVILIBDEPLIB@
|
@ -7,5 +7,3 @@
|
||||
-#include <SDL/SDL_keysym.h>
|
||||
+#include <SDL11/SDL_keysym.h>
|
||||
#endif
|
||||
|
||||
|
||||
|
10
multimedia/avifile/files/patch-videocodecMakefile
Normal file
10
multimedia/avifile/files/patch-videocodecMakefile
Normal file
@ -0,0 +1,10 @@
|
||||
--- plugins/libwin32/videocodec/Makefile.am.orig Mon Jun 4 20:47:34 2001
|
||||
+++ plugins/libwin32/videocodec/Makefile.am Mon Jun 4 20:47:52 2001
|
||||
@@ -5,6 +5,6 @@
|
||||
libvideocodec_la_SOURCES=DS_VideoDecoder.cpp VideoEncoder.cpp \
|
||||
VideoDecoder.cpp Module.cpp VideoCodec.cpp
|
||||
|
||||
-CPPFLAGS = @CPPFLAGS@ -I../loader -I../DirectShow
|
||||
+CPPFLAGS = -I../loader -I../DirectShow @CPPFLAGS@
|
||||
|
||||
LIBS=
|
Loading…
Reference in New Issue
Block a user